summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mailx-support/ChangeLog9
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r1.ebuild13
2 files changed, 17 insertions, 5 deletions
diff --git a/mail-client/mailx-support/ChangeLog b/mail-client/mailx-support/ChangeLog
index c7ad3b63aa2c..5d8ca6e33767 100644
--- a/mail-client/mailx-support/ChangeLog
+++ b/mail-client/mailx-support/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/mailx-support
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/ChangeLog,v 1.20 2009/07/27 19:27:06 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/ChangeLog,v 1.21 2010/06/14 20:01:21 darkside Exp $
+
+ 14 Jun 2010; Jeremy Olexa <darkside@gentoo.org>
+ mailx-support-20060102-r1.ebuild:
+ Add Gentoo Prefix keywords, allow unprivileged install if using a Gentoo
+ Prefix profile. Approved by dertobi123 of the net-mail team
27 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
mailx-support-20060102-r1.ebuild:
diff --git a/mail-client/mailx-support/mailx-support-20060102-r1.ebuild b/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
index 03a46af6f47f..e701f18a2329 100644
--- a/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
+++ b/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/mailx-support-20060102-r1.ebuild,v 1.13 2009/07/27 19:27:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/mailx-support-20060102-r1.ebuild,v 1.14 2010/06/14 20:01:21 darkside Exp $
inherit eutils toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
RDEPEND=""
@@ -20,6 +20,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-respect-ldflags.patch
+
+ # This code should only be ran with Gentoo Prefix profiles
+ if use prefix; then
+ ebegin "Allowing unprivileged install"
+ sed -i -e "s|-g 0 -o 0||g" Makefile
+ eend $?
+ fi
}
src_compile() {