summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gnofract4d/gnofract4d-3.9.ebuild')
-rw-r--r--media-gfx/gnofract4d/gnofract4d-3.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/gnofract4d/gnofract4d-3.9.ebuild b/media-gfx/gnofract4d/gnofract4d-3.9.ebuild
new file mode 100644
index 000000000000..8db5c1bfba04
--- /dev/null
+++ b/media-gfx/gnofract4d/gnofract4d-3.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnofract4d/gnofract4d-3.9.ebuild,v 1.1 2008/08/25 16:50:57 maekke Exp $
+
+inherit distutils fdo-mime multilib python
+
+DESCRIPTION="a program for drawing beautiful mathematically-based images known as fractals."
+HOMEPAGE="http://gnofract4d.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ media-libs/libpng
+ media-libs/jpeg
+ dev-python/pygtk
+ gnome-base/gconf"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_install() {
+ distutils_src_install
+ rm -rf "${D}"/usr/share/doc/${PN}
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/fract*
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}