summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild')
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild
index 63f867b51afc..7a1c03b9a1f7 100644
--- a/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild,v 1.6 2006/11/23 19:51:53 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.4.2-r1.ebuild,v 1.7 2006/11/29 21:25:16 cedk Exp $
-inherit eutils
+WANT_AUTOCONF=2.58
+WANT_AUTOMAKE=1.8
+
+inherit eutils autotools
DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
HOMEPAGE="http://www.nagios.org/"
@@ -44,26 +47,32 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ cd "${S}"
if ! use radius; then
- EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/nagios-plugins-1.4-noradius.patch
+ EPATCH_OPTS="-p0 -d ${S}" epatch ${FILESDIR}/nagios-plugins-1.4-noradius.patch \
+ "${FILESDIR}"/nagios-plugins-1.4-autoconf-fix.patch
fi
if ! use radius; then
- export WANT_AUTOCONF=2.5
- export WANT_AUTMAKE=1.8
- cd ${S}
- aclocal -I m4 || die "Failed to run aclocal"
- autoconf || die "Failed to run autoconf"
- automake || die "Failed to run automake"
+ eaclocal -I m4 || die "eaclocal failed"
+ eautoconf || die "eautoconf failed"
+ automake || die "automake failed"
fi
}
src_compile() {
+ local conf
+ if use ssl; then
+ conf="${conf} --with-openssl=/usr"
+ else
+ conf="${conf} --without-openssl"
+ fi
+
econf \
$(use_with mysql) \
$(use_with postgres) \
- $(use_with ssl openssl) \
$(use_with ipv6) \
+ ${conf} \
--host=${CHOST} \
--prefix=/usr/nagios \
--with-nagios-user=nagios \