summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/files/digest-getmail-4.6.63
-rw-r--r--net-mail/getmail/getmail-4.6.6.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 6b5bdb7dd75f..0b951462cba1 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.134 2006/11/01 04:04:28 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.135 2006/12/12 16:43:55 ticho Exp $
+
+*getmail-4.6.6 (12 Dec 2006)
+
+ 12 Dec 2006; Andrej Kacian <ticho@gentoo.org> +getmail-4.6.6.ebuild:
+ Version bump.
01 Nov 2006; Steve Dibb <beandog@gentoo.org> getmail-4.6.2.ebuild:
amd64 stable, wrt bug #143980
diff --git a/net-mail/getmail/files/digest-getmail-4.6.6 b/net-mail/getmail/files/digest-getmail-4.6.6
new file mode 100644
index 000000000000..ea4ede377310
--- /dev/null
+++ b/net-mail/getmail/files/digest-getmail-4.6.6
@@ -0,0 +1,3 @@
+MD5 b126f7491e321afbf7e465070dd2f863 getmail-4.6.6.tar.gz 143796
+RMD160 dd053dac4b19caf38cb1a77625bdb13feb0eb65d getmail-4.6.6.tar.gz 143796
+SHA256 29b25539e165694fd0bb8f6a1b92537356f6fa77b6d1dbc49bc2346b22039339 getmail-4.6.6.tar.gz 143796
diff --git a/net-mail/getmail/getmail-4.6.6.ebuild b/net-mail/getmail/getmail-4.6.6.ebuild
new file mode 100644
index 000000000000..5ccb31c77bf1
--- /dev/null
+++ b/net-mail/getmail/getmail-4.6.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.6.6.ebuild,v 1.1 2006/12/12 16:43:55 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv ${D}/usr/bin/getmail ${D}/usr/bin/getmail4
+ mv ${D}/usr/bin/getmail_maildir ${D}/usr/bin/getmail_maildir4
+ mv ${D}/usr/bin/getmail_mbox ${D}/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ if [ ${P} != ${PF} ]; then
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/*.html ${D}/usr/share/doc/${PF}/*.css ${D}/usr/share/doc/${PF}/html
+ gzip --silent ${D}/usr/share/doc/${PF}/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}