summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openswan/files/openswan-2.6.21-gentoo.patch')
-rw-r--r--net-misc/openswan/files/openswan-2.6.21-gentoo.patch134
1 files changed, 134 insertions, 0 deletions
diff --git a/net-misc/openswan/files/openswan-2.6.21-gentoo.patch b/net-misc/openswan/files/openswan-2.6.21-gentoo.patch
new file mode 100644
index 000000000000..a6aa25caee10
--- /dev/null
+++ b/net-misc/openswan/files/openswan-2.6.21-gentoo.patch
@@ -0,0 +1,134 @@
+diff -Nru openswan-2.6.21.orig/lib/libdns/Makefile openswan-2.6.21/lib/libdns/Makefile
+--- openswan-2.6.21.orig/lib/libdns/Makefile 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/lib/libdns/Makefile 2009-04-08 23:23:13.000000000 +0000
+@@ -30,8 +30,8 @@
+ -I${srcdir}../libisc/nothreads/include \
+ -I. -I./include -I${srcdir}include \
+ -I${srcdir}../libisc/include
+-CDEFINES = -g ${USERCOMPILE} ${PORTINCLUDE}
+-CWARNINGS = -Werror
++CDEFINES = ${USERCOMPILE} ${PORTINCLUDE}
++CWARNINGS =
+
+ CFLAGS+=${CINCLUDES} ${CDEFINES} ${CWARNINGS}
+
+diff -Nru openswan-2.6.21.orig/lib/libisc/Makefile openswan-2.6.21/lib/libisc/Makefile
+--- openswan-2.6.21.orig/lib/libisc/Makefile 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/lib/libisc/Makefile 2009-04-08 23:23:01.000000000 +0000
+@@ -22,8 +22,8 @@
+ -I${srcdir}nothreads/include \
+ -I. -I./include -I${srcdir}include \
+ $(PORTINCLUDE) -I${OPENSWANSRCDIR}/include
+-CDEFINES = -g -DHAVE_STRERROR ${USERCOMPILE} ${PORTINCLUDE}
+-# CWARNINGS = -Werror
++CDEFINES = -DHAVE_STRERROR ${USERCOMPILE} ${PORTINCLUDE}
++# CWARNINGS =
+
+ CFLAGS+=${CINCLUDES} ${CDEFINES} ${CWARNINGS}
+
+diff -Nru openswan-2.6.21.orig/lib/liblwres/Makefile openswan-2.6.21/lib/liblwres/Makefile
+--- openswan-2.6.21.orig/lib/liblwres/Makefile 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/lib/liblwres/Makefile 2009-04-08 23:22:53.000000000 +0000
+@@ -22,8 +22,8 @@
+ -I${srcdir}../libisc/${ISCARCH}/include \
+ -I${srcdir}../libisc/include \
+ -I. -I./include -I${srcdir}include
+-CDEFINES = -g
+-CWARNINGS = -Werror
++CDEFINES =
++CWARNINGS =
+
+ CFLAGS+=${USERCOMPILE} ${PORTINCLUDE} ${CINCLUDES} ${CDEFINES} ${CWARNINGS}
+
+diff -Nru openswan-2.6.21.orig/Makefile.inc openswan-2.6.21/Makefile.inc
+--- openswan-2.6.21.orig/Makefile.inc 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/Makefile.inc 2009-04-08 23:21:42.000000000 +0000
+@@ -49,7 +49,7 @@
+ DESTDIR?=
+
+ # "local" part of tree, used in building other pathnames
+-INC_USRLOCAL=/usr/local
++INC_USRLOCAL?=/usr
+
+ # PUBDIR is where the "ipsec" command goes; beware, many things define PATH
+ # settings which are assumed to include it (or at least, to include *some*
+@@ -94,7 +94,7 @@
+
+ # sample configuration files go into
+ INC_DOCDIR?=share/doc
+-FINALEXAMPLECONFDIR=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
++FINALEXAMPLECONFDIR?=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
+ EXAMPLECONFDIR=${DESTDIR}${FINALEXAMPLECONFDIR}
+
+ FINALDOCDIR?=${INC_USRLOCAL}/${INC_DOCDIR}/openswan
+diff -Nru openswan-2.6.21.orig/programs/Makefile.program openswan-2.6.21/programs/Makefile.program
+--- openswan-2.6.21.orig/programs/Makefile.program 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/programs/Makefile.program 2009-04-08 23:23:28.000000000 +0000
+@@ -53,7 +53,6 @@
+ WERROR:= -Werror
+ endif
+
+-CFLAGS+= ${WERROR}
+
+ ifneq ($(LD_LIBRARY_PATH),)
+ LDFLAGS=-L$(LD_LIBRARY_PATH)
+diff -Nru openswan-2.6.21.orig/programs/setup/Makefile openswan-2.6.21/programs/setup/Makefile
+--- openswan-2.6.21.orig/programs/setup/Makefile 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/programs/setup/Makefile 2009-04-08 23:21:42.000000000 +0000
+@@ -18,7 +18,6 @@
+
+ # this dance is because setup has to get installed as /etc/rc.d/init.d/ipsec
+ # not as /etc/rc.d/init.d/setup.
+-PROGRAMDIR=$(RCDIR)
+ PROGRAM=setup
+ EXTRA8MAN=setup.8
+
+@@ -29,32 +28,6 @@
+ # into the $BINDIR.
+ #
+ # the priorities match those in setup's chkconfig line
+-doinstall:: setup
+- @rm -f $(BINDIR)/setup
+- @$(INSTALL) $(INSTBINFLAGS) setup $(RCDIR)/ipsec
+- @ln -s $(FINALRCDIR)/ipsec $(BINDIR)/setup
+- -@for i in 0 1 2 3 4 5 6; do mkdir -p $(RCDIR)/../rc$$i.d; done
+- -@cd $(RCDIR)/../rc0.d && ln -f -s ../init.d/ipsec K76ipsec
+- -@cd $(RCDIR)/../rc1.d && ln -f -s ../init.d/ipsec K76ipsec
+- -@cd $(RCDIR)/../rc2.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc3.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc4.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc5.d && ln -f -s ../init.d/ipsec S47ipsec
+- -@cd $(RCDIR)/../rc6.d && ln -f -s ../init.d/ipsec K76ipsec
+-
+-install_file_list::
+- @echo $(RCDIR)/ipsec
+- @echo $(BINDIR)/setup
+- @echo $(RCDIR)/../rc0.d/K76ipsec
+- @echo $(RCDIR)/../rc1.d/K76ipsec
+- @echo $(RCDIR)/../rc2.d/S47ipsec
+- @echo $(RCDIR)/../rc3.d/S47ipsec
+- @echo $(RCDIR)/../rc4.d/S47ipsec
+- @echo $(RCDIR)/../rc5.d/S47ipsec
+- @echo $(RCDIR)/../rc6.d/K76ipsec
+-
+-cleanall::
+- @rm -f setup
+
+ #
+ # $Log: openswan-2.6.21-gentoo.patch,v $
+ # Revision 1.1 2009/04/08 23:30:45 mrness
+ # Version bumps wrt to security bug #264346. Remove -Werror from compiler options (#260927).
+ # (Portage version: 2.1.6.7/cvs/Linux x86_64)
+ #
+diff -Nru openswan-2.6.21.orig/testing/utils/make-uml.sh openswan-2.6.21/testing/utils/make-uml.sh
+--- openswan-2.6.21.orig/testing/utils/make-uml.sh 2009-03-30 13:11:28.000000000 +0000
++++ openswan-2.6.21/testing/utils/make-uml.sh 2009-04-08 23:23:48.000000000 +0000
+@@ -262,7 +262,7 @@
+
+ cd $OPENSWANSRCDIR || exit 1
+
+-make WERROR=-Werror USE_OBJDIR=true programs
++make USE_OBJDIR=true programs
+
+ # now, execute the Makefile that we have created!
+ cd $POOLSPACE && make $OPENSWANHOSTS