summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/files/digest-rsync-2.6.31
-rw-r--r--net-misc/rsync/rsync-2.6.3.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/net-misc/rsync/files/digest-rsync-2.6.3 b/net-misc/rsync/files/digest-rsync-2.6.3
deleted file mode 100644
index 109ffecb3c12..000000000000
--- a/net-misc/rsync/files/digest-rsync-2.6.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2beb30caafa69a01182e71c528fb0393 rsync-2.6.3.tar.gz 583453
diff --git a/net-misc/rsync/rsync-2.6.3.ebuild b/net-misc/rsync/rsync-2.6.3.ebuild
deleted file mode 100644
index 68165c2b7e4f..000000000000
--- a/net-misc/rsync/rsync-2.6.3.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.3.ebuild,v 1.10 2005/01/19 23:25:59 vapier Exp $
-
-inherit eutils flag-o-matic gcc gnuconfig
-
-DESCRIPTION="File transfer program to keep remote files into sync"
-HOMEPAGE="http://rsync.samba.org/"
-SRC_URI="http://rsync.samba.org/ftp/rsync/${P/_/}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="build static acl ipv6"
-
-RDEPEND="virtual/libc
- !build? ( >=dev-libs/popt-1.5 )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- acl? ( sys-apps/acl )"
-
-S="${WORKDIR}/${P/_/}"
-
-src_unpack() {
- unpack "${P/_/}.tar.gz"
- cd ${S}
- if use acl ; then
- epatch patches/acl.diff
- autoconf || die "autoconf"
- autoheader || die "autoheader"
- fi
- gnuconfig_update
-
- # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
- # yes, updating the man page is very important.
- sed -i \
- -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' \
- rsync.1 rsyncd.conf.5 \
- || die "sed rsyncd.conf.5 failed"
-}
-
-src_compile() {
- [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
- use static && append-ldflags -static
-
- econf \
- $(use_with build included-popt) \
- $(use_with acl acl-support) \
- $(use_enable ipv6) \
- --with-rsyncd-conf=/etc/rsync/rsyncd.conf \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
- exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
- if ! use build ; then
- dodir /etc/rsync
- dodoc NEWS OLDNEWS README TODO tech_report.tex
- if [ ! -e /etc/rsync/rsyncd.conf ] ; then
- insinto /etc/rsync
- doins "${FILESDIR}/rsyncd.conf"
- fi
- else
- rm -rf "${D}/usr/share"
- fi
-}
-
-pkg_postinst() {
- ewarn "Please make sure you do NOT disable the rsync server running"
- ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
- ewarn "it says: use chroot = yes"
-}