summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sslwrap/sslwrap-2.0.6.ebuild')
-rw-r--r--net-misc/sslwrap/sslwrap-2.0.6.ebuild27
1 files changed, 16 insertions, 11 deletions
diff --git a/net-misc/sslwrap/sslwrap-2.0.6.ebuild b/net-misc/sslwrap/sslwrap-2.0.6.ebuild
index 5f9ba167c80a..81468909d1dd 100644
--- a/net-misc/sslwrap/sslwrap-2.0.6.ebuild
+++ b/net-misc/sslwrap/sslwrap-2.0.6.ebuild
@@ -1,28 +1,33 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sslwrap/sslwrap-2.0.6.ebuild,v 1.4 2002/12/09 04:33:19 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sslwrap/sslwrap-2.0.6.ebuild,v 1.5 2003/02/10 10:32:00 seemant Exp $
S=${WORKDIR}/${PN}${PV/.0./0}
DESCRIPTION="TSL/SSL - Port Wrapper"
-SRC_URI="http://quiltaholic.com/rickk/sslwrap/${PN}${PV/.0./0}.tar.gz"
+SRC_URI="http://quiltaholic.com/rickk/sslwrap/${PN}${PV/.0./0}.tar.gz
+ mirror://gentoo/${PN}-gentoo.tar.bz2
+ http://cvs.gentoo.org/~seemant/${PN}-gentoo.tar.bz2"
HOMEPAGE="http://quiltaholic.com/rickk/sslwrap/"
-KEYWORDS="x86 sparc "
-LICENSE="sslwrap"
+
SLOT="0"
+LICENSE="sslwrap"
+KEYWORDS="x86 sparc"
-DEPEND=">=sys-libs/glibc-2.1.3
- >=dev-libs/openssl-0.9.6"
+DEPEND=">=dev-libs/openssl-0.9.6"
src_unpack () {
unpack ${A}
cd ${S}
cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" \
- -e "s:/usr/local/ssl/include:/usr/include/openssl:" Makefile.orig > Makefile
- cp ${FILESDIR}/*.c ${S}
+ sed -e "s:-O2:${CFLAGS}:" \
+ -e "s:/usr/local/ssl/include:/usr/include/openssl:" \
+ Makefile.orig > Makefile
+
+ cp ${WORKDIR}/${PN}-gentoo/*.c ${S}
+
for f in *.h *.c ; do
cp ${f} ${f}.orig
- sed -e "s/OPENSSL\"/\"openssl\//g" ${f}.orig > ${f}
+ sed -e "s:OPENSSL\":\"openssl\/:g" ${f}.orig > ${f}
done
}