summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/ww/ww-2.26.ebuild')
-rw-r--r--net-p2p/ww/ww-2.26.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-p2p/ww/ww-2.26.ebuild b/net-p2p/ww/ww-2.26.ebuild
index 716352c21b65..33981c1112c1 100644
--- a/net-p2p/ww/ww-2.26.ebuild
+++ b/net-p2p/ww/ww-2.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ww/ww-2.26.ebuild,v 1.1 2004/10/05 17:20:06 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ww/ww-2.26.ebuild,v 1.2 2004/10/05 17:23:24 squinky86 Exp $
DESCRIPTION="White Water allows people to publish files for download by thousands of people without saturating their bandwidth."
HOMEPAGE="http://ww.walrond.org"
@@ -11,9 +11,13 @@ KEYWORDS="~x86"
IUSE=""
DEPEND=">=dev-libs/openssl-0.9.7"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:-O3:${CFLAGS}:g' Makefile */Makefile
+}
+
src_compile() {
- sed -e "s/-O3/${CFLAGS}/g" Makefile > Makefile.$$
- mv -f Makefile.$$ Makefile || die "moving Makefile"
make clean || die "make clean"
make deps || die "make deps"
make release || die "make release"