summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/hx/ChangeLog10
-rw-r--r--net-p2p/hx/files/digest-hx-0.4.10-r12
-rw-r--r--net-p2p/hx/files/digest-hx-0.4.113
-rw-r--r--net-p2p/hx/hx-0.4.11.ebuild40
4 files changed, 53 insertions, 2 deletions
diff --git a/net-p2p/hx/ChangeLog b/net-p2p/hx/ChangeLog
index 24f701191166..7e79e7c20b04 100644
--- a/net-p2p/hx/ChangeLog
+++ b/net-p2p/hx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/hx
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/ChangeLog,v 1.3 2005/03/13 13:03:35 kang Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/ChangeLog,v 1.4 2006/09/20 15:55:18 kang Exp $
+
+*hx-0.4.11 (20 Sep 2006)
+
+ 20 Sep 2006; Guillaume Destuynder <kang@gentoo.org> +hx-0.4.11.ebuild:
+ fixed hx building on gcc4, and removed libtermcap building dependency. bump
+ ot 0.4.11
*hx-0.4.10-r1 (13 Mar 2005)
diff --git a/net-p2p/hx/files/digest-hx-0.4.10-r1 b/net-p2p/hx/files/digest-hx-0.4.10-r1
index 33e14ac3b4b5..7a70d2230b0b 100644
--- a/net-p2p/hx/files/digest-hx-0.4.10-r1
+++ b/net-p2p/hx/files/digest-hx-0.4.10-r1
@@ -1 +1,3 @@
MD5 6b664c5f798746c5c0617c72d1c95967 mhxd-0.4.10.tar.bz2 768353
+RMD160 cea6f3758263eda33c710fe42ac1db3737a4de43 mhxd-0.4.10.tar.bz2 768353
+SHA256 15aea89d5943ea84bc68e5f8d11e2be772e244e8a2e40132704c12aafebac5db mhxd-0.4.10.tar.bz2 768353
diff --git a/net-p2p/hx/files/digest-hx-0.4.11 b/net-p2p/hx/files/digest-hx-0.4.11
new file mode 100644
index 000000000000..ead2e86ea7cb
--- /dev/null
+++ b/net-p2p/hx/files/digest-hx-0.4.11
@@ -0,0 +1,3 @@
+MD5 add3e0ff4c90aa4f2d1957a5642cde0b mhxd-0.4.11.tar.bz2 970664
+RMD160 6b9d54c9fa872771f4d90d0441d06929d58b6822 mhxd-0.4.11.tar.bz2 970664
+SHA256 54906798fd9155cf3f53c171f0d839ed1e5a329fa89e56bbcdfda4ce8dda0b91 mhxd-0.4.11.tar.bz2 970664
diff --git a/net-p2p/hx/hx-0.4.11.ebuild b/net-p2p/hx/hx-0.4.11.ebuild
new file mode 100644
index 000000000000..429dcdeb607b
--- /dev/null
+++ b/net-p2p/hx/hx-0.4.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/hx/hx-0.4.11.ebuild,v 1.1 2006/09/20 15:55:18 kang Exp $
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+MY_P=mhxd-${PV}
+
+DESCRIPTION="This is a Hotline 1.5+ compatible *nix Hotline Client in CLI. It supports IRC compatibility. See http://www.hotspringsinc.com/"
+SRC_URI="http://projects.acidbeats.de/${MY_P}.tar.bz2"
+HOMEPAGE="http://hotlinex.sf.net/"
+
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ >=sys-libs/zlib-1.1.4"
+
+SLOT="0"
+
+src_compile() {
+ cd work/${MY_P}
+ libtoolize --copy --force
+ econf \
+ `use_enable ssl idea` \
+ `use_enable ssl cipher` \
+ `use_enable ssl hope` \
+ `use_enable ssl compress` \
+ --enable-hx || die "bad configure"
+ emake || die "compile problem"
+ make install || die "compile problem"
+}
+
+src_install() {
+ cd ${PF}/work/${MY_P}
+ dodoc AUTHORS INSTALL PROBLEMS README* ChangeLog TODO NEWS run/hx/ghxvars run/hx/ghxvars.jp \
+ run/hx/hxrc run/hx/hxvars
+
+ dobin run/hx/bin/hx
+}