summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog8
-rw-r--r--net-voip/telepathy-gabble/files/digest-telepathy-gabble-0.4.43
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.4.4.ebuild35
3 files changed, 45 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 00aefaf92f40..98cd8728577d 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.4 2006/11/01 02:06:33 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.5 2006/11/08 19:23:38 peper Exp $
+
+*telepathy-gabble-0.4.4 (08 Nov 2006)
+
+ 08 Nov 2006; Piotr Jaroszyński <peper@gentoo.org>
+ -telepathy-gabble-0.4.2.ebuild, +telepathy-gabble-0.4.4.ebuild:
+ Version bump.
*telepathy-gabble-0.4.3 (01 Nov 2006)
diff --git a/net-voip/telepathy-gabble/files/digest-telepathy-gabble-0.4.4 b/net-voip/telepathy-gabble/files/digest-telepathy-gabble-0.4.4
new file mode 100644
index 000000000000..ec470d20e428
--- /dev/null
+++ b/net-voip/telepathy-gabble/files/digest-telepathy-gabble-0.4.4
@@ -0,0 +1,3 @@
+MD5 061765840fa081342751c8483b3bea23 telepathy-gabble-0.4.4.tar.gz 542376
+RMD160 58fe75ab6d05b778a37d003c8c8db60ce7829f9c telepathy-gabble-0.4.4.tar.gz 542376
+SHA256 318f60185783ad31e8fefcb1da26990a8c419b765aa0223812793e64dafe0dc8 telepathy-gabble-0.4.4.tar.gz 542376
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.4.4.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.4.4.ebuild
new file mode 100644
index 000000000000..60c402701d90
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.4.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.4.4.ebuild,v 1.1 2006/11/08 19:23:38 peper Exp $
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug loudmouth"
+
+DEPEND=">=dev-libs/glib-2.4
+ >=sys-apps/dbus-0.61
+ loudmouth? ( >=net-libs/loudmouth-1.1.1 )"
+RDEPEND="${DEPEND}"
+
+src_compile(){
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable loudmouth)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS README ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog "You don't need to start telepathy-gabble manualy any more."
+ elog "dbus will take care of that."
+}