summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/portapack-firmware/ChangeLog9
-rw-r--r--net-wireless/portapack-firmware/metadata.xml6
-rw-r--r--net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild47
3 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/portapack-firmware/ChangeLog b/net-wireless/portapack-firmware/ChangeLog
new file mode 100644
index 000000000000..e67080cba0fe
--- /dev/null
+++ b/net-wireless/portapack-firmware/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-wireless/portapack-firmware
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/portapack-firmware/ChangeLog,v 1.1 2015/07/31 19:50:13 zerochaos Exp $
+
+*portapack-firmware-20150722 (31 Jul 2015)
+
+ 31 Jul 2015; Rick Farina <zerochaos@gentoo.org> +metadata.xml,
+ +portapack-firmware-20150722.ebuild:
+ new: firmware and host scripts for the hackrf one portapack
diff --git a/net-wireless/portapack-firmware/metadata.xml b/net-wireless/portapack-firmware/metadata.xml
new file mode 100644
index 000000000000..f3b74e3d80ae
--- /dev/null
+++ b/net-wireless/portapack-firmware/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild b/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild
new file mode 100644
index 000000000000..c2c36754a1bb
--- /dev/null
+++ b/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/portapack-firmware/portapack-firmware-20150722.ebuild,v 1.1 2015/07/31 19:50:13 zerochaos Exp $
+
+EAPI=5
+
+DESCRIPTION="Firmware and scripts for controlling the Portapack from Sharebrained"
+HOMEPAGE="https://github.com/sharebrained/portapack-hackrf/releases"
+SRC_URI="https://github.com/sharebrained/portapack-hackrf/releases/download/20150722/portapack-h1-firmware-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PDEPEND=">=net-wireless/hackrf-tools-2015.07.2-r1
+ =app-mobilephone/dfu-util-0.7"
+
+src_install() {
+ insinto /usr/share/hackrf
+ newins portapack-h1-firmware.bin
+
+ cat << EOF > switch_to_portapack
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/portapack-h1-firmware.bin
+EOF
+ dobin switch_to_portapack
+ cat << EOF > switch_to_hackrf
+#!/bin/sh
+printf "Hold down the HackRF's DFU button (the button closest to the antenna jack)\n"
+printf "then plug the HackRF into a USB port on your computer.\n"
+printf "After the HackRF is plugged in, you may release the DFU button.\n"
+printf "Press any key to continue or ^c to abort\n"
+read
+dfu-util --device 1fc9:000c --download /usr/share/hackrf/hackrf_one_usb_ram.dfu --reset
+sleep 2s
+hackrf_spiflash -w /usr/share/hackrf/hackrf_one_usb_rom_to_ram.bin
+EOF
+ dobin switch_to_hackrf
+}