summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/phpBB')
-rw-r--r--net-www/phpBB/ChangeLog9
-rw-r--r--net-www/phpBB/Manifest7
-rw-r--r--net-www/phpBB/files/2.0.8-postinstall-en.txt2
-rw-r--r--net-www/phpBB/files/digest-phpBB-2.0.8a-r11
-rw-r--r--net-www/phpBB/phpBB-2.0.8a-r1.ebuild33
5 files changed, 49 insertions, 3 deletions
diff --git a/net-www/phpBB/ChangeLog b/net-www/phpBB/ChangeLog
index 56a4613e26f9..83cfb123e24e 100644
--- a/net-www/phpBB/ChangeLog
+++ b/net-www/phpBB/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/phpBB
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.12 2004/04/27 20:45:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.13 2004/05/14 22:08:29 stuart Exp $
+
+*phpBB-2.0.8a-r1 (14 May 2004)
+
+ 14 May 2004; Stuart Herbert <stuart@gentoo.org> phpBB-2.0.8a-r1.ebuild,
+ files/2.0.8-postinstall-en.txt:
+ Converted phpBB-2.0.8a to use webapp-config; by Lars Tiefland
+ <ltiefland@gate-birds-sky.org>; see bug #50969
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> phpBB-2.0.6-r1.ebuild:
Add inherit eutils
diff --git a/net-www/phpBB/Manifest b/net-www/phpBB/Manifest
index 782b0cfe0fdf..6b159afbde34 100644
--- a/net-www/phpBB/Manifest
+++ b/net-www/phpBB/Manifest
@@ -1,9 +1,12 @@
+MD5 bcb1768366d608f8511bbf0c8a44fa59 phpBB-2.0.6-r1.ebuild 1340
MD5 51ded889591e27f2b198d396e25566e4 ChangeLog 1637
MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
MD5 0329a803da692e6e047fdd0f9b1d21b5 phpBB-2.0.6-r2.ebuild 1261
-MD5 bcb1768366d608f8511bbf0c8a44fa59 phpBB-2.0.6-r1.ebuild 1340
MD5 6fc277910a0ad79e0af06ea0851866be phpBB-2.0.8a.ebuild 1258
+MD5 19fc7464bd1856a826bf1ed0df9a872e phpBB-2.0.8a-r1.ebuild 905
MD5 2bcc15b387e45c0342ace8fe007ada43 files/digest-phpBB-2.0.6-r1 64
-MD5 81edef11555fd2672d5ccc894ce8b711 files/digest-phpBB-2.0.6-r2 64
MD5 baf12ebb39a1b14b5b0bf0fa9320eba8 files/phpBB-2.0.6-security.patch 248
+MD5 81edef11555fd2672d5ccc894ce8b711 files/digest-phpBB-2.0.6-r2 64
MD5 a5490792af02884bb7bfd22efa001697 files/digest-phpBB-2.0.8a 65
+MD5 a5490792af02884bb7bfd22efa001697 files/digest-phpBB-2.0.8a-r1 65
+MD5 a2ffb1296c4ce58eee7df10b2ccaaebc files/2.0.8-postinstall-en.txt 116
diff --git a/net-www/phpBB/files/2.0.8-postinstall-en.txt b/net-www/phpBB/files/2.0.8-postinstall-en.txt
new file mode 100644
index 000000000000..8cf8278020b9
--- /dev/null
+++ b/net-www/phpBB/files/2.0.8-postinstall-en.txt
@@ -0,0 +1,2 @@
+Please use install/install.php to configure phpBB.
+After that, please delete the contribs/ and install/ directories
diff --git a/net-www/phpBB/files/digest-phpBB-2.0.8a-r1 b/net-www/phpBB/files/digest-phpBB-2.0.8a-r1
new file mode 100644
index 000000000000..76fef3c11048
--- /dev/null
+++ b/net-www/phpBB/files/digest-phpBB-2.0.8a-r1
@@ -0,0 +1 @@
+MD5 44d33a5851800f8f278d3c100fb2fcb3 phpBB-2.0.8a.tar.bz2 457308
diff --git a/net-www/phpBB/phpBB-2.0.8a-r1.ebuild b/net-www/phpBB/phpBB-2.0.8a-r1.ebuild
new file mode 100644
index 000000000000..e6e1fbded058
--- /dev/null
+++ b/net-www/phpBB/phpBB-2.0.8a-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.8a-r1.ebuild,v 1.1 2004/05/14 22:08:29 stuart Exp $
+
+inherit webapp
+
+DESCRIPTION="phpBB is an open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+RESTRICT="nomirror"
+
+RDEPEND="virtual/php"
+
+S=${WORKDIR}/${PN}2
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc ${S}/docs/*
+ rm -rf ${S}/docs/
+
+ cp -a * "${D}/${MY_HTDOCSDIR}"
+
+ echo "<?php trigger_error('Please use install/install.php to configure phpBB for your system!', E_USER_ERROR); ?>" > "${D}/${MY_HTDOCSDIR}/config.php"
+ webapp_serverowned "${MY_HTDOCSDIR}/config.php"
+
+ webapp_postinst_txt en ${FILESDIR}/2.0.8-postinstall-en.txt
+
+ webapp_src_install
+}