summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zc-recipe-egg')
-rw-r--r--net-zope/zc-recipe-egg/ChangeLog10
-rw-r--r--net-zope/zc-recipe-egg/metadata.xml5
-rw-r--r--net-zope/zc-recipe-egg/zc-recipe-egg-1.3.2.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/net-zope/zc-recipe-egg/ChangeLog b/net-zope/zc-recipe-egg/ChangeLog
new file mode 100644
index 000000000000..536b2441b8cf
--- /dev/null
+++ b/net-zope/zc-recipe-egg/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zc-recipe-egg
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zc-recipe-egg/ChangeLog,v 1.1 2010/11/02 07:12:43 arfrever Exp $
+
+*zc-recipe-egg-1.3.2 (02 Nov 2010)
+
+ 02 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zc-recipe-egg-1.3.2.ebuild, +metadata.xml:
+ Initial import from python overlay.
+
diff --git a/net-zope/zc-recipe-egg/metadata.xml b/net-zope/zc-recipe-egg/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/zc-recipe-egg/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/zc-recipe-egg/zc-recipe-egg-1.3.2.ebuild b/net-zope/zc-recipe-egg/zc-recipe-egg-1.3.2.ebuild
new file mode 100644
index 000000000000..b7ff61d32856
--- /dev/null
+++ b/net-zope/zc-recipe-egg/zc-recipe-egg-1.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zc-recipe-egg/zc-recipe-egg-1.3.2.ebuild,v 1.1 2010/11/02 07:12:43 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Recipe for installing Python package distributions as eggs"
+HOMEPAGE="http://pypi.python.org/pypi/zc.recipe.egg"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ >=net-zope/zc-buildout-1.5.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt src/zc/recipe/egg/*.txt"
+PYTHON_MODNAME="${PN//-//}"