summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/relax/ChangeLog8
-rw-r--r--sci-chemistry/relax/files/relax-3.1.0-sample-script.patch25
-rw-r--r--sci-chemistry/relax/relax-3.1.0.ebuild69
3 files changed, 101 insertions, 1 deletions
diff --git a/sci-chemistry/relax/ChangeLog b/sci-chemistry/relax/ChangeLog
index b20fb1f59e4f..2fd134f6d94d 100644
--- a/sci-chemistry/relax/ChangeLog
+++ b/sci-chemistry/relax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/relax
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.10 2013/11/27 11:27:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/ChangeLog,v 1.11 2013/11/29 08:38:42 jlec Exp $
+
+*relax-3.1.0 (29 Nov 2013)
+
+ 29 Nov 2013; Justin Lecher <jlec@gentoo.org> +relax-3.1.0.ebuild,
+ +files/relax-3.1.0-sample-script.patch:
+ Version BUmp
*relax-3.0.2-r2 (27 Nov 2013)
diff --git a/sci-chemistry/relax/files/relax-3.1.0-sample-script.patch b/sci-chemistry/relax/files/relax-3.1.0-sample-script.patch
new file mode 100644
index 000000000000..c1eefd2cb736
--- /dev/null
+++ b/sci-chemistry/relax/files/relax-3.1.0-sample-script.patch
@@ -0,0 +1,25 @@
+ sample_scripts/relax_disp/R1rho_analysis.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/sample_scripts/relax_disp/R1rho_analysis.py b/sample_scripts/relax_disp/R1rho_analysis.py
+index 1dcbf68..11d6f97 100644
+--- a/sample_scripts/relax_disp/R1rho_analysis.py
++++ b/sample_scripts/relax_disp/R1rho_analysis.py
+@@ -77,7 +77,7 @@ spin.isotope(isotope='15N')
+
+ # The spectral data - spectrum ID, peak list file name, spin-lock field strength (Hz), the spin-lock offset (ppm), the relaxation time (s), spectrometer frequency (Hz), and experimental error (RMSD of the base plane noise for each spectrum).
+ data = [
+- ['ref_500MHz', 'ref_500MHz.list', , None, 110.0, 0.1, 500e6, 200000.0]
++ ['ref_500MHz', 'ref_500MHz.list', None, 110.0, 0.1, 500e6, 200000.0]
+ ['nu_1000.0_500MHz', 'nu_1000.0_500MHz.list', 1000.0, 110.0, 0.1, 500e6, 200000.0]
+ ['nu_1500.0_500MHz', 'nu_1500.0_500MHz.list', 1500.0, 110.0, 0.1, 500e6, 200000.0]
+ ['nu_2000.0_500MHz', 'nu_2000.0_500MHz.list', 2000.0, 110.0, 0.1, 500e6, 200000.0]
+@@ -89,7 +89,7 @@ data = [
+ ['nu_5000.0_500MHz', 'nu_5000.0_500MHz.list', 5000.0, 110.0, 0.1, 500e6, 200000.0]
+ ['nu_5500.0_500MHz', 'nu_5500.0_500MHz.list', 5500.0, 110.0, 0.1, 500e6, 200000.0]
+ ['nu_6000.0_500MHz', 'nu_6000.0_500MHz.list', 6000.0, 110.0, 0.1, 500e6, 200000.0]
+- ['ref_800MHz', 'ref_800MHz.list', , None, 110.0, 0.1, 800e6, 200000.0]
++ ['ref_800MHz', 'ref_800MHz.list', None, 110.0, 0.1, 800e6, 200000.0]
+ ['nu_1000.0_800MHz', 'nu_1000.0_800MHz.list', 1000.0, 110.0, 0.1, 800e6, 200000.0]
+ ['nu_1500.0_800MHz', 'nu_1500.0_800MHz.list', 1500.0, 110.0, 0.1, 800e6, 200000.0]
+ ['nu_2000.0_800MHz', 'nu_2000.0_800MHz.list', 2000.0, 110.0, 0.1, 800e6, 200000.0]
diff --git a/sci-chemistry/relax/relax-3.1.0.ebuild b/sci-chemistry/relax/relax-3.1.0.ebuild
new file mode 100644
index 000000000000..f8dde3d0958c
--- /dev/null
+++ b/sci-chemistry/relax/relax-3.1.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/relax/relax-3.1.0.ebuild,v 1.1 2013/11/29 08:38:42 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+WX_GTK_VER="2.9"
+
+inherit eutils python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
+
+DESCRIPTION="Molecular dynamics by NMR data analysis"
+HOMEPAGE="http://www.nmr-relax.com/"
+SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
+ sci-chemistry/molmol
+ sci-chemistry/pymol[${PYTHON_USEDEP}]
+ sci-chemistry/vmd
+ >=sci-libs/bmrblib-1.0.1_pre198[${PYTHON_USEDEP}]
+ >=sci-libs/minfx-1.0.4_pre98[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-visualization/grace
+ sci-visualization/opendx
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ rm -rf minfx bmrblib || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.1-gentoo.patch \
+ "${FILESDIR}"/${P}-sample-script.patch
+ tc-export CC
+}
+
+src_compile() {
+ escons
+}
+
+src_test() {
+ VIRTUALX_COMMAND="${EPYTHON}"
+ virtualmake ./${PN}.py -x || die
+}
+
+src_install() {
+ dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf,prompt_screenshot.txt}
+
+ python_moduleinto ${PN}
+ python_domodule *
+
+ rm ${PN} README || die
+
+ make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
+}