summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gtkwave/gtkwave-3.3.42.ebuild')
-rw-r--r--sci-electronics/gtkwave/gtkwave-3.3.42.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/sci-electronics/gtkwave/gtkwave-3.3.42.ebuild b/sci-electronics/gtkwave/gtkwave-3.3.42.ebuild
index a65e73813839..b10d669d3ef6 100644
--- a/sci-electronics/gtkwave/gtkwave-3.3.42.ebuild
+++ b/sci-electronics/gtkwave/gtkwave-3.3.42.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gtkwave/gtkwave-3.3.42.ebuild,v 1.1 2013/01/21 10:23:06 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gtkwave/gtkwave-3.3.42.ebuild,v 1.2 2013/01/26 20:30:58 tomjbe Exp $
EAPI="4"
-inherit fdo-mime
+inherit autotools eutils fdo-mime toolchain-funcs
DESCRIPTION="A wave viewer for LXT, LXT2, VZT, GHW and standard Verilog VCD/EVCD files"
HOMEPAGE="http://gtkwave.sourceforge.net/"
@@ -27,9 +27,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
dev-util/gperf"
+AT_M4DIR="${S}"
+
src_prepare(){
# do not install doc and examples by default
sed -i -e 's/doc examples//' Makefile.in || die
+
+ # fix parallel make
+ epatch "${FILESDIR}"/${PN}-parallel-make.diff
+
+ eautoreconf
}
src_configure(){
@@ -45,6 +52,10 @@ src_configure(){
$(use_enable judy)
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
emake DESTDIR="${D}" install
dodoc ANALOG_README.TXT SYSTEMVERILOG_README.TXT CHANGELOG.TXT