summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/gawk/files')
-rw-r--r--sys-apps/gawk/files/filefuncs/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-apps/gawk/files/filefuncs/Makefile b/sys-apps/gawk/files/filefuncs/Makefile
index 785b481500de..c3d99de9328e 100644
--- a/sys-apps/gawk/files/filefuncs/Makefile
+++ b/sys-apps/gawk/files/filefuncs/Makefile
@@ -1,7 +1,7 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.5 2005/01/14 13:25:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/files/filefuncs/Makefile,v 1.6 2005/05/14 17:56:03 vapier Exp $
CC ?= gcc
LD = $(CC)
@@ -12,24 +12,24 @@ MINORVER = 0.1
AWKINCDIR = /usr/include/awk
DESTDIR =
-TARGET = filefuncs.so.$(MAJORVER).$(MINORVER)
+TARGET = filefuncs
+TARGET_LIB = $(TARGET).so.$(MAJORVER).$(MINORVER)
LIBDIR = lib
-all: $(TARGET)
+all: $(TARGET_LIB)
-filefuncs.o: filefuncs.c
+$(TARGET).o: $(TARGET).c
$(CC) -shared -Wall -DHAVE_CONFIG_H -c -O2 -fPIC -I$(AWKINCDIR) $^
-filefuncs.so.$(MAJORVER).$(MINORVER): filefuncs.o
- $(LD) -o $@ -shared -Wl,-soname -Wl,filefuncs.so.$(MAJORVER) $^
+$(TARGET_LIB): $(TARGET).o
+ $(LD) -o $@ -shared -Wl,-soname -Wl,$(TARGET).so.$(MAJORVER) $^
-install: $(TARGET)
+install: $(TARGET_LIB)
install -m 0755 -d $(DESTDIR)/$(LIBDIR)/rcscripts
- install -m 0755 $(TARGET) $(DESTDIR)/$(LIBDIR)/rcscripts
- ldconfig -l $(DESTDIR)/$(LIBDIR)/rcscripts/$(TARGET)
- rm -f $(DESTDIR)/$(LIBDIR)/rcscripts/filefuncs.so
- ln -s $(TARGET) $(DESTDIR)/$(LIBDIR)/rcscripts/filefuncs.so
+ install -m 0755 $(TARGET_LIB) $(DESTDIR)/$(LIBDIR)/rcscripts
+ ln -s $(TARGET_LIB) $(DESTDIR)/$(LIBDIR)/rcscripts/$(TARGET).so.$(MAJORVER)
+ ln -s $(TARGET_LIB) $(DESTDIR)/$(LIBDIR)/rcscripts/$(TARGET).so
clean:
rm -f $(TARGET)