summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog7
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.4.00
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.4.0723
-rw-r--r--sys-devel/gcc-config/files/wrapper-1.5.0.c377
-rw-r--r--sys-devel/gcc-config/gcc-config-1.4.0.ebuild52
5 files changed, 1158 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index dad9d5c51a77..8a5ee670a5e8 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.154 2007/05/03 03:30:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.155 2007/05/03 05:20:39 vapier Exp $
+
+ 03 May 2007; Mike Frysinger <vapier@gentoo.org> +files/gcc-config-1.4.0,
+ +files/wrapper-1.5.0.c, +gcc-config-1.4.0.ebuild:
+ Move to GCC_PATH #174422 and make sure LDPATH is not re-ordered on us all
+ the time #168884.
03 May 2007; Jeroen Roovers <jer@gentoo.org> gcc-config-1.3.16.ebuild:
Stable for HPPA (bug #176869).
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.4.0 b/sys-devel/gcc-config/files/digest-gcc-config-1.4.0
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.4.0
diff --git a/sys-devel/gcc-config/files/gcc-config-1.4.0 b/sys-devel/gcc-config/files/gcc-config-1.4.0
new file mode 100755
index 000000000000..71357ae8b88d
--- /dev/null
+++ b/sys-devel/gcc-config/files/gcc-config-1.4.0
@@ -0,0 +1,723 @@
+#!/bin/bash
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.4.0,v 1.15 2007/05/03 05:20:39 vapier Exp $
+
+trap ":" INT QUIT TSTP
+
+argv0=${0##*/}
+source /etc/init.d/functions.sh || {
+ echo "${argv0}: Could not source /etc/init.d/functions.sh!"
+ exit 1
+}
+umask 022
+
+usage() {
+cat << "USAGE_END"
+Usage: gcc-config [options] [CC Profile]
+Change the current cc/gcc profile, or give info about profiles.
+
+Options:
+ -O, --use-old Use the old profile if one was selected.
+ -f, --force Make sure all config files are regenerated.
+ -P, --use-portage-chost Only set to given profile if its CHOST is the
+ same as that set for portage in /etc/make.conf
+ (or one of other portage config files...).
+ -c, --get-current-profile Print current used gcc profile.
+ -l, --list-profiles Print a list of available profiles.
+ -S, --split-profile Split profiles into their components
+ -E, --print-environ Print environment that can be used to setup the
+ current gcc profile, or a specified one.
+ -B, --get-bin-path Print path where binaries of the given/current
+ profile are located.
+ -L, --get-lib-path Print path where libraries of the given/current
+ profile are located.
+ -X, --get-stdcxx-incdir Print path where g++ include files of the
+ given/current profile are located.
+
+Profile names are of the form: <CHOST>-<gcc version>
+For example: i686-pc-linux-gnu-3.2.1
+USAGE_END
+ exit $1
+}
+[[ $# -lt 1 ]] && usage 1
+
+try_real_hard_to_find_CHOST() {
+ #
+ # First we read make.conf
+ #
+
+ local varname=$1
+ local conf=${ROOT}/etc/make.conf
+ local ret=$(source "${conf}" 2>/dev/null ; echo ${!varname})
+ if [[ -z ${ret} ]] ; then
+ # newer portage supports spaces between the var and =
+ # CHOST = "this-is-retarded"
+ ret=$(eval $(
+ sed -n \
+ -e 's:[[:space:]]::g' \
+ -e '/^CHOST=/p' \
+ "${conf}"
+ ) ; echo ${!varname}
+ )
+ fi
+
+ if [[ -n ${ret} ]] ; then
+ echo ${ret}
+ return 0
+ fi
+
+ #
+ # Then we try /etc/env.d/gcc/config
+ #
+ if [[ -s ${ROOT}/etc/env.d/gcc/config ]] ; then
+ ret=$(split_gcc_ver $(eval $(<"${ROOT}"/etc/env.d/gcc/config) ; echo ${CURRENT}))
+ echo ${ret% *}
+ fi
+}
+
+get_real_chost() {
+ [[ -n ${REAL_CHOST} ]] && return 0
+
+ # shortcut for switching compilers in a cross chroot
+ if [[ -n ${CHOST} && ${ROOT} != "/" ]] ; then
+ REAL_CHOST=${CHOST}
+ return 0
+ fi
+
+ # make sure portage isnt broken
+ if python -V &>/dev/null ; then
+ export REAL_CHOST=$(env -i portageq envvar CHOST 2>/dev/null)
+ else
+ ewarn "Python seems to be broken, attempting to locate CHOST ourselves ..."
+ export REAL_CHOST=$(try_real_hard_to_find_CHOST)
+ fi
+
+ if [[ -z ${REAL_CHOST} ]] ; then
+ eerror "${argv0}: Could not get portage CHOST!"
+ eerror "${argv0}: You should verify that CHOST is set in one of these places:"
+ eerror "${argv0}: - ${ROOT}/etc/make.conf"
+ eerror "${argv0}: - active environment"
+ exit 1
+ fi
+}
+
+is_cross_compiler() {
+ get_real_chost
+ [[ ${CC_COMP/${REAL_CHOST}} == ${CC_COMP} ]]
+}
+
+# bool files_exists(search_path, files)
+# Return shell true if the specified files exist.
+# Files with relative paths are searched for in search_path.
+# Both lists are : delimited.
+files_exist() {
+ local p f ret old_IFS
+ local paths=$1 files=$2
+
+ old_IFS=${IFS}
+ export IFS=":"
+
+ ret=0
+ for f in ${files} ; do
+ if [[ ${f} == /* ]] ; then
+ [[ ! -f ${f} ]] && ret=1 && break
+ else
+ # make sure the file exists in at least
+ # one of the specified paths
+ ret=1
+ for p in ${paths} ; do
+ [[ -f ${p}/${f} ]] && ret=0 && break
+ done
+ [[ ${ret} == 1 ]] && break
+ fi
+ done
+
+ export IFS=${old_IFS}
+ if [[ ${ret} == 1 ]] ; then
+ ewarn "Could not locate '${f}' in '${paths}'"
+ fi
+ return ${ret}
+}
+
+switch_profile() {
+ local MY_LDPATH=
+ local GCC_PROFILES=
+ local OLD_CC_COMP=
+ local GCC_PATH=
+
+ if [[ $(id -u) != "0" ]] ; then
+ eerror "${argv0}: Must be root."
+ exit 1
+ fi
+
+ if is_cross_compiler ; then
+ ebegin "Switching cross-compiler to ${CC_COMP}"
+ else
+ ebegin "Switching native-compiler to ${CC_COMP}"
+ fi
+
+ if ! is_cross_compiler ; then
+ # Order our profiles to have the default first ...
+ # We do this so that we can have them ordered with default
+ # first in /etc/ld.so.conf, as the logical is that all
+ # compilers for default CHOST will be used to compile stuff,
+ # and thus we want all their lib paths in /etc/ld.so.conf ...
+ get_real_chost
+ GCC_PROFILES=$(LC_ALL="C" ls -r ${GCC_ENV_D}/${REAL_CHOST}-*)
+ GCC_PROFILES="${GCC_ENV_D}/${CC_COMP} ${GCC_PROFILES}"
+
+ # Extract all LDPATH's for our CHOST
+ MY_LDPATH=""
+ for x in ${GCC_PROFILES} ; do
+ if [[ -f ${x} ]] ; then
+ LDPATH=$(source "${x}"; echo ${LDPATH})
+
+ # Handle LDPATH's that have multiple directories
+ local old_IFS=${IFS}
+ export IFS=":"
+ local sub_ldpath=
+ for sub_ldpath in ${LDPATH} ; do
+ if [[ -d ${sub_ldpath} ]] ; then
+ if [[ ${MY_LDPATH/:${sub_ldpath}} == ${MY_LDPATH} ]] ; then
+ MY_LDPATH="${MY_LDPATH}:${sub_ldpath}"
+ fi
+ fi
+ done
+ export IFS=${old_IFS}
+ fi
+ done
+ MY_LDPATH="${MY_LDPATH:1}" # trim leading :
+ fi
+
+ # Translate old PATH/ROOTPATH to GCC_PATH
+ cp -p "${GCC_ENV_D}/${CC_COMP}" "${GCC_ENV_D}/${CC_COMP}.gcc-config-ref" || return 1
+ sed -i \
+ -e 's:^PATH=:GCC_PATH=:' \
+ -e '/^ROOTPATH=/d' \
+ "${GCC_ENV_D}/${CC_COMP}" || return 1
+ touch -r "${GCC_ENV_D}/${CC_COMP}.gcc-config-ref" "${GCC_ENV_D}/${CC_COMP}" || return 1
+ rm -f "${GCC_ENV_D}/${CC_COMP}.gcc-config-ref" || return 1
+
+ # Setup things properly again for this profile
+ unset GCC_SPECS LDPATH
+ source "${GCC_ENV_D}/${CC_COMP}"
+ OLD_CC_COMP=$(get_current_profile)
+ CTARGET=${CTARGET:-${REAL_CHOST}}
+
+ # What kind of env.d entry are we going to generate ?
+ if is_cross_compiler ; then
+ grep '^GCC_PATH=' "${GCC_ENV_D}/${CC_COMP}" > "${ENV_D}/05gcc-${CTARGET}"
+ echo "CURRENT=${CC_COMP}" > "${GCC_ENV_D}/config-${CTARGET}"
+ else
+ # Pass all by default
+ awk '!/^(STDCXX_INCDIR|LDPATH|CC|CXX|CTARGET|GCCBITS|GCC_SPECS|GCC_PATH)=/ {print $0}' \
+ "${GCC_ENV_D}/${CC_COMP}" > "${ENV_D}/05gcc"
+ echo "LDPATH=\"${MY_LDPATH}\"" >> "${ENV_D}/05gcc"
+ echo "PATH=\"${GCC_PATH}\"" >> "${ENV_D}/05gcc"
+ echo "ROOTPATH=\"${GCC_PATH}\"" >> "${ENV_D}/05gcc"
+ if [[ -n ${GCC_SPECS} ]] ; then
+ if files_exist ${MY_LDPATH} ${GCC_SPECS} ; then
+ echo "GCC_SPECS=\"${GCC_SPECS}\"" >> "${ENV_D}/05gcc"
+ else
+ echo
+ ewarn "Your GCC spec configurations are broken."
+ ewarn "Please re-emerge gcc."
+ echo
+ fi
+ else
+ # People need to rebuild their gcc or setting GCC_SPECS to
+ # "" will cause issues again :(
+ if [[ ${ROOT} != "/" ]] ; then
+ echo "GCC_SPECS=\"\"" >> "${ENV_D}/05gcc"
+ else
+ if ! GCC_SPECS="" /usr/bin/gcc -v &>/dev/null ; then
+ echo
+ ewarn "Your gcc has a bug with GCC_SPECS."
+ ewarn "Please re-emerge gcc."
+ ewarn "http://bugs.gentoo.org/68395"
+ echo
+ else
+ echo "GCC_SPECS=\"\"" >> "${ENV_D}/05gcc"
+ fi
+ fi
+ fi
+
+ echo "CURRENT=${CC_COMP}" > "${GCC_ENV_D}/config"
+ fi
+
+ # Find the bin wrapper
+ local wrapper
+ for wrapper in GENTOO_LIBDIR lib lib64 lib32 lib ; do
+ wrapper="${ROOT}usr/${wrapper}/misc/gcc-config"
+ [[ -e ${wrapper} ]] && break
+ done
+
+ # Update the wrappers for this profile
+ for x in {,${CTARGET}-}{cpp,cc,gcc,c++,g++,f77,g77,gcj,gcjh,gcov,gdc,gdmd,gfortran} ; do
+ # Obviously don't want to touch native stuff for cross-compilers
+ [[ ${x} != ${CTARGET}-* ]] && is_cross_compiler && continue
+
+ # Make sure we have no stale wrappers
+ rm -f "${ROOT}/usr/bin/${x}"
+ [[ ${x:${#x}-3} == "gcc" || ${x:${#x}-3} == "g++" ]] \
+ && rm -f "${ROOT}/usr/bin/${x}"{32,64}
+
+ # Only install a wrapper if the binary exists ...
+ # We want to figure out the 'reference file' for each
+ # wrapper (the binary we're 'wrapping') so that we can
+ # sync mtimes together. This makes things like ccache
+ # happy. See Bug #70548 for more info.
+ local ref
+ case ${x} in
+ cc) ref=${ROOT}/${GCC_PATH}/gcc;;
+ f77) ref=${ROOT}/${GCC_PATH}/g77;;
+ *) ref=${ROOT}/${GCC_PATH}/${x};;
+ esac
+ if [[ -x ${ref} ]] ; then
+ cp -f "${wrapper}" "${ROOT}/usr/bin/${x}"
+ touch -r "${ref}" "${ROOT}/usr/bin/${x}"
+
+ # Install 32bit and 64bit wrappers if need be
+ # This should probably get folded back into the wrapper ...
+ if [[ ${x:${#x}-3} == "gcc" ]] || [[ ${x:${#x}-3} == "g++" ]] ; then
+ for bits in ${GCCBITS} ; do
+ cp -f "${wrapper}" "${ROOT}/usr/bin/${x}${bits}"
+ done
+ fi
+ fi
+ done
+ # legacy cruft, make sure we dont leave it laying around #143205
+ rm -f "${ROOT}/usr/bin/${CTARGET}-cc"
+ # Only install cpp if switching to a native one
+ if ! is_cross_compiler && [[ ${CTARGET} != *-solaris* ]] ; then
+ rm -f "${ROOT}/lib/cpp"
+ cp -f "${wrapper}" "${ROOT}/lib/cpp"
+ fi
+
+ # We need to make sure that libgcc_s.so / libunwind.so make it into /lib.
+ # On many systems (x86/amd64/etc...), this will probably never matter,
+ # but on other systems (arm/mips/etc...), this is quite critical.
+ # http://bugs.gentoo.org/60190
+ #
+ # The funky move magic is required for proper updating of in-use files.
+ if ! is_cross_compiler ; then
+ # Need to cut out extra paths in multilib case and pray the first path
+ # is the "root" multilib path ... maybe some day change this to use
+ # `gcc -print-file-name` ...
+ LDPATH=${LDPATH%%:*}
+ for multilib in $("${ROOT}/${GCC_PATH}"/gcc -print-multi-lib); do
+ multiarg=${multilib#*;}
+ multiarg=${multiarg/@/-}
+ multilibdir=${multilib%;*}
+ libdir="lib/"$("${ROOT}/${GCC_PATH}"/gcc ${multiarg} -print-multi-os-directory)
+ if mkdir -p "${ROOT}/${libdir}"/.gcc.config.new ; then
+ for gcclib in gcc_s unwind ; do
+ if [[ -n $(ls "${ROOT}/${LDPATH}/${multilibdir}"/lib${gcclib}.so.* 2>/dev/null) ]]; then
+ cp -pP "${ROOT}/${LDPATH}/${multilibdir}"/lib${gcclib}.so.* "${ROOT}/${libdir}"/.gcc.config.new/
+ # no need to sanity remove this as the `mv` should take
+ # care of it. we also need this step to be completly atomic
+ # for systems that have even `mv` linked against libgcc_s.so.
+ # http://bugs.gentoo.org/150257
+ #rm -f "${ROOT}/${libdir}"/lib${gcclib}.so*
+ mv -f "${ROOT}/${libdir}"/.gcc.config.new/* "${ROOT}/${libdir}"/
+ fi
+ done
+ rmdir "${ROOT}/${libdir}"/.gcc.config.new
+ fi
+ done
+ unset multilib
+ unset multilibdir
+ unset multiarg
+ unset libdir
+ fi
+
+ if [[ ${ROOT} == "/" ]] && [[ ${OLD_CC_COMP} != ${CC_COMP} || ${FORCE} == "yes" ]] ; then
+ # in case python is broken ...
+ if ! env-update ; then
+ echo ""
+ ewarn "env-update failed to work properly; making sure ld.so.conf paths"
+ ewarn "are setup properly. Please rerun gcc-config with the -f option."
+ echo ""
+ grep -h ^LDPATH= "${ROOT}"/etc/env.d/05gcc \
+ | sed -e 's:^LDPATH=::' -e 's:"::g' -e 's|:|\n|g' \
+ >> /etc/ld.so.conf
+ ldconfig
+ fi
+ fi
+
+ eend 0
+
+ if [[ ${ROOT} == "/" ]] && [[ ${OLD_CC_COMP} != ${CC_COMP} ]] ; then
+ echo
+ ewarn "If you intend to use the gcc from the new profile in an already"
+ ewarn "running shell, please remember to do:"
+ echo
+ ewarn " # source /etc/profile"
+ echo
+ fi
+
+ return 0
+}
+
+get_current_profile() {
+ local conf="${GCC_ENV_D}/config"
+ if [[ -n ${CTARGET} ]] ; then
+ conf="${conf}-${CTARGET}"
+ elif [[ -n ${CC_COMP} ]] && is_cross_compiler ; then
+ conf="${conf}-${CC_COMP}"
+ fi
+
+ if [[ ! -f ${conf} ]] ; then
+ eerror "${argv0}: No gcc profile is active!"
+ return 1
+ fi
+
+ CURRENT=$(source "${conf}"; echo ${CURRENT})
+
+ if [[ -z ${CURRENT} ]] ; then
+ eerror "${argv0}: No gcc profile is active!"
+ return 1
+ elif [[ ! -f ${GCC_ENV_D}/${CURRENT} ]] ; then
+ eerror "${argv0}: Active gcc profile is invalid!"
+ return 1
+ fi
+
+ echo "${CURRENT}"
+
+ return 0
+}
+
+list_profiles() {
+ local i=1
+
+ if [[ ${ROOT} != "/" ]] ; then
+ echo "Using gcc-config info in ${ROOT}"
+ fi
+
+ if [[ ! -f ${GCC_ENV_D}/config ]] ; then
+ eerror "${argv0}: No gcc profile is active; please select one!"
+ fi
+
+ eval $(grep -s ^CURRENT= "${GCC_ENV_D}"/config)
+ CURRENT_NATIVE=${CURRENT}
+ local target=
+ for x in "${GCC_ENV_D}"/* ; do
+ if [[ -f ${x} ]] && [[ ${x/\/config} == ${x} ]] ; then
+ CTARGET=$(source "${x}"; echo ${CTARGET})
+ if [[ ${target} != ${CTARGET} ]] ; then
+ [[ -n ${target} ]] && echo
+ target=${CTARGET}
+ CTARGET=""
+ fi
+
+ x=${x##*/}
+ if [[ ${x} == ${CURRENT_NATIVE} ]] ; then
+ x="${x} ${GOOD}*${NORMAL}"
+ elif [[ -e ${GCC_ENV_D}/config-${target} ]] ; then
+ source "${GCC_ENV_D}/config-${target}"
+ [[ ${x} == ${CURRENT} ]] && x="${x} ${HILITE}*${NORMAL}"
+ fi
+ echo " [${i}] ${x}"
+ ((++i))
+ fi
+ done
+}
+
+print_environ() {
+ local GCC_PATH=
+ local ENV_CMD=
+ local SET_ELEMENT=
+
+ GCC_PATH=$(source "${GCC_ENV_D}/${CC_COMP}"; echo ${GCC_PATH:-${PATH}})
+
+ case ${SHELL} in
+ */csh|*/tsch)
+ ENV_CMD="setenv"
+ SET_ELEMENT=" "
+ ;;
+ *)
+ ENV_CMD="export"
+ SET_ELEMENT="="
+ ;;
+ esac
+
+ echo "${ENV_CMD} PATH${SET_ELEMENT}\"${GCC_PATH}:${PATH}\""
+}
+
+get_bin_path() {
+ if [[ -e ${GCC_ENV_D}/${CC_COMP} ]] ; then
+ (
+ unset PATH GCC_PATH
+ source "${GCC_ENV_D}/${CC_COMP}"
+ echo "${GCC_PATH:-${PATH}}"
+ )
+ else
+ echo "no-config"
+ echo "${GCC_ENV_D}/${CC_COMP} doesnt exist" 1>&2
+ fi
+
+ return 0
+}
+
+get_lib_path() {
+ if [[ -e ${GCC_ENV_D}/${CC_COMP} ]] ; then
+ (
+ unset LDPATH
+ source "${GCC_ENV_D}/${CC_COMP}"
+ echo "${LDPATH}"
+ )
+ else
+ echo "no-config"
+ echo "${GCC_ENV_D}/${CC_COMP} doesnt exist" 1>&2
+ fi
+
+ return 0
+}
+
+get_stdcxx_incdir() {
+ # XXX: we should prob scrub this ...
+ if [[ -e ${GCC_ENV_D}/${CC_COMP} ]] ; then
+ (
+ unset LDPATH STDCXX_INCDIR
+ source "${GCC_ENV_D}/${CC_COMP}"
+ echo "${LDPATH}/include/${STDCXX_INCDIR}"
+ )
+ else
+ echo "no-config"
+ echo "${GCC_ENV_D}/${CC_COMP} doesnt exist" 1>&2
+ fi
+
+ return 0
+}
+
+split_gcc_ver() {
+ # Split up the gcc profile into components:
+ # TARGET-VER[-specs] -> TARGET VER [specs]
+ # arm-linux-3.3.6 -> arm-linux 3.3.6
+ # x86_64-linux-4.0.1-pre1234 -> x86_64-linux 4.0.1-pre1234
+ # sh-linux-3.4.4-hardened -> sh-linux 3.4.4 hardened
+ #
+ # So below we will start at the end and run a small state machine ...
+ # specs [3]
+ # accept everything
+ # specs -> version transition [3->2]
+ # when we find a version component
+ # version [2]
+ # accept only version components (see the regex)
+ # version -> target transition [2->1]
+ # when we hit a non version component
+ # target [1]
+ # accept everything we have left
+ #
+ echo "$@" | awk -F- '
+ function pushit(onme, pushee) {
+ return (onme == "" ? pushee : pushee"-"onme);
+ }
+ {
+ state=3
+ targ=""
+ ver=""
+ spec=""
+ for (i=NF; i > 0; --i) {
+ if (state >= 2) {
+ if ($i ~ /^(alpha|beta|pre|rc|p)?[[:digit:].]+$/) {
+ ver=pushit(ver, $i)
+ state=2
+ } else if (state == 3)
+ spec=pushit(spec, $i)
+ else
+ state=1
+ }
+ if (state == 1)
+ targ = pushit(targ, $i)
+ }
+
+ if (targ == "") {
+ if (ver == "") {
+ ver=spec
+ spec=""
+ }
+ targ=ver
+ ver=""
+ }
+ print targ " " ver (spec != "" ? " " spec : "")
+ }'
+}
+chop_gcc_ver_spec() {
+ local splitTED=$(split_gcc_ver $@) # target ver spec
+ splitTED=${splitTED#* } # ver spec
+ echo ${splitTED/ /-} # ver-spec
+}
+
+NEED_ACTION="yes"
+DOIT="switch_profile"
+CHECK_CHOST="no"
+FORCE="no"
+
+CC_COMP=
+[[ -z ${ROOT} ]] && ROOT="/"
+[[ ${ROOT:0-1} != "/" ]] && ROOT="${ROOT}/"
+ENV_D="${ROOT}etc/env.d"
+GCC_ENV_D="${ENV_D}/gcc"
+
+for x in "$@" ; do
+ case "${x}" in
+ # Only use specified compiler if one is not already selected.
+ -O|--use-old)
+ if get_current_profile &>/dev/null ; then
+ CC_COMP=$(get_current_profile)
+ else
+ eerror "No profile selected, unable to utilize --use-old"
+ exit 1
+ fi
+ ;;
+ -f|--force)
+ FORCE="yes"
+ ;;
+ -P|--use-portage-chost)
+ CHECK_CHOST="yes"
+ ;;
+ -c|--get-current-profile)
+ if [[ ${NEED_ACTION} == "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="get_current_profile"
+ fi
+ ;;
+ -l|--list-profiles)
+ if [[ ${NEED_ACTION} == "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="list_profiles"
+ fi
+ ;;
+ -S|--split-profile)
+ if [[ ( $1 != "-S" && $1 != "--split-profile" ) || $# -eq 1 ]] ; then
+ usage 1
+ fi
+ shift # push -S out
+ for x in "$@" ; do
+ split_gcc_ver ${x}
+ done
+ exit 0
+ ;;
+ -E|--print-environ)
+ if [[ ${NEED_ACTION} == "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="print_environ"
+ fi
+ ;;
+ -B|--get-bin-path)
+ if [[ ${NEED_ACTION} == "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="get_bin_path"
+ fi
+ ;;
+ -L|--get-lib-path)
+ if [[ ${NEED_ACTION} == "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="get_lib_path"
+ fi
+ ;;
+ -X|--get-stdcxx-incdir)
+ if [[ ${NEED_ACTION} == "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="get_stdcxx_incdir"
+ fi
+ ;;
+ -h|--help)
+ usage 0
+ ;;
+ -V|--version)
+ echo "gcc-config-PORTAGE-VERSION"
+ exit 0
+ ;;
+ -*)
+ eerror "${argv0}: Invalid switch! Run ${argv0} without parameters for help."
+ exit 1
+ ;;
+ *)
+ if [[ -z ${CC_COMP} ]] ; then
+ if [[ -z $(echo ${x} | tr -d '[:digit:]') ]] ; then
+ # User gave us a # representing the profile
+ i=1
+ for y in "${GCC_ENV_D}"/* ; do
+ [[ -f ${y} ]] || continue
+ [[ ${y/\/config} != ${y} ]] && continue
+
+ if [[ -f ${y} ]] && [[ ${x} == ${i} ]] ; then
+ CC_COMP=${y##*/}
+ break
+ fi
+ ((++i))
+ done
+ else
+ # User gave us a full HOST-gccver
+ x=${x##*/}
+ if [[ ${DOIT} == "get_current_profile" && -z $(ls "${GCC_ENV_D}"/${x}-* 2>/dev/null) ]] || \
+ [[ ${DOIT} != "get_current_profile" && ! -f ${GCC_ENV_D}/${x} ]]
+ then
+ # Maybe they just gave us a gccver ...
+ get_real_chost
+ if [[ -f ${GCC_ENV_D}/${REAL_CHOST}-${x} ]] ; then
+ x=${REAL_CHOST}-${x}
+ else
+ eerror "${argv0}: Could not locate '$x' in '${GCC_ENV_D}/' !"
+ exit 1
+ fi
+ fi
+ CC_COMP=${x}
+ fi
+ else
+ eerror "${argv0}: Too many arguments! Run ${argv0} without parameters for help."
+ exit 1
+ fi
+ ;;
+ esac
+done
+
+if [[ ${DOIT} == "switch_profile" ]] && [[ -z ${CC_COMP} ]] ; then
+ usage 1
+fi
+
+if [[ -z ${CC_COMP} ]] ; then
+ CC_COMP=$(get_current_profile)
+ if [[ $? -ne 0 ]] ; then
+ echo "${CC_COMP}"
+ list_profiles
+ exit 1
+ fi
+fi
+
+if [[ ${DOIT} != "get_current_profile" ]] ; then
+ GCC_LIB=$(
+ LDPATH=$(source "${GCC_ENV_D}/${CC_COMP}"; echo ${LDPATH})
+ echo ${LDPATH} | awk -F/ '{ print "/"$2"/"$3"/"$4"/" }'
+ )
+
+ CC_COMP_VERSION=$(chop_gcc_ver_spec ${CC_COMP})
+ CC_COMP_TARGET=${CC_COMP%-${CC_COMP_VERSION}*}
+
+ if [[ ! -d ${ROOT}/${GCC_LIB}/${CC_COMP_TARGET}/${CC_COMP_VERSION} ]]; then
+ CC_COMP_VERSION=${CC_COMP_VERSION%-*}
+ fi
+
+ if [[ ! -d ${ROOT}/${GCC_LIB}/${CC_COMP_TARGET}/${CC_COMP_VERSION} ]] || \
+ [[ ! -f ${GCC_ENV_D}/${CC_COMP} ]]
+ then
+ eerror "${argv0}: Profile does not exist or invalid setting for ${GCC_ENV_D}/${CC_COMP}" 1>&2
+ #exit 1
+ fi
+fi
+
+if [[ ${CHECK_CHOST} == "yes" ]] ; then
+ # Chosen CHOST are not the same as the real CHOST according to
+ # make.conf, and --use-portage-chost option was given, so do nothing
+ get_real_chost
+ CC_COMP_VERSION=$(chop_gcc_ver_spec ${CC_COMP})
+ CC_COMP_TARGET=${CC_COMP:0:${#CC_COMP}-${#CC_COMP_VERSION}-1}
+ [[ ${CC_COMP_TARGET} != ${REAL_CHOST} ]] && exit 0
+fi
+
+eval ${DOIT}
+
+# vim:ts=4
diff --git a/sys-devel/gcc-config/files/wrapper-1.5.0.c b/sys-devel/gcc-config/files/wrapper-1.5.0.c
new file mode 100644
index 000000000000..4766e33f0b72
--- /dev/null
+++ b/sys-devel/gcc-config/files/wrapper-1.5.0.c
@@ -0,0 +1,377 @@
+/*
+ * Copyright 1999-2005 Gentoo Foundation
+ * Distributed under the terms of the GNU General Public License v2
+ * $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/wrapper-1.5.0.c,v 1.1 2007/05/03 05:20:39 vapier Exp $
+ * Author: Martin Schlemmer <azarah@gentoo.org>
+ * az's lackey: Mike Frysinger <vapier@gentoo.org>
+ */
+
+#define _REENTRANT
+#define _GNU_SOURCE
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <sys/param.h>
+#include <unistd.h>
+#include <sys/wait.h>
+#include <libgen.h>
+#include <string.h>
+#include <stdarg.h>
+#include <errno.h>
+
+#define GCC_CONFIG "/usr/bin/gcc-config"
+#define ENVD_BASE "/etc/env.d/05gcc"
+
+struct wrapper_data {
+ char name[MAXPATHLEN + 1];
+ char fullname[MAXPATHLEN + 1];
+ char bin[MAXPATHLEN + 1];
+ char tmp[MAXPATHLEN + 1];
+ char *path;
+};
+
+static struct {
+ char *alias;
+ char *target;
+} wrapper_aliases[] = {
+ { "cc", "gcc" },
+ { "f77", "g77" },
+ { NULL, NULL }
+};
+
+static const char *wrapper_strerror(int err, struct wrapper_data *data)
+{
+ /* this app doesn't use threads and strerror
+ * is more portable than strerror_r */
+ strncpy(data->tmp, strerror(err), sizeof(data->tmp));
+ return data->tmp;
+}
+
+static void wrapper_exit(char *msg, ...)
+{
+ va_list args;
+ fprintf(stderr, "gcc-config error: ");
+ va_start(args, msg);
+ vfprintf(stderr, msg, args);
+ va_end(args);
+ exit(1);
+}
+
+/* check_for_target checks in path for the file we are seeking
+ * it returns 1 if found (with data->bin setup), 0 if not and
+ * negative on error
+ */
+static int check_for_target(char *path, struct wrapper_data *data)
+{
+ struct stat sbuf;
+ int result;
+ char str[MAXPATHLEN + 1];
+ size_t len = strlen(path) + strlen(data->name) + 2;
+
+ snprintf(str, len, "%s/%s", path, data->name);
+
+ /* Stat possible file to check that
+ * 1) it exist and is a regular file, and
+ * 2) it is not the wrapper itself, and
+ * 3) it is in a /gcc-bin/ directory tree
+ */
+ result = stat(str, &sbuf);
+ if ((result == 0) && \
+ ((sbuf.st_mode & S_IFREG) || (sbuf.st_mode & S_IFLNK)) && \
+ (strcmp(str, data->fullname) != 0) && \
+ (strstr(str, "/gcc-bin/") != 0)) {
+
+ strncpy(data->bin, str, MAXPATHLEN);
+ data->bin[MAXPATHLEN] = 0;
+ result = 1;
+ } else
+ result = 0;
+
+ return result;
+}
+
+static int find_target_in_path(struct wrapper_data *data)
+{
+ char *token = NULL, *state;
+ char str[MAXPATHLEN + 1];
+
+ if (data->path == NULL) return 0;
+
+ /* Make a copy since strtok_r will modify path */
+ snprintf(str, MAXPATHLEN + 1, "%s", data->path);
+
+ token = strtok_r(str, ":", &state);
+
+ /* Find the first file with suitable name in PATH. The idea here is
+ * that we do not want to bind ourselfs to something static like the
+ * default profile, or some odd environment variable, but want to be
+ * able to build something with a non default gcc by just tweaking
+ * the PATH ... */
+ while ((token != NULL) && strlen(token)) {
+ if (check_for_target(token, data))
+ return 1;
+ token = strtok_r(NULL, ":", &state);
+ }
+
+ return 0;
+}
+
+/* find_target_in_envd parses /etc/env.d/05gcc, and tries to
+ * extract PATH, which is set to the current profile's bin
+ * directory ...
+ */
+static int find_target_in_envd(struct wrapper_data *data, int cross_compile)
+{
+ FILE *envfile = NULL;
+ char *token = NULL, *state;
+ char str[MAXPATHLEN + 1];
+ char *strp = str;
+ char envd_file[MAXPATHLEN + 1];
+
+ if (!cross_compile) {
+ snprintf(envd_file, MAXPATHLEN, "%s", ENVD_BASE);
+ } else {
+ char *ctarget, *end = strrchr(data->name, '-');
+ if (end == NULL)
+ return 0;
+ ctarget = strdup(data->name);
+ ctarget[end - data->name] = '\0';
+ snprintf(envd_file, MAXPATHLEN, "%s-%s", ENVD_BASE, ctarget);
+ free(ctarget);
+ }
+ envfile = fopen(envd_file, "r");
+ if (envfile == NULL)
+ return 0;
+
+ while (fgets(strp, MAXPATHLEN, envfile) != NULL) {
+ /* Keep reading ENVD_FILE until we get a line that
+ * starts with 'GCC_PATH=' ... keep 'PATH=' around
+ * for older gcc versions.
+ */
+ if (strncmp(strp, "GCC_PATH=", strlen("GCC_PATH=")) &&
+ strncmp(strp, "PATH=", strlen("PATH=")))
+ continue;
+
+ token = strtok_r(strp, "=", &state);
+ if ((token != NULL) && strlen(token))
+ /* The second token should be the value of PATH .. */
+ token = strtok_r(NULL, "=", &state);
+ else
+ goto bail;
+
+ if ((token != NULL) && strlen(token)) {
+ strp = token;
+ /* A bash variable may be unquoted, quoted with " or
+ * quoted with ', so extract the value without those ..
+ */
+ token = strtok(strp, "\n\"\'");
+
+ while (token != NULL) {
+ if (check_for_target(token, data)) {
+ fclose(envfile);
+ return 1;
+ }
+
+ token = strtok(NULL, "\n\"\'");
+ }
+ }
+
+ strp = str;
+ }
+
+bail:
+ fclose(envfile);
+ return (cross_compile ? 0 : find_target_in_envd(data, 1));
+}
+
+static void find_wrapper_target(struct wrapper_data *data)
+{
+ FILE *inpipe = NULL;
+ char str[MAXPATHLEN + 1];
+
+ if (find_target_in_path(data))
+ return;
+
+ if (find_target_in_envd(data, 0))
+ return;
+
+ /* Only our wrapper is in PATH, so
+ get the CC path using gcc-config and
+ execute the real binary in there... */
+ inpipe = popen(GCC_CONFIG " --get-bin-path", "r");
+ if (inpipe == NULL)
+ wrapper_exit(
+ "Could not open pipe: %s\n",
+ wrapper_strerror(errno, data));
+
+ if (fgets(str, MAXPATHLEN, inpipe) == 0)
+ wrapper_exit(
+ "Could not get compiler binary path: %s\n",
+ wrapper_strerror(errno, data));
+
+ strncpy(data->bin, str, sizeof(data->bin) - 1);
+ data->bin[strlen(data->bin) - 1] = '/';
+ strncat(data->bin, data->name, sizeof(data->bin) - 1);
+ data->bin[MAXPATHLEN] = 0;
+
+ pclose(inpipe);
+}
+
+/* This function modifies PATH to have gcc's bin path appended */
+static void modify_path(struct wrapper_data *data)
+{
+ char *newpath = NULL, *token = NULL, *state;
+ char dname_data[MAXPATHLEN + 1], str[MAXPATHLEN + 1];
+ char *str2 = dname_data, *dname = dname_data;
+ size_t len = 0;
+
+ if (data->bin == NULL)
+ return;
+
+ snprintf(str2, MAXPATHLEN + 1, "%s", data->bin);
+
+ if ((dname = dirname(str2)) == NULL)
+ return;
+
+ if (data->path == NULL)
+ return;
+
+ /* Make a copy since strtok_r will modify path */
+ snprintf(str, MAXPATHLEN + 1, "%s", data->path);
+
+ token = strtok_r(str, ":", &state);
+
+ /* Check if we already appended our bin location to PATH */
+ if ((token != NULL) && strlen(token)) {
+ if (!strcmp(token, dname))
+ return;
+ }
+
+ len = strlen(dname) + strlen(data->path) + 2 + strlen("PATH") + 1;
+
+ newpath = (char *)malloc(len);
+ if (newpath == NULL)
+ wrapper_exit("out of memory\n");
+ memset(newpath, 0, len);
+
+ snprintf(newpath, len, "PATH=%s:%s", dname, data->path);
+ putenv(newpath);
+}
+
+static char *abi_flags[] = {
+ "-m32", "-m64", "-mabi", NULL
+};
+static char **build_new_argv(char **argv, const char *newflags_str)
+{
+#define MAX_NEWFLAGS 32
+ char *newflags[MAX_NEWFLAGS];
+ char **retargv;
+ unsigned int argc, i;
+ char *state, *flags_tokenized;
+
+ retargv = argv;
+
+ /* make sure user hasn't specified any ABI flags already ...
+ * if they have, lets just get out of here */
+ for (argc = 0; argv[argc]; ++argc)
+ for (i = 0; abi_flags[i]; ++i)
+ if (!strncmp(argv[argc], abi_flags[i], strlen(abi_flags[i])))
+ return retargv;
+
+ /* Tokenize the flag list and put it into newflags array */
+ flags_tokenized = strdup(newflags_str);
+ if (flags_tokenized == NULL)
+ return retargv;
+ i = 0;
+ newflags[i] = strtok_r(flags_tokenized, " \t\n", &state);
+ while (newflags[i] != NULL && i < MAX_NEWFLAGS-1)
+ newflags[++i] = strtok_r(NULL, " \t\n", &state);
+
+ /* allocate memory for our spiffy new argv */
+ retargv = (char**)calloc(argc + i + 1, sizeof(char*));
+ /* start building retargv */
+ retargv[0] = argv[0];
+ /* insert the ABI flags first so cmdline always overrides ABI flags */
+ memcpy(retargv+1, newflags, i * sizeof(char*));
+ /* copy over the old argv */
+ if (argc > 1)
+ memcpy(retargv+1+i, argv+1, (argc-1) * sizeof(char*));
+
+ return retargv;
+}
+
+int main(int argc, char *argv[])
+{
+ struct wrapper_data data;
+ size_t size;
+ int i;
+ char **newargv = argv;
+
+ memset(&data, 0, sizeof(data));
+
+ if (getenv("PATH")) {
+ data.path = strdup(getenv("PATH"));
+ if (data.path == NULL)
+ wrapper_exit("%s wrapper: out of memory\n", argv[0]);
+ }
+
+ /* What should we find ? */
+ strcpy(data.name, basename(argv[0]));
+
+ /* Allow for common compiler names like cc->gcc */
+ for (i = 0; wrapper_aliases[i].alias; ++i)
+ if (!strcmp(data.name, wrapper_aliases[i].alias))
+ strcpy(data.name, wrapper_aliases[i].target);
+
+ /* What is the full name of our wrapper? */
+ size = sizeof(data.fullname);
+ i = snprintf(data.fullname, size, "/usr/bin/%s", data.name);
+ if ((i == -1) || (i > (int)size))
+ wrapper_exit("invalid wrapper name: \"%s\"\n", data.name);
+
+ find_wrapper_target(&data);
+
+ modify_path(&data);
+
+ if (data.path)
+ free(data.path);
+ data.path = NULL;
+
+ /* Set argv[0] to the correct binary, else gcc can't find internal headers
+ * http://bugs.gentoo.org/8132
+ */
+ argv[0] = data.bin;
+
+ /* If this is g{cc,++}{32,64}, we need to add -m{32,64}
+ * otherwise we need to add ${CFLAGS_${ABI}}
+ */
+ size = strlen(data.bin) - 2;
+ if(!strcmp(data.bin + size, "32") ) {
+ *(data.bin + size) = '\0';
+ newargv = build_new_argv(argv, "-m32");
+ } else if (!strcmp(data.bin + size, "64") ) {
+ *(data.bin + size) = '\0';
+ newargv = build_new_argv(argv, "-m64");
+ } else if(getenv("ABI")) {
+ char envvar[50];
+
+ /* We use CFLAGS_${ABI} for gcc, g++, g77, etc as they are
+ * the same no matter which compiler we are using.
+ */
+ snprintf(envvar, sizeof(envvar), "CFLAGS_%s", getenv("ABI"));
+
+ if (getenv(envvar)) {
+ newargv = build_new_argv(argv, getenv(envvar));
+ if(!newargv)
+ wrapper_exit("%s wrapper: out of memory\n", argv[0]);
+ }
+ }
+
+ /* Ok, lets do it one more time ... */
+ if (execv(data.bin, newargv) < 0)
+ wrapper_exit("Could not run/locate \"%s\"\n", data.name);
+
+ return 0;
+}
diff --git a/sys-devel/gcc-config/gcc-config-1.4.0.ebuild b/sys-devel/gcc-config/gcc-config-1.4.0.ebuild
new file mode 100644
index 000000000000..0c66547c807a
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.4.0.ebuild,v 1.5 2007/05/03 05:20:39 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs multilib
+
+# Version of .c wrapper to use
+W_VER="1.5.0"
+
+DESCRIPTION="Utility to change the gcc compiler being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*" #~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!app-admin/eselect-compiler"
+
+S=${WORKDIR}
+
+src_compile() {
+ strip-flags
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wall -o wrapper \
+ "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
+}
+
+src_install() {
+ newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
+ sed -i \
+ -e "s:PORTAGE-VERSION:${PVR}:g" \
+ -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
+ "${D}"/usr/bin/${PN}
+
+ exeinto /usr/$(get_libdir)/misc
+ newexe wrapper gcc-config || die "install wrapper"
+}
+
+pkg_postinst() {
+ # Do we have a valid multi ver setup ?
+ if gcc-config --get-current-profile &>/dev/null ; then
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
+ [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
+ gcc-config $(/usr/bin/gcc-config --get-current-profile)
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+}