summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog10
-rw-r--r--sys-devel/gcc/files/pro-police-docs.patch74
-rw-r--r--sys-devel/gcc/gcc-4.7.2-r1.ebuild65
3 files changed, 74 insertions, 75 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index eb60d034378f..1bc5edf9ceae 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.937 2013/02/08 10:32:13 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.938 2013/02/25 04:42:07 dirtyepic Exp $
+
+*gcc-4.7.2-r1 (25 Feb 2013)
+
+ 25 Feb 2013; Ryan Hill <dirtyepic@gentoo.org> +gcc-4.7.2-r1.ebuild,
+ -files/pro-police-docs.patch:
+ 4.7.2 p1.4: Fixes bug #451680 (bootstrap comparison failure on alpha),
+ bug #421305 and #417271 (libitm build breakage), and PR55940 (incorrect
+ code building virtualbox kernel modules). Revbump for unmasking.
08 Feb 2013; Agostino Sarubbo <ago@gentoo.org> gcc-4.6.3.ebuild:
Stable for s390, wrt bug #418383
diff --git a/sys-devel/gcc/files/pro-police-docs.patch b/sys-devel/gcc/files/pro-police-docs.patch
deleted file mode 100644
index 091ea44ef0d7..000000000000
--- a/sys-devel/gcc/files/pro-police-docs.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-Index: gcc/doc/invoke.texi
-===================================================================
-RCS file: /cvsroot/gcc/gcc/gcc/doc/invoke.texi,v
-retrieving revision 1.364
-diff -c -3 -p -r1.364 invoke.texi
-*** gcc/doc/invoke.texi 21 Nov 2003 11:42:58 -0000 1.364
---- gcc/doc/invoke.texi 22 Nov 2003 08:12:35 -0000
-*************** in the following sections.
-*** 228,234 ****
- -Wno-multichar -Wnonnull -Wpacked -Wpadded @gol
- -Wparentheses -Wpointer-arith -Wredundant-decls @gol
- -Wreturn-type -Wsequence-point -Wshadow @gol
-! -Wsign-compare -Wstrict-aliasing @gol
- -Wswitch -Wswitch-default -Wswitch-enum @gol
- -Wsystem-headers -Wtrigraphs -Wundef -Wuninitialized @gol
- -Wunknown-pragmas -Wunreachable-code @gol
---- 228,234 ----
- -Wno-multichar -Wnonnull -Wpacked -Wpadded @gol
- -Wparentheses -Wpointer-arith -Wredundant-decls @gol
- -Wreturn-type -Wsequence-point -Wshadow @gol
-! -Wsign-compare -Wstack-protector -Wstrict-aliasing @gol
- -Wswitch -Wswitch-default -Wswitch-enum @gol
- -Wsystem-headers -Wtrigraphs -Wundef -Wuninitialized @gol
- -Wunknown-pragmas -Wunreachable-code @gol
-*************** in the following sections.
-*** 681,686 ****
---- 681,687 ----
- -fshort-double -fshort-wchar @gol
- -fverbose-asm -fpack-struct -fstack-check @gol
- -fstack-limit-register=@var{reg} -fstack-limit-symbol=@var{sym} @gol
-+ -fstack-protector -fstack-protector-all @gol
- -fargument-alias -fargument-noalias @gol
- -fargument-noalias-global -fleading-underscore @gol
- -ftls-model=@var{model} @gol
-*************** effectively. Often, the problem is that
-*** 3014,3019 ****
---- 3015,3024 ----
- complex; GCC will refuse to optimize programs when the optimization
- itself is likely to take inordinate amounts of time.
-
-+ @item -Wstack-protector
-+ @opindex Wstack-protector
-+ Warn when not issuing stack smashing protection for some reason
-+
- @item -Werror
- @opindex Werror
- Make all warnings into errors.
-*************** and grows downwards, you can use the fla
-*** 11474,11479 ****
---- 11479,11502 ----
- @option{-fstack-limit-symbol=__stack_limit} and
- @option{-Wl,--defsym,__stack_limit=0x7ffe0000} to enforce a stack limit
- of 128KB@. Note that this may only work with the GNU linker.
-+
-+ @item -fstack-protector
-+ @item -fstack-protector-all
-+ @opindex fstack-protector
-+ @opindex fstack-protector-all
-+ @opindex fno-stack-protector
-+ Generate code to protect an application from a stack smashing
-+ attack. The features are (1) the insertion of random value next to the
-+ frame pointer to detect the integrity of the stack, (2) the reordering
-+ of local variables to place buffers after pointers to avoid the
-+ corruption of pointers that could be used to further corrupt arbitrary
-+ memory locations, (3) the copying of pointers in function arguments to
-+ an area preceding local variable buffers to prevent the corruption of
-+ pointers that could be used to further corrupt arbitrary memory
-+ locations, and the (4) omission of instrumentation code from some
-+ functions to decrease the performance overhead. If the integrity
-+ would be broken, the program is aborted. If no-stack-protector is
-+ specified, instrumentation codes are generated at every functions.
-
- @cindex aliasing of parameters
- @cindex parameters, aliased
diff --git a/sys-devel/gcc/gcc-4.7.2-r1.ebuild b/sys-devel/gcc/gcc-4.7.2-r1.ebuild
new file mode 100644
index 000000000000..f3f8621f113e
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.7.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.2-r1.ebuild,v 1.1 2013/02/25 04:42:07 dirtyepic Exp $
+
+PATCH_VER="1.4"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.18"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ # drop the x32 stuff once 4.7 goes stable
+ if [[ ${CTARGET} != x86_64* ]] || ! has x32 $(get_all_abis TARGET) ; then
+ EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
+ fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ ewarn
+ ewarn "LTO support is still experimental and unstable."
+ ewarn "Any bugs resulting from the use of LTO will not be fixed."
+ ewarn
+}