summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog11
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r6 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r5)0
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r1 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.3.13)0
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.123
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.133
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.12-r6.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild)2
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.13-r1.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.3.13.ebuild)4
7 files changed, 17 insertions, 6 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 0a398c99f587..c69fda77a917 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.114 2006/01/05 03:05:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.115 2006/01/08 09:52:45 vapier Exp $
+
+*gcc-config-1.3.13-r1 (08 Jan 2006)
+*gcc-config-1.3.12-r6 (08 Jan 2006)
+
+ 08 Jan 2006; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.12,
+ files/gcc-config-1.3.13, -gcc-config-1.3.12-r5.ebuild,
+ +gcc-config-1.3.12-r6.ebuild, -gcc-config-1.3.13.ebuild,
+ +gcc-config-1.3.13-r1.ebuild:
+ Ignore directores in /etc/env.d/gcc #118246 by Mark Purtill.
*gcc-config-1.3.12-r5 (05 Jan 2006)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r5 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r6
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r5
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.12-r6
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.13 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r1
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.13
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r1
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.12 b/sys-devel/gcc-config/files/gcc-config-1.3.12
index 8366a2678f7c..ebce2f0a711b 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.12
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.12
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.13 2006/01/05 03:05:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.14 2006/01/08 09:52:45 vapier Exp $
trap ":" INT QUIT TSTP
@@ -595,6 +595,7 @@ for x in "$@" ; do
# User gave us a # representing the profile
i=1
for y in "${GCC_ENV_D}"/* ; do
+ [[ -f ${y} ]] || continue
[[ ${y/\/config} != ${y} ]] && continue
if [[ -f ${y} ]] && [[ ${x} == ${i} ]] ; then
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.13 b/sys-devel/gcc-config/files/gcc-config-1.3.13
index 2a82308a947b..e2c8debd3bf2 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.13
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.13
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.13,v 1.2 2006/01/05 03:05:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.13,v 1.3 2006/01/08 09:52:45 vapier Exp $
trap ":" INT QUIT TSTP
@@ -601,6 +601,7 @@ for x in "$@" ; do
# User gave us a # representing the profile
i=1
for y in "${GCC_ENV_D}"/* ; do
+ [[ -f ${y} ]] || continue
[[ ${y/\/config} != ${y} ]] && continue
if [[ -f ${y} ]] && [[ ${x} == ${i} ]] ; then
diff --git a/sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild b/sys-devel/gcc-config/gcc-config-1.3.12-r6.ebuild
index a04e9726b036..eb3a252ddb8c 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.12-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.12-r5.ebuild,v 1.1 2006/01/05 03:05:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.12-r6.ebuild,v 1.1 2006/01/08 09:52:45 vapier Exp $
inherit toolchain-funcs multilib
diff --git a/sys-devel/gcc-config/gcc-config-1.3.13.ebuild b/sys-devel/gcc-config/gcc-config-1.3.13-r1.ebuild
index e1dc88e8ed7d..f6dfdfa8d70b 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.13.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.13-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.13.ebuild,v 1.1 2005/12/30 11:04:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.13-r1.ebuild,v 1.1 2006/01/08 09:52:45 vapier Exp $
inherit toolchain-funcs multilib