summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/encfs/ChangeLog5
-rw-r--r--sys-fs/encfs/encfs-1.5.ebuild47
-rw-r--r--sys-fs/encfs/encfs-1.6.ebuild8
-rw-r--r--sys-fs/encfs/files/encfs-1.3.2.1-gcc-4.3.patch324
-rw-r--r--sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch176
-rw-r--r--sys-fs/encfs/files/encfs-1.5-boost-system-and-as-needed.patch20
-rw-r--r--sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch11
7 files changed, 9 insertions, 582 deletions
diff --git a/sys-fs/encfs/ChangeLog b/sys-fs/encfs/ChangeLog
index 6c914cab144f..e64bf3bca6f6 100644
--- a/sys-fs/encfs/ChangeLog
+++ b/sys-fs/encfs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/encfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.47 2010/07/17 09:34:52 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.48 2010/08/31 19:05:41 ssuominen Exp $
+
+ 31 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> encfs-1.6.ebuild:
+ USE="xattr" by Martin Väth.
17 Jul 2010; Christian Faulhammer <fauli@gentoo.org> encfs-1.6.ebuild:
stable x86, bug 327929
diff --git a/sys-fs/encfs/encfs-1.5.ebuild b/sys-fs/encfs/encfs-1.5.ebuild
deleted file mode 100644
index 4052a547d889..000000000000
--- a/sys-fs/encfs/encfs-1.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.5.ebuild,v 1.6 2009/08/07 10:45:25 ssuominen Exp $
-
-WANT_AUTOMAKE="1.10"
-
-inherit eutils autotools
-
-MY_P="${P}-2"
-
-DESCRIPTION="Encrypted Filesystem module for Linux"
-SRC_URI="http://encfs.googlecode.com/files/${MY_P}.tgz"
-HOMEPAGE="http://www.arg0.net/encfs"
-LICENSE="GPL-2"
-KEYWORDS="amd64 sparc x86"
-SLOT="0"
-IUSE="nls"
-
-DEPEND=">=dev-libs/openssl-0.9.7
- >=sys-fs/fuse-2.6
- >=dev-libs/rlog-1.3.6
- >=dev-libs/boost-1.34
- nls? ( >=sys-devel/gettext-0.14.1 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # bug 245782 - sys-fs/encfs-1.5 fails to build with --as-needed
- epatch "${FILESDIR}"/${P}-boost-system-and-as-needed.patch
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
- eautomake
-}
-
-src_compile() {
- econf `use_enable nls` || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README
-}
-
-pkg_postinst() {
- einfo "Please see http://www.arg0.net/encfsintro"
- einfo "if this is your first time using encfs."
-}
diff --git a/sys-fs/encfs/encfs-1.6.ebuild b/sys-fs/encfs/encfs-1.6.ebuild
index 8ecb5f609038..72869d7f370a 100644
--- a/sys-fs/encfs/encfs-1.6.ebuild
+++ b/sys-fs/encfs/encfs-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.6.ebuild,v 1.6 2010/07/17 09:34:52 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.6.ebuild,v 1.7 2010/08/31 19:05:41 ssuominen Exp $
EAPI=2
@@ -13,7 +13,7 @@ SRC_URI="http://encfs.googlecode.com/files/${P}-1.tgz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~sparc x86"
-IUSE=""
+IUSE="xattr"
RDEPEND=">=dev-libs/boost-1.34
>=dev-libs/openssl-0.9.7
@@ -22,7 +22,7 @@ RDEPEND=">=dev-libs/boost-1.34
DEPEND="${RDEPEND}
dev-lang/perl
dev-util/pkgconfig
- sys-apps/attr
+ xattr? ( sys-apps/attr )
sys-devel/gettext"
src_configure() {
@@ -33,6 +33,8 @@ src_configure() {
BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
einfo "Building against ${BOOST_PKG}."
+ use xattr || export ac_cv_header_attr_xattr_h=no
+
econf \
--with-boost=${BOOST_INC} \
--with-boost-libdir=${BOOST_LIB} \
diff --git a/sys-fs/encfs/files/encfs-1.3.2.1-gcc-4.3.patch b/sys-fs/encfs/files/encfs-1.3.2.1-gcc-4.3.patch
deleted file mode 100644
index 7a5652825f6d..000000000000
--- a/sys-fs/encfs/files/encfs-1.3.2.1-gcc-4.3.patch
+++ /dev/null
@@ -1,324 +0,0 @@
---- encfs/BlockFileIO.cpp
-+++ encfs/BlockFileIO.cpp
-@@ -20,6 +20,7 @@
- #include "MemoryPool.h"
-
- #include <rlog/rlog.h>
-+#include <cstring>
-
- #include "i18n.h"
-
---- encfs/BlockNameIO.cpp
-+++ encfs/BlockNameIO.cpp
-@@ -23,6 +23,7 @@
- #include <rlog/rlog.h>
- #include <rlog/Error.h>
- #include <rlog/RLogChannel.h>
-+#include <cstring>
-
- #include "i18n.h"
-
---- encfs/CipherFileIO.cpp
-+++ encfs/CipherFileIO.cpp
-@@ -23,7 +23,7 @@
- #include <rlog/rlog.h>
-
- #include <fcntl.h>
--#include <errno.h>
-+#include <cerrno>
-
- /*
- - Version 2:0 adds support for a per-file initialization vector with a
---- encfs/CipherV3.cpp
-+++ encfs/CipherV3.cpp
-@@ -22,7 +22,7 @@
-
- #include "../config.h"
-
--#include <string.h>
-+#include <cstring>
-
- #define NO_DES
-
---- encfs/Config.cpp
-+++ encfs/Config.cpp
-@@ -23,6 +23,7 @@
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <cstring>
-
-
- using namespace std;
---- encfs/ConfigVar.cpp
-+++ encfs/ConfigVar.cpp
-@@ -17,6 +17,7 @@
-
- #include "ConfigVar.h"
- #include <rlog/rlog.h>
-+#include <cstring>
-
- using namespace rlog;
-
---- encfs/DirNode.cpp
-+++ encfs/DirNode.cpp
-@@ -22,9 +22,10 @@
-
- #include <sys/stat.h>
- #include <sys/types.h>
--#include <errno.h>
--#include <stdio.h>
--#include <stdlib.h>
-+#include <cerrno>
-+#include <cstring>
-+#include <cstdio>
-+#include <cstdlib>
- #include <pthread.h>
- #include <unistd.h>
- #ifdef linux
---- encfs/FileNode.cpp
-+++ encfs/FileNode.cpp
-@@ -19,7 +19,8 @@
- // of sys/stat.h or other system headers (to be safe)
- #include "encfs.h"
-
--#include <errno.h>
-+#include <cstring>
-+#include <cerrno>
- #include <sys/stat.h>
- #include <sys/types.h>
- #include <fcntl.h>
---- encfs/FileUtils.cpp
-+++ encfs/FileUtils.cpp
-@@ -45,9 +45,10 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <ctype.h>
--#include <stdio.h>
--#include <stdlib.h>
--#include <errno.h>
-+#include <cstdio>
-+#include <cstdlib>
-+#include <cerrno>
-+#include <cstring>
-
- #include <iostream>
- #include <sstream>
---- encfs/MACFileIO.cpp
-+++ encfs/MACFileIO.cpp
-@@ -22,6 +22,7 @@
- #include <rlog/rlog.h>
- #include <rlog/Error.h>
- #include <rlog/RLogChannel.h>
-+#include <cstring>
-
- #include "i18n.h"
-
---- encfs/MACFileIOCompat.cpp
-+++ encfs/MACFileIOCompat.cpp
-@@ -21,6 +21,7 @@
-
- #include <rlog/rlog.h>
- #include <rlog/Error.h>
-+#include <cstring>
-
- #include "i18n.h"
-
---- encfs/MemoryPool.cpp
-+++ encfs/MemoryPool.cpp
-@@ -19,8 +19,8 @@
- #include "MemoryPool.h"
- #include <rlog/rlog.h>
-
--#include <stdlib.h>
--#include <string.h>
-+#include <cstdlib>
-+#include <cstring>
-
- #include "config.h"
- #include <pthread.h>
---- encfs/NameIO.cpp
-+++ encfs/NameIO.cpp
-@@ -26,6 +26,7 @@
- // for static build. Need to reference the modules which are registered at
- // run-time, to ensure that the linker doesn't optimize them away.
- #include <iostream>
-+#include <cstring>
- #include "BlockNameIO.h"
- #include "StreamNameIO.h"
- #include "NullNameIO.h"
---- encfs/NullCipher.cpp
-+++ encfs/NullCipher.cpp
-@@ -21,6 +21,7 @@
- #include "Interface.h"
-
- #include <rlog/rlog.h>
-+#include <cstring>
-
- using namespace std;
- using namespace rel;
---- encfs/NullNameIO.cpp
-+++ encfs/NullNameIO.cpp
-@@ -19,6 +19,7 @@
-
- #include "Cipher.h"
- #include "base64.h"
-+#include <cstring>
-
- using namespace rel;
-
---- encfs/OpaqueValue.cpp
-+++ encfs/OpaqueValue.cpp
-@@ -20,7 +20,7 @@
- #include "PtrImpl.h"
- #include <rlog/rlog.h>
-
--#include <stdlib.h>
-+#include <cstdlib>
-
- using namespace std;
- using namespace rel;
---- encfs/Ptr.cpp
-+++ encfs/Ptr.cpp
-@@ -20,7 +20,7 @@
-
- #include "Ptr.h"
-
--#include <stdlib.h>
-+#include <cstdlib>
-
- using namespace rel;
-
---- encfs/RawFileIO.cpp
-+++ encfs/RawFileIO.cpp
-@@ -28,7 +28,8 @@
- #include <sys/stat.h>
- #include <fcntl.h>
-
--#include <errno.h>
-+#include <cerrno>
-+#include <cstring>
-
- using namespace std;
-
---- encfs/SSL_Cipher.cpp
-+++ encfs/SSL_Cipher.cpp
-@@ -31,7 +31,7 @@
- #include "MemoryPool.h"
- #include "Mutex.h"
-
--#include <string.h>
-+#include <cstring>
-
- #include <sys/mman.h>
-
---- encfs/StreamNameIO.cpp
-+++ encfs/StreamNameIO.cpp
-@@ -22,6 +22,7 @@
-
- #include <rlog/rlog.h>
- #include <rlog/Error.h>
-+#include <cstring>
-
- #include "i18n.h"
-
---- encfs/encfs.cpp
-+++ encfs/encfs.cpp
-@@ -17,12 +17,12 @@
-
- #include "encfs.h"
-
--#include <stdio.h>
--#include <string.h>
-+#include <cstdio>
-+#include <cstring>
- #include <unistd.h>
- #include <fcntl.h>
- #include <dirent.h>
--#include <errno.h>
-+#include <cerrno>
- #include <sys/statvfs.h>
-
- #include <sys/types.h>
---- encfs/encfs.h
-+++ encfs/encfs.h
-@@ -28,7 +28,7 @@
- #endif
-
- #ifndef linux
--#include <errno.h>
-+#include <cerrno>
-
- static __inline int setfsuid(uid_t uid)
- {
---- encfs/main.cpp
-+++ encfs/main.cpp
-@@ -25,10 +25,10 @@
- #include <sstream>
-
- #include <assert.h>
--#include <stdio.h>
-+#include <cstdio>
- #include <unistd.h>
- #include <sys/time.h>
--#include <errno.h>
-+#include <cerrno>
-
- #include <getopt.h>
-
---- encfs/readpassphrase.cpp
-+++ encfs/readpassphrase.cpp
-@@ -36,14 +36,14 @@
- #ifndef HAVE_READPASSPHRASE
-
- #include <signal.h>
--#include <stdio.h>
--#include <errno.h>
-+#include <cstdio>
-+#include <cerrno>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <unistd.h>
- #include <paths.h>
--#include <string.h>
-+#include <cstring>
- #include <ctype.h>
-
- #include <termios.h>
---- encfs/test.cpp
-+++ encfs/test.cpp
-@@ -22,7 +22,7 @@
-
- #include <iostream>
-
--#include <stdlib.h>
-+#include <cstdlib>
-
- #include "Cipher.h"
- #include "DirNode.h"
---- intl/autosprintf.cpp
-+++ intl/autosprintf.cpp
-@@ -17,7 +17,7 @@
- Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
- USA. */
-
--/* Tell glibc's <stdio.h> to provide a prototype for vasprintf().
-+/* Tell glibc's <cstdio> to provide a prototype for vasprintf().
- This must come before <config.h> because <config.h> may include
- <features.h>, and once <features.h> has been included, it's too late. */
- #ifndef _GNU_SOURCE
-@@ -28,10 +28,10 @@
- #include "autosprintf.h"
-
- #include <stdarg.h>
--#include <stdlib.h>
--#include <string.h>
-+#include <cstdlib>
-+#include <cstring>
- //#include "lib-asprintf.h"
--#include <stdio.h>
-+#include <cstdio>
-
- namespace gnu
- {
diff --git a/sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch b/sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch
deleted file mode 100644
index b979c76aa12e..000000000000
--- a/sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch
+++ /dev/null
@@ -1,176 +0,0 @@
---- encfs/CipherFileIO.cpp
-+++ encfs/CipherFileIO.cpp
-@@ -23,7 +23,7 @@
- #include <rlog/rlog.h>
-
- #include <fcntl.h>
--#include <errno.h>
-+#include <cerrno>
-
- using boost::shared_ptr;
-
---- encfs/ConfigVar.h
-+++ encfs/ConfigVar.h
-@@ -19,6 +19,7 @@
- #define _ConfigVar_incl_
-
- #include <string>
-+#include <cstring>
- #include <boost/shared_ptr.hpp>
-
- using boost::shared_ptr;
---- encfs/DirNode.cpp
-+++ encfs/DirNode.cpp
-@@ -22,9 +22,9 @@
-
- #include <sys/stat.h>
- #include <sys/types.h>
--#include <errno.h>
--#include <stdio.h>
--#include <stdlib.h>
-+#include <cerrno>
-+#include <cstdio>
-+#include <cstdlib>
- #include <pthread.h>
- #include <unistd.h>
- #ifdef linux
---- encfs/FileNode.cpp
-+++ encfs/FileNode.cpp
-@@ -19,7 +19,7 @@
- // of sys/stat.h or other system headers (to be safe)
- #include "encfs.h"
-
--#include <errno.h>
-+#include <cerrno>
- #include <sys/stat.h>
- #include <sys/types.h>
- #include <fcntl.h>
---- encfs/FileUtils.cpp
-+++ encfs/FileUtils.cpp
-@@ -47,9 +47,9 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <ctype.h>
--#include <stdio.h>
--#include <stdlib.h>
--#include <errno.h>
-+#include <cstdio>
-+#include <cstdlib>
-+#include <cerrno>
- #include <string.h>
-
- #include <iostream>
---- encfs/MemoryPool.cpp
-+++ encfs/MemoryPool.cpp
-@@ -19,7 +19,7 @@
- #include "MemoryPool.h"
- #include <rlog/rlog.h>
-
--#include <stdlib.h>
-+#include <cstdlib>
- #include <string.h>
-
- #include "config.h"
---- encfs/NameIO.h
-+++ encfs/NameIO.h
-@@ -19,6 +19,7 @@
- #define _NameIO_incl_
-
- #include <string>
-+#include <cstring>
- #include <list>
-
- #include <inttypes.h>
---- encfs/RawFileIO.cpp
-+++ encfs/RawFileIO.cpp
-@@ -29,7 +29,7 @@
- #include <fcntl.h>
- #include <string.h>
-
--#include <errno.h>
-+#include <cerrno>
-
- using namespace std;
-
---- encfs/encfs.cpp
-+++ encfs/encfs.cpp
-@@ -17,12 +17,12 @@
-
- #include "encfs.h"
-
--#include <stdio.h>
-+#include <cstdio>
- #include <string.h>
- #include <unistd.h>
- #include <fcntl.h>
- #include <dirent.h>
--#include <errno.h>
-+#include <cerrno>
- #include <sys/statvfs.h>
- #include <sys/time.h>
-
---- encfs/encfs.h
-+++ encfs/encfs.h
-@@ -28,7 +28,7 @@
- #endif
-
- #ifndef linux
--#include <errno.h>
-+#include <cerrno>
-
- static __inline int setfsuid(uid_t uid)
- {
---- encfs/main.cpp
-+++ encfs/main.cpp
-@@ -25,10 +25,10 @@
- #include <sstream>
-
- #include <assert.h>
--#include <stdio.h>
-+#include <cstdio>
- #include <unistd.h>
- #include <sys/time.h>
--#include <errno.h>
-+#include <cerrno>
- #include <string.h>
-
- #include <getopt.h>
---- encfs/readpassphrase.cpp
-+++ encfs/readpassphrase.cpp
-@@ -36,8 +36,8 @@
- #ifndef HAVE_READPASSPHRASE
-
- #include <signal.h>
--#include <stdio.h>
--#include <errno.h>
-+#include <cstdio>
-+#include <cerrno>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
---- encfs/test.cpp
-+++ encfs/test.cpp
-@@ -22,7 +22,7 @@
-
- #include <iostream>
-
--#include <stdlib.h>
-+#include <cstdlib>
-
- #include "Cipher.h"
- #include "DirNode.h"
---- intl/autosprintf.cpp
-+++ intl/autosprintf.cpp
-@@ -28,10 +28,10 @@
- #include "autosprintf.h"
-
- #include <stdarg.h>
--#include <stdlib.h>
-+#include <cstdlib>
- #include <string.h>
- //#include "lib-asprintf.h"
--#include <stdio.h>
-+#include <cstdio>
-
- namespace gnu
- {
diff --git a/sys-fs/encfs/files/encfs-1.5-boost-system-and-as-needed.patch b/sys-fs/encfs/files/encfs-1.5-boost-system-and-as-needed.patch
deleted file mode 100644
index 9b00259f10b0..000000000000
--- a/sys-fs/encfs/files/encfs-1.5-boost-system-and-as-needed.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur encfs-1.5.orig/encfs/Makefile.am encfs-1.5/encfs/Makefile.am
---- encfs-1.5.orig/encfs/Makefile.am 2009-03-16 08:11:56.330904107 +0100
-+++ encfs-1.5/encfs/Makefile.am 2009-03-16 08:13:13.164266321 +0100
-@@ -3,7 +3,6 @@
-
- ALL_INCLUDES = @RLOG_CFLAGS@ @OPENSSL_CFLAGS@ @BOOST_CPPFLAGS@
- ALL_LDFLAGS = @RLOG_LIBS@ @OPENSSL_LIBS@ @FUSE_LIBS@
--ALL_LDFLAGS += @BOOST_SERIALIZATION_LIB@ @BOOST_FILESYSTEM_LIB@
-
- INCLUDES = $(all_includes) -I../intl
-
-@@ -43,7 +42,7 @@
- # : +1 : => internal changes, nothing breaks
- #
- libencfs_la_LDFLAGS = -version-info 5:0:1
--libencfs_la_LIBADD = -lrlog
-+libencfs_la_LIBADD = -lrlog @OPENSSL_LIBS@ @BOOST_SERIALIZATION_LIB@ @BOOST_FILESYSTEM_LIB@ @BOOST_SYSTEM_LIB@
-
- EXTRASRC = ../intl/autosprintf.cpp
- if BUILD_OPENSSL
diff --git a/sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch b/sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch
deleted file mode 100644
index f42cbe6ed27d..000000000000
--- a/sys-fs/encfs/files/encfs-1.5-glibc-2.10.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- encfs/NameIO.cpp
-+++ encfs/NameIO.cpp
-@@ -190,7 +190,7 @@
- } else
- {
- bool isDotFile = (*path == '.');
-- char *next = strchr( path, '/' );
-+ const char *next = strchr( path, '/' );
- int len = next ? next - path : strlen( path );
-
- // at this point we know that len > 0