summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/iprutils/ChangeLog11
-rwxr-xr-xsys-fs/iprutils/files/iprupdate2
-rw-r--r--sys-fs/iprutils/files/iprutils-2.4.7-tinfo.patch14
-rw-r--r--sys-fs/iprutils/iprutils-2.4.7.ebuild46
4 files changed, 70 insertions, 3 deletions
diff --git a/sys-fs/iprutils/ChangeLog b/sys-fs/iprutils/ChangeLog
index f34250efa1e8..383deac08bc7 100644
--- a/sys-fs/iprutils/ChangeLog
+++ b/sys-fs/iprutils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/iprutils
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/iprutils/ChangeLog,v 1.41 2014/12/25 13:02:26 pinkbyte Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/iprutils/ChangeLog,v 1.42 2015/06/04 17:07:16 jer Exp $
+
+*iprutils-2.4.7 (04 Jun 2015)
+
+ 04 Jun 2015; Jeroen Roovers <jer@gentoo.org> +iprutils-2.4.7.ebuild,
+ +files/iprutils-2.4.7-tinfo.patch, files/iprupdate:
+ Version bump (bug #532488). Fix a bashism (bug #526268). Fix building against
+ sys-libs/ncurses[tinfo] (bug #457530). Add USE=static-libs.
*iprutils-2.3.18 (25 Dec 2014)
diff --git a/sys-fs/iprutils/files/iprupdate b/sys-fs/iprutils/files/iprupdate
index 196f913b94ed..9aba8fee8303 100755
--- a/sys-fs/iprutils/files/iprupdate
+++ b/sys-fs/iprutils/files/iprupdate
@@ -6,6 +6,6 @@ depend() {
start() {
ebegin "Checking ipr microcode levels"
- /sbin/iprupdate &> /dev/null
+ /sbin/iprupdate 2>&1 > /dev/null
eend $? "Failed to complete ipr microcode updates"
}
diff --git a/sys-fs/iprutils/files/iprutils-2.4.7-tinfo.patch b/sys-fs/iprutils/files/iprutils-2.4.7-tinfo.patch
new file mode 100644
index 000000000000..406f3efff2a7
--- /dev/null
+++ b/sys-fs/iprutils/files/iprutils-2.4.7-tinfo.patch
@@ -0,0 +1,14 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,10 @@
+ AC_CHECK_LIB([menu], [new_menu], [], [AC_ERROR("libmenu not found.")])
+ AC_CHECK_LIB([panel], [show_panel], [], [AC_ERROR("libpanel not found.")])
+ AC_CHECK_LIB([ncurses], [curses_version], [],
+- [AC_ERROR("libncurses not found.")])
++ AC_CHECK_LIB([tinfo], [curses_version], [],
++ [AC_ERROR("libncurses not found.")]))
++AC_CHECK_LIB([ncurses], [wnoutrefresh], [],
++ [AC_ERROR("libncurses not found.")])
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([fcntl.h libintl.h locale.h netinet/in.h nl_types.h \
diff --git a/sys-fs/iprutils/iprutils-2.4.7.ebuild b/sys-fs/iprutils/iprutils-2.4.7.ebuild
new file mode 100644
index 000000000000..cede33bc9019
--- /dev/null
+++ b/sys-fs/iprutils/iprutils-2.4.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/iprutils/iprutils-2.4.7.ebuild,v 1.1 2015/06/04 17:07:16 jer Exp $
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="IBM's tools for support of the ipr SCSI controller"
+SRC_URI="mirror://sourceforge/iprdd/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/iprdd/"
+
+SLOT="0"
+LICENSE="IBM"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DEPEND="
+ >=sys-libs/ncurses-5.4-r5
+ >=sys-apps/pciutils-2.1.11-r1
+ virtual/udev
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/logger
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.7-tinfo.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}"/iprinit iprinit
+ newinitd "${FILESDIR}"/iprupdate iprupdate
+ newinitd "${FILESDIR}"/iprdump iprdump
+
+ prune_libtool_files
+}