summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog7
-rw-r--r--www-client/chromium/chromium-6.0.472.25-r1.ebuild8
-rw-r--r--www-client/chromium/chromium-9999.ebuild8
-rw-r--r--www-client/chromium/files/chromium-plugins-path-r0.patch18
4 files changed, 32 insertions, 9 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 697261f3df2a..72181503bb09 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.153 2010/08/11 00:03:15 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.154 2010/08/11 03:20:06 phajdan.jr Exp $
+
+ 11 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/chromium-plugins-path-r0.patch, chromium-6.0.472.25-r1.ebuild,
+ chromium-9999.ebuild:
+ Update plugins search path instead of using a symlink.
11 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+files/chromium-make-3.82-compatibility-r0.patch,
diff --git a/www-client/chromium/chromium-6.0.472.25-r1.ebuild b/www-client/chromium/chromium-6.0.472.25-r1.ebuild
index a3f6c7617e03..b15bdb5f0d57 100644
--- a/www-client/chromium/chromium-6.0.472.25-r1.ebuild
+++ b/www-client/chromium/chromium-6.0.472.25-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.25-r1.ebuild,v 1.3 2010/08/11 00:03:15 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-6.0.472.25-r1.ebuild,v 1.4 2010/08/11 03:20:06 phajdan.jr Exp $
EAPI="2"
@@ -62,6 +62,9 @@ src_prepare() {
# Fix compilation, bug #332131.
epatch "${FILESDIR}"/${PN}-make-3.82-compatibility-r0.patch
+ # Add Gentoo plugin paths.
+ epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
+
remove_bundled_lib "third_party/bzip2"
remove_bundled_lib "third_party/codesighs"
remove_bundled_lib "third_party/cros"
@@ -208,9 +211,6 @@ src_install() {
doexe out/Release/ffmpegsumo_nolink || die
doexe out/Release/libffmpegsumo.so || die
- # Use system plugins by default.
- dosym /usr/$(get_libdir)/nsbrowser/plugins "$(get_chromium_home)/plugins"
-
# Install icon and desktop entry.
newicon out/Release/product_logo_48.png ${PN}-browser.png
dosym "$(get_chromium_home)/chromium-launcher.sh" /usr/bin/chromium
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index 0808a7b18f21..b32d36d85c83 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.73 2010/08/11 00:03:15 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.74 2010/08/11 03:20:06 phajdan.jr Exp $
EAPI="2"
@@ -108,6 +108,9 @@ src_prepare() {
# Fix compilation, bug #332131.
epatch "${FILESDIR}"/${PN}-make-3.82-compatibility-r0.patch
+ # Add Gentoo plugin paths.
+ epatch "${FILESDIR}"/${PN}-plugins-path-r0.patch
+
remove_bundled_lib "third_party/bzip2"
remove_bundled_lib "third_party/codesighs"
remove_bundled_lib "third_party/cros"
@@ -261,9 +264,6 @@ src_install() {
dosym /usr/$(get_libdir)/libavformat.so.52 "$(get_chromium_home)"
dosym /usr/$(get_libdir)/libavutil.so.50 "$(get_chromium_home)"
- # Use system plugins by default.
- dosym /usr/$(get_libdir)/nsbrowser/plugins "$(get_chromium_home)/plugins"
-
# Install icon and desktop entry.
newicon out/Release/product_logo_48.png ${PN}-browser.png
dosym "$(get_chromium_home)/chromium-launcher.sh" /usr/bin/chromium
diff --git a/www-client/chromium/files/chromium-plugins-path-r0.patch b/www-client/chromium/files/chromium-plugins-path-r0.patch
new file mode 100644
index 000000000000..2cf8274e492d
--- /dev/null
+++ b/www-client/chromium/files/chromium-plugins-path-r0.patch
@@ -0,0 +1,18 @@
+--- webkit/glue/plugins/plugin_list_posix.cc.orig 2010-08-11 02:50:36.000000000 +0200
++++ webkit/glue/plugins/plugin_list_posix.cc 2010-08-11 02:51:37.000000000 +0200
+@@ -146,6 +146,7 @@
+ // This varies across different browsers and versions, so check 'em all.
+ plugin_dirs->push_back(FilePath("/usr/lib/browser-plugins"));
+ plugin_dirs->push_back(FilePath("/usr/lib/mozilla/plugins"));
++ plugin_dirs->push_back(FilePath("/usr/lib/nsbrowser/plugins"));
+ plugin_dirs->push_back(FilePath("/usr/lib/firefox/plugins"));
+ plugin_dirs->push_back(FilePath("/usr/lib/xulrunner-addons/plugins"));
+
+@@ -154,6 +155,7 @@
+ // But a user reported on their Fedora system they are separate.
+ plugin_dirs->push_back(FilePath("/usr/lib64/browser-plugins"));
+ plugin_dirs->push_back(FilePath("/usr/lib64/mozilla/plugins"));
++ plugin_dirs->push_back(FilePath("/usr/lib64/nsbrowser/plugins"));
+ plugin_dirs->push_back(FilePath("/usr/lib64/firefox/plugins"));
+ plugin_dirs->push_back(FilePath("/usr/lib64/xulrunner-addons/plugins"));
+ #endif