summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/files/digest-qt-4.0.11
-rw-r--r--x11-libs/qt/files/digest-qt-4.1.01
-rw-r--r--x11-libs/qt/qt-4.0.1.ebuild189
-rw-r--r--x11-libs/qt/qt-4.1.0.ebuild198
5 files changed, 5 insertions, 390 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 06422382eb13..199a71dee46f 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.287 2006/02/22 18:00:12 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.288 2006/02/22 18:01:28 caleb Exp $
+
+ 22 Feb 2006; Caleb Tennis <caleb@gentoo.org> -qt-4.0.1.ebuild,
+ -qt-4.1.0.ebuild:
+ remove old versions
*qt-4.1.1 (22 Feb 2006)
diff --git a/x11-libs/qt/files/digest-qt-4.0.1 b/x11-libs/qt/files/digest-qt-4.0.1
deleted file mode 100644
index bc1cd358b7a6..000000000000
--- a/x11-libs/qt/files/digest-qt-4.0.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 2db4a4d797d37d0605b776420327503a qt-x11-opensource-src-4.0.1.tar.gz 20141717
diff --git a/x11-libs/qt/files/digest-qt-4.1.0 b/x11-libs/qt/files/digest-qt-4.1.0
deleted file mode 100644
index 87b17979288a..000000000000
--- a/x11-libs/qt/files/digest-qt-4.1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0e3982a54f56b6420d3062b20524410a qt-x11-opensource-src-4.1.0.tar.gz 25634393
diff --git a/x11-libs/qt/qt-4.0.1.ebuild b/x11-libs/qt/qt-4.0.1.ebuild
deleted file mode 100644
index d0c2ae49ea2c..000000000000
--- a/x11-libs/qt/qt-4.0.1.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.0.1.ebuild,v 1.16 2006/01/13 12:56:28 caleb Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-SRCTYPE="opensource-src"
-DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework."
-HOMEPAGE="http://www.trolltech.com/"
-
-SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.gz"
-S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
-
-LICENSE="|| ( QPL-1.0 GPL-2 )"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="accessibility cups debug doc examples firebird gif jpeg mng mysql nas nis odbc opengl png postgres sqlite xinerama zlib"
-
-DEPEND="|| ( ( x11-libs/libXrandr
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXfont
- x11-libs/libSM
- x11-proto/xextproto
- x11-proto/inputproto
- xinerama? ( x11-proto/xineramaproto x11-libs/libXinerama )
- )
- virtual/x11
- )
- virtual/xft
- >=media-libs/freetype-2
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- mng? ( media-libs/libmng )
- nas? ( >=media-libs/nas-1.5 )
- odbc? ( dev-db/unixODBC )
- mysql? ( dev-db/mysql )
- firebird? ( dev-db/firebird )
- opengl? ( virtual/opengl virtual/glu )
- postgres? ( dev-db/postgresql )
- cups? ( net-print/cups )
- zlib? ( sys-libs/zlib )"
-
-pkg_setup() {
- QTBASEDIR=/usr/$(get_libdir)/qt4
- QTPREFIXDIR=/usr/$(get_libdir)/qt4
- QTBINDIR=/usr/bin
- QTLIBDIR=/usr/$(get_libdir)/qt4
- QTDATADIR=/usr/share/doc/${PF}
- QTDOCDIR=${QTDATADIR}/doc
- QTHEADERDIR=/usr/include/qt4
- QTPLUGINDIR=${QTLIBDIR}/plugins
- QTSYSCONFDIR=/etc/qt4
- QTTRANSDIR=${QTDATADIR}/translations
- QTEXAMPLESDIR=${QTDATADIR}/examples
- QTDEMOSDIR=${QTDATADIR}/demos
-
- PLATFORM=$(qt_mkspecs_dir)
-}
-
-qt_use() {
- useq ${1} && echo "-${1}" || echo "-no-${1}"
- return 0
-}
-
-qt_mkspecs_dir() {
- # Allows us to define which mkspecs dir we want to use. Currently we only use
- # linux-g++ or linux-g++-64, but others could be used for various platforms.
-
- if [[ $(get_libdir) == "lib" ]]; then
- echo "linux-g++"
- else
- echo "linux-g++-64"
- fi
-}
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
-
- sed -i -e 's:read acceptance:acceptance=yes:' configure
-
- cd mkspecs/$(qt_mkspecs_dir)
- # set c/xxflags and ldflags
-
- # Don't let the user go too overboard with flags. If you really want to, uncomment
- # out the line below and give 'er a whirl.
- strip-flags
- replace-flags -O3 -O2
-
- sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
- -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
- -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
- qmake.conf
-
- # Do not link with -rpath. See bug #75181.
- sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" \
- qmake.conf
- cd ${S}
-
- epatch ${FILESDIR}/qt4-nomkdir.patch
-
- if [[ "$(gcc-major-version)" == "4" ]]; then
- einfo "Visibility support: auto"
- else
- einfo "Visibility support: disabled"
- sed -i -e "s:CFG_REDUCE_EXPORTS=auto:CFG_REDUCE_EXPORTS=no:" configure
- fi
-}
-
-src_compile() {
- export PATH="${S}/bin:${PATH}"
- export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
-
- [ $(get_libdir) != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
-
- myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
- myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
- use png && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
- use jpeg && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
- use debug && myconf="${myconf} -debug-and-release" || myconf="${myconf} -release"
- use zlib && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
-
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
- use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
- use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
- use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
-
- myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
-
- ./configure -stl -verbose -largefile \
- -platform ${PLATFORM} -xplatform ${PLATFORM} \
- -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
- -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
- -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} \
- -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR} ${myconf} || die
-
- emake sub-tools-all-ordered || die
- if use examples; then
- emake sub-examples-all-ordered || die
- fi
-}
-
-src_install() {
- export PATH="${S}/bin:${PATH}"
- export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
-
- make INSTALL_ROOT=${D} sub-tools-install_subtargets-ordered || die
-
- if use examples; then
- make INSTALL_ROOT=${D} sub-examples-install_subtargets || die
- make INSTALL_ROOT=${D} sub-demos-install_subtargets || die
- fi
-
- make INSTALL_ROOT=${D} install_qmake || die
- make INSTALL_ROOT=${D} install_mkspecs || die
-
- if use doc; then
- make INSTALL_ROOT=${D} install_htmldocs || die
- fi
-
- # The QtAssistant header files aren't installed..not sure why
- cp -pPR ${S}/include/QtAssistant ${D}/${QTHEADERDIR}/QtAssistant
-
- keepdir "${QTSYSCONFDIR}"
-
- sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.la
- sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
- sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.pc
-
- # List all the multilib libdirs
- local libdirs
- for libdir in $(get_all_libdirs); do
- libdirs="${libdirs}:/usr/${libdir}/qt4"
- done
-
- cat > "${T}/44qt4" << EOF
-PATH=${QTBINDIR}
-ROOTPATH=${QTBINDIR}
-LDPATH=${libdirs:1}
-QMAKESPEC=$(qt_mkspecs_dir)
-EOF
- doenvd "${T}/44qt4"
-}
diff --git a/x11-libs/qt/qt-4.1.0.ebuild b/x11-libs/qt/qt-4.1.0.ebuild
deleted file mode 100644
index ba352dc99ff3..000000000000
--- a/x11-libs/qt/qt-4.1.0.ebuild
+++ /dev/null
@@ -1,198 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.0.ebuild,v 1.3 2006/01/03 12:12:06 caleb Exp $
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-SRCTYPE="opensource-src"
-DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework."
-HOMEPAGE="http://www.trolltech.com/"
-
-SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.gz"
-S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
-
-LICENSE="|| ( QPL-1.0 GPL-2 )"
-SLOT="4"
-KEYWORDS="-*"
-IUSE="accessibility cups debug doc examples firebird gif jpeg mng mysql nas nis odbc opengl png postgres sqlite xinerama zlib"
-
-DEPEND="|| ( ( x11-libs/libXrandr
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXfont
- x11-proto/xextproto
- x11-proto/inputproto
- xinerama? ( x11-proto/xineramaproto x11-libs/libXinerama )
- )
- virtual/x11
- )
- virtual/xft
- >=media-libs/freetype-2
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- mng? ( media-libs/libmng )
- nas? ( >=media-libs/nas-1.5 )
- odbc? ( dev-db/unixODBC )
- mysql? ( dev-db/mysql )
- firebird? ( dev-db/firebird )
- opengl? ( virtual/opengl virtual/glu )
- postgres? ( dev-db/libpq )
- cups? ( net-print/cups )
- zlib? ( sys-libs/zlib )"
-
-pkg_setup() {
- QTBASEDIR=/usr/$(get_libdir)/qt4
- QTPREFIXDIR=/usr/$(get_libdir)/qt4
- QTBINDIR=/usr/bin
- QTLIBDIR=/usr/$(get_libdir)/qt4
- QTPCDIR=/usr/$(get_libdir)/pkgconfig
- QTDATADIR=/usr/share/doc/${PF}
- QTDOCDIR=${QTDATADIR}/doc
- QTHEADERDIR=/usr/include/qt4
- QTPLUGINDIR=${QTLIBDIR}/plugins
- QTSYSCONFDIR=/etc/qt4
- QTTRANSDIR=${QTDATADIR}/translations
- QTEXAMPLESDIR=${QTDATADIR}/examples
- QTDEMOSDIR=${QTDATADIR}/demos
-
- PLATFORM=$(qt_mkspecs_dir)
-}
-
-qt_use() {
- useq ${1} && echo "-${1}" || echo "-no-${1}"
- return 0
-}
-
-qt_mkspecs_dir() {
- # Allows us to define which mkspecs dir we want to use. Currently we only use
- # linux-g++ or linux-g++-64, but others could be used for various platforms.
-
- if [[ $(get_libdir) == "lib" ]]; then
- echo "linux-g++"
- else
- echo "linux-g++-64"
- fi
-}
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
-
- sed -i -e 's:read acceptance:acceptance=yes:' configure
-
- cd mkspecs/$(qt_mkspecs_dir)
- # set c/xxflags and ldflags
-
- # Don't let the user go too overboard with flags. If you really want to, uncomment
- # out the line below and give 'er a whirl.
- strip-flags
- replace-flags -O3 -O2
-
- sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
- -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
- -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
- qmake.conf
-
- # Do not link with -rpath. See bug #75181.
- sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" \
- qmake.conf
-
- # Replace X11R6/ directories, so /usr/X11R6/lib -> /usr/lib
- sed -i -e "s:X11R6/::" qmake.conf
-
- cd ${S}
- epatch ${FILESDIR}/qt4-nomkdir.patch
- epatch ${FILESDIR}/qt-4.1.0-configure-no-mysql.diff
- epatch ${FILESDIR}/qt-4.1.0-debug-and-release.diff
-
- if [[ "$(gcc-major-version)" == "4" ]]; then
- einfo "Visibility support: auto"
- else
- einfo "Visibility support: disabled"
- sed -i -e "s:CFG_REDUCE_EXPORTS=auto:CFG_REDUCE_EXPORTS=no:" configure
- fi
-}
-
-src_compile() {
- export PATH="${S}/bin:${PATH}"
- export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
-
- [ $(get_libdir) != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
-
- myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
- myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
-
- use nas && myconf="${myconf} -system-nas-sound"
- use gif && myconf="${myconf} -qt-gif" || myconf="${myconf} -no-gif"
- use png && myconf="${myconf} -system-libpng" || myconf="${myconf} -qt-libpng"
- use jpeg && myconf="${myconf} -system-libjpeg" || myconf="${myconf} -qt-libjpeg"
- use debug && myconf="${myconf} -debug-and-release" || myconf="${myconf} -release"
- use zlib && myconf="${myconf} -system-zlib" || myconf="${myconf} -qt-zlib"
-
- use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
- use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
- use firebird && myconf="${myconf} -plugin-sql-ibase" || myconf="${myconf} -no-sql-ibase"
- use sqlite && myconf="${myconf} -plugin-sql-sqlite" || myconf="${myconf} -no-sql-sqlite"
- use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
-
- myconf="${myconf} -tablet -xrender -xrandr -xkb -xshape -sm"
-
- ./configure -stl -verbose -largefile \
- -platform ${PLATFORM} -xplatform ${PLATFORM} \
- -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
- -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
- -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} \
- -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR} ${myconf} || die
-
- emake sub-tools-all-ordered || die
- if use examples; then
- emake sub-examples-all-ordered || die
- fi
-}
-
-src_install() {
- export PATH="${S}/bin:${PATH}"
- export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
-
- make INSTALL_ROOT=${D} sub-tools-install_subtargets-ordered || die
-
- if use examples; then
- make INSTALL_ROOT=${D} sub-examples-install_subtargets || die
- make INSTALL_ROOT=${D} sub-demos-install_subtargets || die
- fi
-
- make INSTALL_ROOT=${D} install_qmake || die
- make INSTALL_ROOT=${D} install_mkspecs || die
-
- if use doc; then
- make INSTALL_ROOT=${D} install_htmldocs || die
- fi
-
- # The QtAssistant header files aren't installed..not sure why
- #cp -pPR ${S}/include/QtAssistant ${D}/${QTHEADERDIR}/QtAssistant
-
- keepdir "${QTSYSCONFDIR}"
-
- sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.la
- sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
- sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.pc
-
- # Move .pc files into the pkgconfig directory
- dodir ${QTPCDIR}
- mv ${D}/${QTLIBDIR}/*.pc ${D}/${QTPCDIR}
-
- # List all the multilib libdirs
- local libdirs
- for libdir in $(get_all_libdirs); do
- libdirs="${libdirs}:/usr/${libdir}/qt4"
- done
-
- cat > "${T}/44qt4" << EOF
-PATH=${QTBINDIR}
-ROOTPATH=${QTBINDIR}
-LDPATH=${libdirs:1}
-QMAKESPEC=$(qt_mkspecs_dir)
-EOF
- doenvd "${T}/44qt4"
-}