summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gdk-pixbuf/ChangeLog9
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild80
2 files changed, 88 insertions, 1 deletions
diff --git a/x11-libs/gdk-pixbuf/ChangeLog b/x11-libs/gdk-pixbuf/ChangeLog
index 3ed8b7e2f37d..d64cdd4d825b 100644
--- a/x11-libs/gdk-pixbuf/ChangeLog
+++ b/x11-libs/gdk-pixbuf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gdk-pixbuf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.3 2010/11/07 19:11:27 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/ChangeLog,v 1.4 2010/11/08 23:22:59 eva Exp $
+
+*gdk-pixbuf-2.22.1 (09 Nov 2010)
+
+ 09 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +gdk-pixbuf-2.22.1.ebuild:
+ Version bump. Implement GIcon interface, fix loader.cache detection on
+ windows, translation updates.
07 Nov 2010; Jory A. Pratt <anarchy@gentoo.org> gdk-pixbuf-2.22.0.ebuild:
Convert media-libs/jpeg to virtual/jpeg
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild
new file mode 100644
index 000000000000..b9214c6049fc
--- /dev/null
+++ b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gdk-pixbuf/gdk-pixbuf-2.22.1.ebuild,v 1.1 2010/11/08 23:22:59 eva Exp $
+
+EAPI="3"
+
+inherit gnome.org multilib libtool autotools
+
+DESCRIPTION="Image loading library for GTK+"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+X debug doc +introspection jpeg jpeg2k tiff test"
+
+# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
+RDEPEND="
+ >=dev-libs/glib-2.25.15
+ >=media-libs/libpng-1.2.43-r2:0
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ jpeg? ( virtual/jpeg )
+ jpeg2k? ( media-libs/jasper )
+ tiff? ( >=media-libs/tiff-3.9.2 )
+ X? ( x11-libs/libX11 )
+ !<gnome-base/gail-1000
+ !<gnome-base/librsvg-2.31.0
+ !<x11-libs/gtk+-2.21.3:2
+ !<x11-libs/gtk+-2.90.4:3"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=sys-devel/gettext-0.17
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )"
+
+src_prepare() {
+ # Only build against libX11 if the user wants to do so
+ epatch "${FILESDIR}"/${PN}-2.21.4-fix-automagic-x11.patch
+
+ elibtoolize
+ eautoreconf
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="
+ $(use_enable doc gtk-doc)
+ $(use_with jpeg libjpeg)
+ $(use_with jpeg2k libjasper)
+ $(use_with tiff libtiff)
+ $(use_enable introspection)
+ $(use_with X x11)
+ --with-libpng"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS NEWS* README* || die "dodoc failed"
+
+ # New library, remove .la files
+ rm -vf "${D}"/usr/lib*/gdk-pixbuf-2.0/*/loaders/*.la
+}
+
+pkg_postinst() {
+ gdk-pixbuf-query-loaders > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+
+ if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
+ fi
+}