summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog8
-rw-r--r--x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.93
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-0.9.ebuild55
3 files changed, 65 insertions, 1 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index 8a70bd352a22..01375a7708e2 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.22 2006/09/03 14:31:39 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.23 2006/11/14 16:25:23 joshuabaergen Exp $
+
+*xkeyboard-config-0.9 (14 Nov 2006)
+
+ 14 Nov 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xkeyboard-config-0.9.ebuild:
+ Version bump. Thanks to Camille Huot for the poke (bug #155124).
*xkeyboard-config-0.8-r1 (03 Sep 2006)
diff --git a/x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.9 b/x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.9
new file mode 100644
index 000000000000..9c211c67470d
--- /dev/null
+++ b/x11-misc/xkeyboard-config/files/digest-xkeyboard-config-0.9
@@ -0,0 +1,3 @@
+MD5 52afe60101ace8532881e70f6c2dc020 xkeyboard-config-0.9.tar.bz2 471807
+RMD160 2b6e127e0e4728c4c0ea4014bed0f383f80b88a2 xkeyboard-config-0.9.tar.bz2 471807
+SHA256 bb84c40036c4eab0f88bf09951bf36c867d0196988636edfd6efa14d61be777d xkeyboard-config-0.9.tar.bz2 471807
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-0.9.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-0.9.ebuild
new file mode 100644
index 000000000000..e5d4af0524ce
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.9.ebuild,v 1.1 2006/11/14 16:25:23 joshuabaergen Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="X keyboard configuration database"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~x86 ~x86-fbsd"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+SRC_URI="http://xlibs.freedesktop.org/xkbdesc/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="x11-apps/xkbcomp
+ !x11-misc/xkbdata"
+DEPEND="${RDEPEND}
+ dev-perl/XML-Parser"
+
+pkg_setup() {
+ # (#130590) The old XKB directory can screw stuff up
+ local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
+ if [[ -d ${DIR} ]] ; then
+ eerror "Directory ${DIR} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${DIR}"
+ fi
+
+ # The old xkbdata 'pc' directory can screw stuff up, because portage won't
+ # let us overwrite a directory with a file
+ local PC="${ROOT}usr/share/X11/xkb/symbols/pc"
+ if [[ -d ${PC} ]] ; then
+ eerror "Directory ${PC} should be"
+ eerror "manually deleted/renamed/relocated before installing!"
+ die "Manually remove ${PC}"
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-xkb-base=/usr/share/X11/xkb \
+ --enable-compat-rules \
+ --disable-xkbcomp-symlink \
+ --with-xkb-rules-symlink=xorg \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ echo "CONFIG_PROTECT=\"/usr/share/X11/xkb\"" > "${T}"/10xkeyboard-config
+ doenvd "${T}"/10xkeyboard-config
+}