summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog6
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.05_no-MOTIF-WM-INFO.patch38
2 files changed, 43 insertions, 1 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index e9b55ff36f03..76df99a06c8d 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.154 2010/01/27 07:05:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.155 2010/01/29 04:48:10 jer Exp $
+
+ 29 Jan 2010; Jeroen Roovers <jer@gentoo.org>
+ +files/rxvt-unicode-9.05_no-MOTIF-WM-INFO.patch:
+ Reinstate erroneously removed patch thanks to toomore_such (bug #302566).
27 Jan 2010; Jeroen Roovers <jer@gentoo.org> -rxvt-unicode-9.05-r3.ebuild,
-files/rxvt-unicode-9.05_no-MOTIF-WM-INFO.patch,
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.05_no-MOTIF-WM-INFO.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.05_no-MOTIF-WM-INFO.patch
new file mode 100644
index 000000000000..972adbe06836
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.05_no-MOTIF-WM-INFO.patch
@@ -0,0 +1,38 @@
+While setting MWM_HINTS_DECORATIONS to disable window decorations
+seems to work with most window managers, using _MOTIF_WM_INFO seems
+not to, and in some cases can lead to severe problems with focus
+management. Therefore this patch here disables the _MOTIF_WM_INFO
+check and always attempts to have the window manager honour the
+decorations hint.
+
+If your window manager does not honour MWM_HINTS_DECORATIONS, and you
+are determined that you want to have borderless windows nevertheless,
+you are still free to enable override-redirect manually, using the
+corresponding command line option or X resource.
+
+See also: http://bugs.gentoo.org/show_bug.cgi?id=237271
+2008-09-10 Martin von Gagern
+
+Index: src/init.C
+===================================================================
+RCS file: /schmorpforge/rxvt-unicode/src/init.C,v
+retrieving revision 1.253
+diff -u -r1.253 init.C
+--- src/init.C 15 Jul 2008 16:41:22 -0000 1.253
++++ src/init.C 10 Sep 2008 08:07:09 -0000
+@@ -1078,15 +1078,7 @@
+ #if ENABLE_FRILLS
+ if (option (Opt_borderLess))
+ {
+- if (XInternAtom (dpy, "_MOTIF_WM_INFO", True) == None)
+- {
+- // rxvt_warn("Window Manager does not support MWM hints. Bypassing window manager control for borderless window.\n");
+- attributes.override_redirect = true;
+- }
+- else
+- {
+ mwmhints.flags = MWM_HINTS_DECORATIONS;
+- }
+ }
+ #endif
+