summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/aewm++')
-rw-r--r--x11-wm/aewm++/ChangeLog7
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5.ebuild20
2 files changed, 14 insertions, 13 deletions
diff --git a/x11-wm/aewm++/ChangeLog b/x11-wm/aewm++/ChangeLog
index aabae50bffe3..8db70c627f8a 100644
--- a/x11-wm/aewm++/ChangeLog
+++ b/x11-wm/aewm++/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/aewm++
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/ChangeLog,v 1.17 2008/11/20 17:48:35 dertobi123 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/ChangeLog,v 1.18 2010/06/06 20:12:20 ssuominen Exp $
+
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> aewm++-1.1.5.ebuild:
+ Fix HOMEPAGE wrt #239223 by Paweł Szubert.
20 Nov 2008; Tobias Scherbaum <dertobi123@gentoo.org> aewm++-1.1.5.ebuild:
ppc stable, bug #245248
diff --git a/x11-wm/aewm++/aewm++-1.1.5.ebuild b/x11-wm/aewm++/aewm++-1.1.5.ebuild
index 37f3833eac75..8253c9ee9f05 100644
--- a/x11-wm/aewm++/aewm++-1.1.5.ebuild
+++ b/x11-wm/aewm++/aewm++-1.1.5.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/aewm++-1.1.5.ebuild,v 1.3 2008/11/20 17:48:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++/aewm++-1.1.5.ebuild,v 1.4 2010/06/06 20:12:20 ssuominen Exp $
+EAPI=2
inherit eutils toolchain-funcs
DESCRIPTION="A window manager with more modern features than aewm but with the same look and feel."
-HOMEPAGE="http://frankhale.org"
-SRC_URI="http://frankhale.org/${P}.tar.gz"
+HOMEPAGE="http://github.com/frankhale/aewmpp"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -19,20 +20,17 @@ DEPEND="${RDEPEND}
x11-proto/xextproto
x11-proto/xproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch
- sed -i -e "s:install -s:install:" Makefile \
- || die "sed failed."
+ sed -i -e "s:install -s:install:" Makefile || die
}
src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" LDPATH="" \
- ADDITIONAL_CFLAGS="" INCLUDES="" || die "emake failed."
+ ADDITIONAL_CFLAGS="" INCLUDES="" || die
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die
dodoc ChangeLog README
}