From fe46accb8f7952c81b33710b13a1947b9cb7f177 Mon Sep 17 00:00:00 2001
From: Tim Yamin <plasmaroo@gentoo.org>
Date: Wed, 18 Feb 2004 14:46:29 +0000
Subject: Version bump.

---
 dev-lang/mosml/ChangeLog               |  9 +++++++--
 dev-lang/mosml/files/digest-mosml-2.00 |  1 -
 dev-lang/mosml/files/digest-mosml-2.01 |  1 +
 dev-lang/mosml/mosml-2.00.ebuild       | 35 ----------------------------------
 dev-lang/mosml/mosml-2.01.ebuild       | 35 ++++++++++++++++++++++++++++++++++
 5 files changed, 43 insertions(+), 38 deletions(-)
 delete mode 100644 dev-lang/mosml/files/digest-mosml-2.00
 create mode 100644 dev-lang/mosml/files/digest-mosml-2.01
 delete mode 100644 dev-lang/mosml/mosml-2.00.ebuild
 create mode 100644 dev-lang/mosml/mosml-2.01.ebuild

diff --git a/dev-lang/mosml/ChangeLog b/dev-lang/mosml/ChangeLog
index 3cb0b7d138dc..e791761938ca 100644
--- a/dev-lang/mosml/ChangeLog
+++ b/dev-lang/mosml/ChangeLog
@@ -1,6 +1,11 @@
 # ChangeLog for dev-lang/mosml
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/ChangeLog,v 1.1 2003/11/13 21:31:40 plasmaroo Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/ChangeLog,v 1.2 2004/02/18 14:46:29 plasmaroo Exp $
+
+*mosml-2.01 (18 Feb 2004)
+
+  18 Feb 2004; <plasmaroo@gentoo.org> mosml-2.01.ebuild:
+  Version bump; closes bug #41560.
 
 *mosml-2.00 (13 Nov 2003)
 
diff --git a/dev-lang/mosml/files/digest-mosml-2.00 b/dev-lang/mosml/files/digest-mosml-2.00
deleted file mode 100644
index 62aa1a3fb4d1..000000000000
--- a/dev-lang/mosml/files/digest-mosml-2.00
+++ /dev/null
@@ -1 +0,0 @@
-MD5 b18f8022a06442f84c8dbfa47067ce07 mos20src.tar.gz 2308637
diff --git a/dev-lang/mosml/files/digest-mosml-2.01 b/dev-lang/mosml/files/digest-mosml-2.01
new file mode 100644
index 000000000000..8247bad7fbb5
--- /dev/null
+++ b/dev-lang/mosml/files/digest-mosml-2.01
@@ -0,0 +1 @@
+MD5 74aaaf988201fe92a9dbfbcb1e646f70 mos201src.tar.gz 2314392
diff --git a/dev-lang/mosml/mosml-2.00.ebuild b/dev-lang/mosml/mosml-2.00.ebuild
deleted file mode 100644
index 5e7b07e883cf..000000000000
--- a/dev-lang/mosml/mosml-2.00.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.00.ebuild,v 1.3 2004/02/02 18:06:54 plasmaroo Exp $
-
-S="${WORKDIR}/${PN}/src"
-DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
-SRC_URI="http://www.dina.kvl.dk/~sestoft/mosml/mos20src.tar.gz"
-HOMEPAGE="http://www.dina.dk/~sestoft/mosml.html"
-LICENSE="GPL-2"
-DEPEND=""
-KEYWORDS="x86"
-SLOT="0"
-
-src_compile() {
-
-	emake MOSMLHOME=/opt/mosml world || die
-
-}
-
-src_install () {
-
-	make MOSMLHOME=${D}/opt/mosml install || die
-	rm ${D}/opt/mosml/lib/camlrunm # This is a bad symlink
-	echo "#!/opt/mosml/bin/camlrunm" > ${D}/opt/mosml/lib/header
-
-	dodoc  ../README
-	into   /usr/bin
-	dosym  /opt/mosml/bin/mosml     /usr/bin/mosml
-	dosym  /opt/mosml/bin/mosmlc    /usr/bin/mosmlc
-	dosym  /opt/mosml/bin/mosmllex  /usr/bin/mosmllex
-	dosym  /opt/mosml/bin/mosmlyac  /usr/bin/mosmlyac
-	dosym  /opt/mosml/bin/camlrunm  /usr/bin/camlrunm
-	dosym  /opt/mosml/bin/camlrunm  /opt/mosml/lib/camlrunm
-
-}
diff --git a/dev-lang/mosml/mosml-2.01.ebuild b/dev-lang/mosml/mosml-2.01.ebuild
new file mode 100644
index 000000000000..40a4d63aad51
--- /dev/null
+++ b/dev-lang/mosml/mosml-2.01.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.1 2004/02/18 14:46:29 plasmaroo Exp $
+
+S="${WORKDIR}/${PN}/src"
+DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
+SRC_URI="http://www.dina.kvl.dk/~sestoft/mosml/mos201src.tar.gz"
+HOMEPAGE="http://www.dina.dk/~sestoft/mosml.html"
+LICENSE="GPL-2"
+DEPEND=""
+KEYWORDS="~x86"
+SLOT="0"
+
+src_compile() {
+
+	emake MOSMLHOME=/opt/mosml world || die
+
+}
+
+src_install () {
+
+	make MOSMLHOME=${D}/opt/mosml install || die
+	rm ${D}/opt/mosml/lib/camlrunm # This is a bad symlink
+	echo "#!/opt/mosml/bin/camlrunm" > ${D}/opt/mosml/lib/header
+
+	dodoc  ../README
+	into   /usr/bin
+	dosym  /opt/mosml/bin/mosml     /usr/bin/mosml
+	dosym  /opt/mosml/bin/mosmlc    /usr/bin/mosmlc
+	dosym  /opt/mosml/bin/mosmllex  /usr/bin/mosmllex
+	dosym  /opt/mosml/bin/mosmlyac  /usr/bin/mosmlyac
+	dosym  /opt/mosml/bin/camlrunm  /usr/bin/camlrunm
+	dosym  /opt/mosml/bin/camlrunm  /opt/mosml/lib/camlrunm
+
+}
-- 
cgit v1.2.3-65-gdbad