From 24ca2a17bac0a3590ee951c16c4942b6b8fce493 Mon Sep 17 00:00:00 2001
From: Michael Sterrett <mr_bones_@gentoo.org>
Date: Mon, 23 Feb 2004 17:59:02 +0000
Subject: filter-flags in src_compile

---
 app-text/ptex/ChangeLog            | 8 ++++++--
 app-text/ptex/ptex-3.1.2-r1.ebuild | 5 +++--
 app-text/ptex/ptex-3.1.2.ebuild    | 5 ++---
 3 files changed, 11 insertions(+), 7 deletions(-)

(limited to 'app-text/ptex')

diff --git a/app-text/ptex/ChangeLog b/app-text/ptex/ChangeLog
index 28c7f0995f18..fde1847e7483 100644
--- a/app-text/ptex/ChangeLog
+++ b/app-text/ptex/ChangeLog
@@ -1,6 +1,10 @@
 # ChangeLog for app-text/ptex
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ChangeLog,v 1.8 2003/12/22 15:46:47 usata Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ChangeLog,v 1.9 2004/02/23 17:59:02 mr_bones_ Exp $
+
+  23 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> ptex-3.1.2-r1.ebuild,
+  ptex-3.1.2.ebuild:
+  filter-flags in src_compile
 
   23 Dec 2003; Mamoru KOMACHI <usata@gentoo.org> ptex-3.1.2-r1.ebuild,
   ptex-3.1.3.ebuild:
diff --git a/app-text/ptex/ptex-3.1.2-r1.ebuild b/app-text/ptex/ptex-3.1.2-r1.ebuild
index 75f0351a9407..e9d61bf08c81 100644
--- a/app-text/ptex/ptex-3.1.2-r1.ebuild
+++ b/app-text/ptex/ptex-3.1.2-r1.ebuild
@@ -1,9 +1,8 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.2-r1.ebuild,v 1.8 2004/02/23 17:56:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.2-r1.ebuild,v 1.9 2004/02/23 17:59:02 mr_bones_ Exp $
 
 inherit eutils flag-o-matic
-filter-flags "-fstack-protector"
 
 IUSE="X"
 
@@ -70,6 +69,8 @@ src_unpack() {
 
 src_compile() {
 
+	filter-flags "-fstack-protector"
+
 	einfo "Building teTeX"
 
 	econf	--bindir=/usr/bin \
diff --git a/app-text/ptex/ptex-3.1.2.ebuild b/app-text/ptex/ptex-3.1.2.ebuild
index d37eb407fe63..268f840e7b22 100644
--- a/app-text/ptex/ptex-3.1.2.ebuild
+++ b/app-text/ptex/ptex-3.1.2.ebuild
@@ -1,9 +1,8 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.2.ebuild,v 1.8 2004/02/23 17:56:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ptex/ptex-3.1.2.ebuild,v 1.9 2004/02/23 17:59:02 mr_bones_ Exp $
 
 inherit eutils flag-o-matic
-filter-flags "-fstack-protector"
 
 IUSE="cjk ncurses X libwww png"
 
@@ -71,7 +70,6 @@ src_unpack() {
 }
 
 src_compile() {
-
 	local myconf=""
 	use X \
 		&& myconf="--with-x" \
@@ -88,6 +86,7 @@ src_compile() {
 	use ncurses \
 		&& myconf="${myconf} --with-system-ncurses"
 
+	filter-flags "-fstack-protector"
 
 	# Does it make sense to compile the included libwww with mysql ?
 
-- 
cgit v1.2.3-65-gdbad