From 4709c8b7f1287570b10e2e1fa9631fa7262212be Mon Sep 17 00:00:00 2001
From: Tim Harder <radhermit@gentoo.org>
Date: Mon, 5 Dec 2011 22:09:01 +0000
Subject: Version bump.

(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
---
 dev-embedded/msp430mcu/ChangeLog                   |  8 +++++++-
 .../files/msp430mcu-20111205-install.patch         | 17 +++++++++++++++
 dev-embedded/msp430mcu/msp430mcu-20111205.ebuild   | 24 ++++++++++++++++++++++
 3 files changed, 48 insertions(+), 1 deletion(-)
 create mode 100644 dev-embedded/msp430mcu/files/msp430mcu-20111205-install.patch
 create mode 100644 dev-embedded/msp430mcu/msp430mcu-20111205.ebuild

(limited to 'dev-embedded')

diff --git a/dev-embedded/msp430mcu/ChangeLog b/dev-embedded/msp430mcu/ChangeLog
index 9b76f7ac458a..775288eec68d 100644
--- a/dev-embedded/msp430mcu/ChangeLog
+++ b/dev-embedded/msp430mcu/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for dev-embedded/msp430mcu
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/ChangeLog,v 1.2 2011/11/18 06:59:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/ChangeLog,v 1.3 2011/12/05 22:09:01 radhermit Exp $
+
+*msp430mcu-20111205 (05 Dec 2011)
+
+  05 Dec 2011; Tim Harder <radhermit@gentoo.org> +msp430mcu-20111205.ebuild,
+  +files/msp430mcu-20111205-install.patch:
+  Version bump.
 
 *msp430mcu-20111107 (18 Nov 2011)
 
diff --git a/dev-embedded/msp430mcu/files/msp430mcu-20111205-install.patch b/dev-embedded/msp430mcu/files/msp430mcu-20111205-install.patch
new file mode 100644
index 000000000000..b2cc6460cddf
--- /dev/null
+++ b/dev-embedded/msp430mcu/files/msp430mcu-20111205-install.patch
@@ -0,0 +1,17 @@
+--- msp430mcu-20111205/scripts/install.sh.orig
++++ msp430mcu-20111205/scripts/install.sh
+@@ -32,14 +32,3 @@
+ # Install MCU-specific memory and periph maps
+ cp -pr ${ANALYSIS}/ldscripts ${LIBPATH}
+ chmod -R og+rX ${LIBPATH}/ldscripts
+-
+-# Install utility that tells where everything got installed
+-cat bin/msp430mcu-config.in \
+-| sed \
+-    -e 's!@PREFIX@!'"${PREFIX}"'!g' \
+-    -e 's!@SCRIPTPATH@!'"${LIBPATH}/ldscripts"'!g' \
+-    -e 's!@INCPATH@!'"${INCPATH}"'!g' \
+-    -e 's!@VERSION@!'"${VERSION}"'!g' \
+-    -e 's!@UPSTREAM_VERSION@!'"${UPSTREAM_VERSION}"'!g' \
+-> ${BINPATH}/msp430mcu-config \
+-&& chmod 0755 ${BINPATH}/msp430mcu-config
diff --git a/dev-embedded/msp430mcu/msp430mcu-20111205.ebuild b/dev-embedded/msp430mcu/msp430mcu-20111205.ebuild
new file mode 100644
index 000000000000..1285977c22ac
--- /dev/null
+++ b/dev-embedded/msp430mcu/msp430mcu-20111205.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/msp430mcu-20111205.ebuild,v 1.1 2011/12/05 22:09:01 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="MCU-specific data for MSP430 microcontrollers"
+HOMEPAGE="http://mspgcc.sourceforge.net"
+SRC_URI="mirror://sourceforge/mspgcc/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+	epatch "${FILESDIR}"/${P}-install.patch
+}
+
+src_install() {
+	MSP430MCU_ROOT="${S}" ./scripts/install.sh "${D}/usr"
+}
-- 
cgit v1.2.3-65-gdbad