From 2b2393802dd6efc97174f1ef527d678a17b40d0c Mon Sep 17 00:00:00 2001
From: Michael Sterrett <mr_bones_@gentoo.org>
Date: Tue, 12 Feb 2008 17:56:45 +0000
Subject: old (Portage version: 2.1.3.19)

---
 games-board/crafty/crafty-20.14.ebuild | 79 ------------------------------
 games-board/crafty/crafty-21.6.ebuild  | 87 ----------------------------------
 2 files changed, 166 deletions(-)
 delete mode 100644 games-board/crafty/crafty-20.14.ebuild
 delete mode 100644 games-board/crafty/crafty-21.6.ebuild

(limited to 'games-board/crafty')

diff --git a/games-board/crafty/crafty-20.14.ebuild b/games-board/crafty/crafty-20.14.ebuild
deleted file mode 100644
index 515344d4461a..000000000000
--- a/games-board/crafty/crafty-20.14.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-20.14.ebuild,v 1.3 2007/03/12 13:44:57 genone Exp $
-
-inherit flag-o-matic games
-
-DESCRIPTION="Bob Hyatt's strong chess engine"
-HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
-SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
-
-LICENSE="crafty"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="icc no-opts"
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-	app-arch/unzip
-	icc? ( >=dev-lang/icc-5.0 )"
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-	sed -i \
-		-e '/-o crafty/s/CC/CXX/' Makefile \
-		|| die "sed failed"
-	sed -i \
-		-e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
-		|| die "sed failed"
-}
-
-src_compile() {
-	local makeopts="target=LINUX"
-
-	if ! use no-opts ; then
-		if use icc ; then
-			makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
-			append-flags -D_REENTRANT -tpp6 \
-				-DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-				-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
-				-DSMP -DCPUS=4 -DCLONE -DDGT
-			append-flags -O2 -fno-alias -fforce-mem \
-				-fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
-		else
-			if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
-			|| [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
-				append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-					-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
-					-DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
-				append-flags -fforce-mem -fno-gcse \
-					-fomit-frame-pointer -mpreferred-stack-boundary=2
-				makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
-			else
-				: # everything else :)
-			fi
-		fi
-	fi
-	append-flags -DPOSIX
-	emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
-}
-
-src_install() {
-	dogamesbin crafty || die "dogamesbin failed"
-	insinto "${GAMES_DATADIR}/${PN}"
-	doins crafty.hlp || die "doins failed"
-	prepgamesdirs
-}
-
-pkg_postinst() {
-	games_pkg_postinst
-	elog
-	elog "Note: No books or tablebases have been installed. If you want them, just"
-	elog "      download them from ${HOMEPAGE}."
-	elog "      You will find documentation there too. In most cases you take now "
-	elog "      your xboard compatible application, (xboard, eboard, knights) and "
-	elog "      just play chess against computer opponent. Have fun."
-	elog
-}
diff --git a/games-board/crafty/crafty-21.6.ebuild b/games-board/crafty/crafty-21.6.ebuild
deleted file mode 100644
index 779780ae428a..000000000000
--- a/games-board/crafty/crafty-21.6.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-21.6.ebuild,v 1.2 2007/12/09 10:25:17 tupone Exp $
-
-inherit flag-o-matic games
-
-DESCRIPTION="Bob Hyatt's strong chess engine"
-HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
-SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
-
-LICENSE="crafty"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="icc no-opts"
-RESTRICT="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-	app-arch/unzip
-	icc? ( >=dev-lang/icc-5.0 )"
-
-src_unpack() {
-	unpack ${A}
-	cd "${S}"
-	sed -i \
-		-e '/-o crafty/s/CC/CXX/' \
-		-e 's:CXFLAGS:CXXFLAGS:g' \
-		Makefile \
-		|| die "sed failed"
-	sed -i \
-		-e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
-		|| die "sed failed"
-}
-
-src_compile() {
-	local makeopts="target=LINUX"
-
-	if ! use no-opts ; then
-		if use icc ; then
-			makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
-			append-flags -D_REENTRANT -tpp6 \
-				-DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-				-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
-				-DSMP -DCPUS=4 -DCLONE -DDGT
-			append-flags -O2 -fno-alias -fforce-mem \
-				-fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
-		else
-			if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
-			|| [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
-				append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-					-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
-					-DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
-				append-flags -fno-gcse \
-					-fomit-frame-pointer -mpreferred-stack-boundary=2
-				makeopts="${makeopts} CC=gcc CXX=g++"
-			elif [[ "${CHOST}" == "x86_64-pc-linux-gnu" ]] ; then
-				append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-					-DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
-					-DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
-				append-flags -fomit-frame-pointer
-				makeopts="${makeopts} CC=gcc CXX=g++"
-			else
-				: # everything else :)
-			fi
-		fi
-	fi
-	append-flags -DPOSIX
-	emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
-}
-
-src_install() {
-	dogamesbin crafty || die "dogamesbin failed"
-	insinto "${GAMES_DATADIR}/${PN}"
-	doins crafty.hlp || die "doins failed"
-	prepgamesdirs
-}
-
-pkg_postinst() {
-	games_pkg_postinst
-	elog
-	elog "Note: No books or tablebases have been installed. If you want them, just"
-	elog "      download them from ${HOMEPAGE}."
-	elog "      You will find documentation there too. In most cases you take now "
-	elog "      your xboard compatible application, (xboard, eboard, knights) and "
-	elog "      just play chess against computer opponent. Have fun."
-	elog
-}
-- 
cgit v1.2.3-65-gdbad