From 09de86a3f203c13ac64e4a02071c492e4130048f Mon Sep 17 00:00:00 2001
From: Aron Griffis <agriffis@gentoo.org>
Date: Thu, 26 Feb 2004 04:10:37 +0000
Subject: Fix bug #42738 with patch submitted by Jos� Romildo Malaquias
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

---
 net-mail/mutt/ChangeLog                          |  6 ++-
 net-mail/mutt/files/8patch-1.5.6.dyc.source_stat | 61 ++++++++++++++++++++++++
 net-mail/mutt/mutt-1.5.6.ebuild                  |  6 ++-
 3 files changed, 71 insertions(+), 2 deletions(-)
 create mode 100644 net-mail/mutt/files/8patch-1.5.6.dyc.source_stat

(limited to 'net-mail/mutt')

diff --git a/net-mail/mutt/ChangeLog b/net-mail/mutt/ChangeLog
index e594927b577a..b34d499a6885 100644
--- a/net-mail/mutt/ChangeLog
+++ b/net-mail/mutt/ChangeLog
@@ -1,6 +1,10 @@
 # ChangeLog for net-mail/mutt
 # Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.47 2004/02/25 22:09:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/ChangeLog,v 1.48 2004/02/26 04:10:36 agriffis Exp $
+
+  25 Feb 2004; Aron Griffis <agriffis@gentoo.org> mutt-1.5.6.ebuild,
+  files/8patch-1.5.6.dyc.source_stat:
+  Fix bug #42738 with patch submitted by Jos� Romildo Malaquias
 
   25 Feb 2004; Aron Griffis <agriffis@gentoo.org> mutt-1.5.6.ebuild:
   Always apply slang fix, even when USE=vanilla
diff --git a/net-mail/mutt/files/8patch-1.5.6.dyc.source_stat b/net-mail/mutt/files/8patch-1.5.6.dyc.source_stat
new file mode 100644
index 000000000000..da380763263c
--- /dev/null
+++ b/net-mail/mutt/files/8patch-1.5.6.dyc.source_stat
@@ -0,0 +1,61 @@
+? mutt/build
+? mutt/stamp-h1
+Index: mutt/init.c
+===================================================================
+RCS file: /home/roessler/cvs/mutt/init.c,v
+retrieving revision 3.19
+diff -u -r3.19 init.c
+--- mutt/init.c	1 Feb 2004 18:00:16 -0000	3.19
++++ mutt/init.c	6 Feb 2004 20:29:08 -0000
+@@ -1368,18 +1368,6 @@
+   char *linebuf = NULL;
+   size_t buflen;
+   pid_t pid;
+-  struct stat s;
+-
+-  if (stat (rcfile, &s) < 0)
+-  {
+-    snprintf (err->data, err->dsize, _("%s: stat: %s"), rcfile, strerror (errno));
+-    return (-1);
+-  }
+-  if (!S_ISREG (s.st_mode))
+-  {
+-    snprintf (err->data, err->dsize, _("%s: not a regular file"), rcfile);
+-    return (-1);
+-  }
+ 
+   if ((f = mutt_open_read (rcfile, &pid)) == NULL)
+   {
+Index: mutt/muttlib.c
+===================================================================
+RCS file: /home/roessler/cvs/mutt/muttlib.c,v
+retrieving revision 3.18
+diff -u -r3.18 muttlib.c
+--- mutt/muttlib.c	1 Feb 2004 17:10:43 -0000	3.18
++++ mutt/muttlib.c	6 Feb 2004 20:29:09 -0000
+@@ -1134,6 +1134,8 @@
+ FILE *mutt_open_read (const char *path, pid_t *thepid)
+ {
+   FILE *f;
++  struct stat s;
++
+   int len = mutt_strlen (path);
+ 
+   if (path[len - 1] == '|')
+@@ -1149,6 +1151,16 @@
+   }
+   else
+   {
++    if (stat (path, &s) < 0)
++    {
++      mutt_error (_("%s: stat: %s"), path, strerror (errno));
++      return (NULL);
++    }
++    if (!S_ISREG (s.st_mode))
++    {
++      mutt_error (_("%s: not a regular file"), path);
++      return (NULL);
++    }
+     f = fopen (path, "r");
+     *thepid = -1;
+   }
diff --git a/net-mail/mutt/mutt-1.5.6.ebuild b/net-mail/mutt/mutt-1.5.6.ebuild
index 5013c9a48921..8820f7813821 100644
--- a/net-mail/mutt/mutt-1.5.6.ebuild
+++ b/net-mail/mutt/mutt-1.5.6.ebuild
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.5.6.ebuild,v 1.5 2004/02/25 22:09:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mutt/mutt-1.5.6.ebuild,v 1.6 2004/02/26 04:10:36 agriffis Exp $
 
 IUSE="ssl nls slang crypt imap mbox nntp vanilla"
 
@@ -65,6 +65,10 @@ src_unpack() {
 
 	# Fix a slang problem that is already fixed in upstream cvs
 	epatch ${FILESDIR}/slang.patch
+
+	# Fix ability to read from a subprocess with source script.sh|
+	# Bug #42738 (25 Feb 2004 agriffis)
+	epatch ${FILESDIR}/8patch-1.5.6.dyc.source_stat
 }
 
 src_compile() {
-- 
cgit v1.2.3-65-gdbad