From 5e51097d39a11b7821bb1880703b328622f359ae Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Mon, 20 Oct 2008 04:25:04 +0000
Subject: Bug #241970: version bump - Lots of changes in CJK code. (Portage
 version: 2.2_rc12/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)

---
 net-misc/suite3270/ChangeLog              |  8 ++-
 net-misc/suite3270/suite3270-3.3.8.ebuild | 82 +++++++++++++++++++++++++++++++
 2 files changed, 89 insertions(+), 1 deletion(-)
 create mode 100644 net-misc/suite3270/suite3270-3.3.8.ebuild

(limited to 'net-misc/suite3270')

diff --git a/net-misc/suite3270/ChangeLog b/net-misc/suite3270/ChangeLog
index c82af0d625a6..ae1ee574fc32 100644
--- a/net-misc/suite3270/ChangeLog
+++ b/net-misc/suite3270/ChangeLog
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/suite3270
 # Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.27 2008/10/12 15:58:51 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/ChangeLog,v 1.28 2008/10/20 04:25:04 robbat2 Exp $
+
+*suite3270-3.3.8 (20 Oct 2008)
+
+  20 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+  +suite3270-3.3.8.ebuild:
+  Bug #241970: version bump - Lots of changes in CJK code.
 
   12 Oct 2008; Friedrich Oslage <bluebird@gentoo.org>
   suite3270-3.3.7_p5.ebuild:
diff --git a/net-misc/suite3270/suite3270-3.3.8.ebuild b/net-misc/suite3270/suite3270-3.3.8.ebuild
new file mode 100644
index 000000000000..98cb22f07f1a
--- /dev/null
+++ b/net-misc/suite3270/suite3270-3.3.8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/suite3270/suite3270-3.3.8.ebuild,v 1.1 2008/10/20 04:25:04 robbat2 Exp $
+
+inherit eutils
+
+IUSE="cjk doc ncurses ssl tcl X"
+
+S="${WORKDIR}"
+DESCRIPTION="Complete 3270 access package"
+SRC_URI="http://x3270.bgp.nu/download/${PN}-${PV/_/}.tgz"
+HOMEPAGE="http://www.geocities.com/SiliconValley/Peaks/7814/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+
+RDEPEND="X? ( x11-libs/libX11
+			  x11-libs/libXaw
+			  x11-libs/libXmu
+			  x11-libs/libXt )
+		 ncurses? ( sys-libs/ncurses
+					sys-libs/readline )
+		 ssl? ( dev-libs/openssl )
+		 tcl? ( dev-lang/tcl )"
+
+DEPEND="${RDEPEND}
+		X? ( x11-misc/imake
+			 x11-misc/xbitmaps
+			 x11-proto/xproto
+			 app-text/rman
+			 x11-apps/mkfontdir
+			 x11-apps/bdftopcf )"
+
+SUB_PV="3.3"
+MY_FONTDIR="/usr/share/fonts/x3270"
+
+suite3270_makelist() {
+	MY_PLIST="pr3287 s3270"
+	use ncurses && MY_PLIST="${MY_PLIST} c3270"
+	use tcl && MY_PLIST="${MY_PLIST} tcl3270"
+	use X && MY_PLIST="${MY_PLIST} x3270"
+}
+
+src_compile() {
+	local myconf
+
+	myconf="--without-pr3287"
+	myconf="${myconf} --cache-file=${S}/config.cache"
+	myconf="${myconf} $(use_enable cjk dbcs)"
+	myconf="${myconf} $(use_enable ssl)"
+	myconf="${myconf} $(use_with X x)"
+	myconf="${myconf} $(use_with X fontdir ${MY_FONTDIR})"
+
+	suite3270_makelist
+	for p in ${MY_PLIST} ; do
+		cd "${S}/${p}-${SUB_PV}"
+		econf ${myconf} || die "econf failed on ${p}"
+		emake || die "emake faild on ${p}"
+	done
+}
+
+src_install () {
+	suite3270_makelist
+	use X && dodir ${MY_FONTDIR}
+	for p in ${MY_PLIST} ; do
+		cd "${S}/${p}-${SUB_PV}"
+		emake DESTDIR="${D}" install install.man \
+			|| die "emake failed on ${p}"
+		use doc && docinto ${p} && dohtml html/*
+	done
+
+	use X && rm -f "${D}/${MY_FONTDIR}/fonts.dir"
+	return 0
+}
+
+pkg_postinst() {
+	if use X ; then
+		einfo "Running mkfontdir on ${MY_FONTDIR}"
+		mkfontdir ${MY_FONTDIR}
+	fi
+}
-- 
cgit v1.2.3-65-gdbad