summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2011-10-08 12:53:16 +0200
committerThomas Raschbacher <lordvan@gentoo.org>2011-10-08 12:53:16 +0200
commit12deb4c93d11aa9a6f978690e96ee6e958164487 (patch)
treec5865b7b56abaf6374a48b1cca8214971af6d195
parentdigest fix (diff)
downloadlordvan-12deb4c93d11aa9a6f978690e96ee6e958164487.tar.gz
lordvan-12deb4c93d11aa9a6f978690e96ee6e958164487.tar.bz2
lordvan-12deb4c93d11aa9a6f978690e96ee6e958164487.zip
unmasking me-tv 2.0.1
-rw-r--r--media-video/openshot/Manifest2
-rw-r--r--media-video/openshot/openshot-1.2.2.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/media-video/openshot/Manifest b/media-video/openshot/Manifest
new file mode 100644
index 0000000..7db9b57
--- /dev/null
+++ b/media-video/openshot/Manifest
@@ -0,0 +1,2 @@
+DIST openshot-1.2.2.tar.gz 16192987 RMD160 737ca66a7ccf01ee000fc30691d164f1fbee1788 SHA1 6c0098ecb3d8fecc286760be3b37140504a8e6fc SHA256 e61f5b898a163ab90cca00f4c83dcab9570fe43c7c6d420b9e846a24b0aa8cf1
+EBUILD openshot-1.2.2.ebuild 1783 RMD160 08f253e20f4507c1b4367aa5edb119d9d3f4728c SHA1 6eb612759a89d56795b3ddb1943a5fc1e4553982 SHA256 4aa3ed4c6aa28b52ff414e8c735e3f653b468bd14acb5d1654f0e528d6ed2463
diff --git a/media-video/openshot/openshot-1.2.2.ebuild b/media-video/openshot/openshot-1.2.2.ebuild
new file mode 100644
index 0000000..5890700
--- /dev/null
+++ b/media-video/openshot/openshot-1.2.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml"
+
+inherit distutils fdo-mime python
+
+DESCRIPTION="OpenShot Video Editor is a non-linear video editor"
+HOMEPAGE="http://www.openshotvideo.com"
+SRC_URI="http://launchpad.net/openshot/1.2/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dv faac faad flac ieee1394 mp3 ogg quicktime theora vorbis wavpack x264 \
+xvid"
+
+CDEPEND="
+ >=x11-libs/gtk+-2.18
+ dev-python/pygtk
+ dev-python/pygoocanvas
+ dev-python/pyxdg
+ dev-python/librsvg-python"
+
+RDEPEND="${CDEPEND}
+ media-libs/mlt[dv?,ffmpeg,frei0r,gtk,melt,python,quicktime?,sdl,vorbis?,xml]
+ media-sound/sox[encode,ffmpeg,flac?,ogg?,wavpack?]
+ media-video/ffmpeg[encode,faac?,faad?,ieee1394?,mp3?,sdl,theora?,vorbis?,\
+x264?,xvid?]"
+
+DEPEND="${CDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 .
+ distutils_src_prepare
+
+ # Avoid stuff covered by fdo-mime.eclass
+ # (update-mime-database update-desktop-database update-mime)
+ # export "FAKEROOTKEY=gentoo" does not work as this variable is filtered
+ # by portage
+ sed -i -e '/FAILED = /q' setup.py
+}
+
+# TODO: check stuff installed to /usr/lib/python2.6/site-packages as there are
+# some parts installed which shouldn't (locale, themes, profiles effects,
+# etc...) Afaik only python stuff should go there and the rest probably to
+# /usr/share/openshot
+# The same goes for /usr/lib/mime/packages
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}
+