summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-nodejs/through/through-2.3.4.ebuild')
-rw-r--r--dev-nodejs/through/through-2.3.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-nodejs/through/through-2.3.4.ebuild b/dev-nodejs/through/through-2.3.4.ebuild
new file mode 100644
index 0000000..dab1a14
--- /dev/null
+++ b/dev-nodejs/through/through-2.3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+NODEJS_MODULE=${PN}
+
+inherit multilib
+
+DESCRIPTION="Simplified stream contsruction."
+HOMEPAGE="https://npmjs.org/package/through"
+SRC_URI="http://registry.npmjs.org/${PN}/-/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=net-libs/nodejs-0.8.10"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack "${A}"
+ mv "${WORKDIR}/package" ${S}
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ local node_modules="${D}/usr/$(get_libdir)/node_modules/${NODEJS_MODULE}"
+
+ mkdir -p ${node_modules} || die "Could not create DEST folder"
+ cp -r ${S}/{index.js,package.json} ${node_modules}
+
+ dodoc readme* LICENSE*
+}