aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-02-22 20:05:35 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-04-02 14:09:08 +0200
commit5fc5a8eb99d439550b025e5c67f17b849cda62ba (patch)
treea6385cd35ea36b03b147e50d1158578cb74c1f3f
parentARM: Fix ld bloat introduced between binutils-2.38 and 2.39 (diff)
downloadbinutils-gdb-gentoo/binutils-2.39.tar.gz
binutils-gdb-gentoo/binutils-2.39.tar.bz2
binutils-gdb-gentoo/binutils-2.39.zip
Apply a similar libiberty fix as in 7d53105d for libopcodes and libgprofnggentoo/binutils-2.39-6gentoo/binutils-2.39
Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=29042 Bug: https://bugs.gentoo.org/834720 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--gprofng/src/Makefile.am3
-rw-r--r--gprofng/src/Makefile.in3
-rwxr-xr-xopcodes/configure4
-rw-r--r--opcodes/configure.ac4
4 files changed, 8 insertions, 6 deletions
diff --git a/gprofng/src/Makefile.am b/gprofng/src/Makefile.am
index 6e0931524e4..268fad95389 100644
--- a/gprofng/src/Makefile.am
+++ b/gprofng/src/Makefile.am
@@ -131,7 +131,8 @@ libgprofng_la_LDFLAGS = -version-info 0:0:0
# Pass -lpthread instead of $(PTHREAD_LIBS) due to $(PTHREAD_LIBS) being empty
# when -nostdlib is passed to libtool.
# See bug 29364 - libgprofng.so: needs to link against -pthread
-libgprofng_la_LIBADD = $(top_builddir)/../opcodes/libopcodes.la \
+libgprofng_la_LIBADD = $(GPROFNG_LIBADD) \
+ $(top_builddir)/../opcodes/libopcodes.la \
$(top_builddir)/../bfd/libbfd.la \
$(GPROFNG_LIBADD) \
-lpthread -ldl
diff --git a/gprofng/src/Makefile.in b/gprofng/src/Makefile.in
index ba7fdd6e8ad..49ec2179f5e 100644
--- a/gprofng/src/Makefile.in
+++ b/gprofng/src/Makefile.in
@@ -555,7 +555,8 @@ libgprofng_la_LDFLAGS = -version-info 0:0:0
# Pass -lpthread instead of $(PTHREAD_LIBS) due to $(PTHREAD_LIBS) being empty
# when -nostdlib is passed to libtool.
# See bug 29364 - libgprofng.so: needs to link against -pthread
-libgprofng_la_LIBADD = $(top_builddir)/../opcodes/libopcodes.la \
+libgprofng_la_LIBADD = $(GPROFNG_LIBADD) \
+ $(top_builddir)/../opcodes/libopcodes.la \
$(top_builddir)/../bfd/libbfd.la \
$(GPROFNG_LIBADD) \
-lpthread -ldl
diff --git a/opcodes/configure b/opcodes/configure
index db023b48c28..35b4739d279 100755
--- a/opcodes/configure
+++ b/opcodes/configure
@@ -12427,10 +12427,10 @@ if test "$enable_shared" = "yes"; then
case "${host}" in
*-*-cygwin*)
SHARED_LDFLAGS="-no-undefined"
- SHARED_LIBADD="-L`pwd`/../bfd -lbfd -L`pwd`/../libiberty -liberty $SHARED_LIBADD"
+ SHARED_LIBADD="$SHARED_LIBADD -L`pwd`/../bfd -lbfd -L`pwd`/../libiberty -liberty $SHARED_LIBADD"
;;
*)
- SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
+ SHARED_LIBADD="${SHARED_LIBADD} ../bfd/libbfd.la ${SHARED_LIBADD}"
SHARED_DEPENDENCIES="../bfd/libbfd.la"
;;
esac
diff --git a/opcodes/configure.ac b/opcodes/configure.ac
index e998d613436..1fb15291d20 100644
--- a/opcodes/configure.ac
+++ b/opcodes/configure.ac
@@ -193,10 +193,10 @@ if test "$enable_shared" = "yes"; then
case "${host}" in
*-*-cygwin*)
SHARED_LDFLAGS="-no-undefined"
- SHARED_LIBADD="-L`pwd`/../bfd -lbfd -L`pwd`/../libiberty -liberty $SHARED_LIBADD"
+ SHARED_LIBADD="$SHARED_LIBADD -L`pwd`/../bfd -lbfd -L`pwd`/../libiberty -liberty $SHARED_LIBADD"
;;
*)
- SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
+ SHARED_LIBADD="${SHARED_LIBADD} ../bfd/libbfd.la ${SHARED_LIBADD}"
SHARED_DEPENDENCIES="../bfd/libbfd.la"
;;
esac