aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Kwan <dougkwan@google.com>2009-12-06 02:20:53 +0000
committerDoug Kwan <dougkwan@google.com>2009-12-06 02:20:53 +0000
commitf4e5969cc0a9a29070832a4439b3e22d9cd9621b (patch)
tree34057695a07afb36c4845b9f5f3b2ee90e1d9068 /gold/ChangeLog
parent*** empty log message *** (diff)
downloadbinutils-gdb-f4e5969cc0a9a29070832a4439b3e22d9cd9621b.tar.gz
binutils-gdb-f4e5969cc0a9a29070832a4439b3e22d9cd9621b.tar.bz2
binutils-gdb-f4e5969cc0a9a29070832a4439b3e22d9cd9621b.zip
2009-12-05 Doug Kwan <dougkwan@google.com>
* arm.cc: Update comments about interworking and stub generation. (Target_arm::Relocate::reloc_is_non_pic): Update list of relocations considered as non-PIC. (Arm_relocate_functions::base_abs): Fix formatting. (Arm_relocate_functions::got_prel): Fix comment. Change interface of function to use GOT entry address instead of offset. (Target_arm::Scan::global): Issue an error if a symbol would need a PLT does not get one because it is untyped. Remove code to create dynamic symbols for relative branches. (Target_arm::Relocate::relocate: Use 0 instead of false since function takes unsigned integer instead of boolean.
Diffstat (limited to 'gold/ChangeLog')
-rw-r--r--gold/ChangeLog14
1 files changed, 14 insertions, 0 deletions
diff --git a/gold/ChangeLog b/gold/ChangeLog
index 1c0401e3743..9d5883f5aa6 100644
--- a/gold/ChangeLog
+++ b/gold/ChangeLog
@@ -1,3 +1,17 @@
+2009-12-05 Doug Kwan <dougkwan@google.com>
+
+ * arm.cc: Update comments about interworking and stub generation.
+ (Target_arm::Relocate::reloc_is_non_pic): Update list of relocations
+ considered as non-PIC.
+ (Arm_relocate_functions::base_abs): Fix formatting.
+ (Arm_relocate_functions::got_prel): Fix comment. Change interface
+ of function to use GOT entry address instead of offset.
+ (Target_arm::Scan::global): Issue an error if a symbol would need a
+ PLT does not get one because it is untyped. Remove code to create
+ dynamic symbols for relative branches.
+ (Target_arm::Relocate::relocate: Use 0 instead of false since function
+ takes unsigned integer instead of boolean.
+
2009-12-05 H.J. Lu <hongjiu.lu@intel.com>
* testsuite/Makefile.am (constructor_test_LDADD): New. Empty.