aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Mezentsev <vladimir.mezentsev@oracle.com>2022-03-11 08:58:31 +0000
committerNick Clifton <nickc@redhat.com>2022-03-11 08:58:31 +0000
commitbb368aad297fe3ad40cf397e6fc85aa471429a28 (patch)
tree0ab25909b8fe789d676bbdb00d501d4d485e4afe /gprofng/common/cc_libcollector.h
parentAutomatic date update in version.in (diff)
downloadbinutils-gdb-bb368aad297fe3ad40cf397e6fc85aa471429a28.tar.gz
binutils-gdb-bb368aad297fe3ad40cf397e6fc85aa471429a28.tar.bz2
binutils-gdb-bb368aad297fe3ad40cf397e6fc85aa471429a28.zip
gprofng: a new GNU profiler
top-level * Makefile.def: Add gprofng module. * configure.ac: Add --enable-gprofng option. * src-release.sh: Add gprofng. * Makefile.in: Regenerate. * configure: Regenerate. * gprofng: New directory. binutils * MAINTAINERS: Add gprofng maintainer. * README-how-to-make-a-release: Add gprofng. include. * collectorAPI.h: New file. * libcollector.h: New file. * libfcollector.h: New file.
Diffstat (limited to 'gprofng/common/cc_libcollector.h')
-rw-r--r--gprofng/common/cc_libcollector.h44
1 files changed, 44 insertions, 0 deletions
diff --git a/gprofng/common/cc_libcollector.h b/gprofng/common/cc_libcollector.h
new file mode 100644
index 00000000000..e0785418bb3
--- /dev/null
+++ b/gprofng/common/cc_libcollector.h
@@ -0,0 +1,44 @@
+/* Copyright (C) 2021 Free Software Foundation, Inc.
+ Contributed by Oracle.
+
+ This file is part of GNU Binutils.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3, or (at your option)
+ any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, 51 Franklin Street - Fifth Floor, Boston,
+ MA 02110-1301, USA. */
+
+/*
+ * This file describes the enum's, etc. shared by the collector control
+ * class and libcollector and its modules. It is #included in collctrl.h
+ * so any changes to it should follow the procedure described there.
+ */
+
+#ifndef _CC_LIBCOLLECTOR_H
+#define _CC_LIBCOLLECTOR_H
+
+/* definitions for synchronization tracing scope -- a bit mask */
+#define SYNCSCOPE_NATIVE 0x1
+#define SYNCSCOPE_JAVA 0x2
+
+typedef enum
+{
+ FOLLOW_NONE = 0x0,
+ FOLLOW_EXEC = 0x1,
+ FOLLOW_FORK = 0x2,
+ FOLLOW_ON = 0x3,
+ FOLLOW_COMBO = 0x4,
+ FOLLOW_ALL = 0x7
+} Follow_type;
+
+#endif /* !__CC_LIBCOLLECTOR_H */