diff options
author | Roland McGrath <roland@gnu.org> | 1995-11-24 10:00:21 +0000 |
---|---|---|
committer | Roland McGrath <roland@gnu.org> | 1995-11-24 10:00:21 +0000 |
commit | f44820454cd5266a807041bd5e5ae36b4f4f6d84 (patch) | |
tree | 735a61a88221a522e93ee6d4aeac29472cbc81ae | |
parent | Wed Nov 22 12:37:39 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu> (diff) | |
download | glibc-cvs/libc-951125.tar.gz glibc-cvs/libc-951125.tar.bz2 glibc-cvs/libc-951125.zip |
Thu Nov 23 18:26:52 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu>cvs/libc-951126cvs/libc-951125cvs/libc-951124
* configure.in (--enable-libio): Set $stdio based on $enableval,
not always to libio.
Thu Nov 23 18:06:48 1995 Richard Stallman <rms@gnu.ai.mit.edu>
* malloc/malloc.c (_malloc_internal): Can't use
get_contiguous_space when the heap info table
will be growing. Account for new contiguous space in _heaplimit.
-rw-r--r-- | ChangeLog | 11 | ||||
-rw-r--r-- | configure.in | 7 |
2 files changed, 17 insertions, 1 deletions
@@ -1,3 +1,14 @@ +Thu Nov 23 18:26:52 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu> + + * configure.in (--enable-libio): Set $stdio based on $enableval, + not always to libio. + +Thu Nov 23 18:06:48 1995 Richard Stallman <rms@gnu.ai.mit.edu> + + * malloc/malloc.c (_malloc_internal): Can't use + get_contiguous_space when the heap info table + will be growing. Account for new contiguous space in _heaplimit. + Wed Nov 22 12:37:39 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu> * sysdeps/unix/sysv/linux/i386/sysdep.S (_errno): Define as alias diff --git a/configure.in b/configure.in index e35769afb2..891859c0c0 100644 --- a/configure.in +++ b/configure.in @@ -55,7 +55,12 @@ AC_ARG_WITH(weak-symbols, dnl AC_ARG_ENABLE(libio, dnl [ --enable-libio build in GNU libio instead of GNU stdio], - stdio=libio, stdio=default) + [if test $enableval = yes; then + stdio=libio + else + stdio=stdio + fi], + stdio=default) dnl Arguments to enable or disable building the shared, profiled, and dnl -fomit-frame-pointer libraries. |