diff options
author | Roland McGrath <roland@gnu.org> | 1996-05-16 04:32:47 +0000 |
---|---|---|
committer | Roland McGrath <roland@gnu.org> | 1996-05-16 04:32:47 +0000 |
commit | 20c811896c49336ead3c35a4323d4e19a1dffdb1 (patch) | |
tree | 33740a6642a70f2355fbd1df8b3da1b9d51b7ab0 | |
parent | Wed May 15 18:59:38 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu> (diff) | |
download | glibc-cvs/libc-960519.tar.gz glibc-cvs/libc-960519.tar.bz2 glibc-cvs/libc-960519.zip |
Thu May 16 00:31:44 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu>cvs/libc-960520cvs/libc-960519cvs/libc-960518cvs/libc-960517cvs/libc-960516
* Makerules [versioned]: Make symlinks in the build directory, because
the versioned names might be referenced by a DT_NEEDED in another
library.
-rw-r--r-- | ChangeLog | 6 | ||||
-rw-r--r-- | Makerules | 9 |
2 files changed, 15 insertions, 0 deletions
@@ -1,3 +1,9 @@ +Thu May 16 00:31:44 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu> + + * Makerules [versioned]: Make symlinks in the build directory, because + the versioned names might be referenced by a DT_NEEDED in another + library. + Wed May 15 18:59:38 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu> * manual/examples/longopt.c: Include stdlib.h and getopt.h. @@ -601,6 +601,15 @@ endef object-suffixes-left := $(versioned) include $(..)o-iterator.mk +# Make symlinks in the build directory, because the versioned names might +# be referenced by a DT_NEEDED in another library. +define o-iterator-doit +$(objpfx)$o$($o-version): $(objpfx)$o; $$(make-link) +endef +object-suffixes-left := $(versioned) +include $(..)o-iterator.mk + + define o-iterator-doit $(libdir)/$o$($o-version): $(libdir)/$(o:.so=)-$(version).so; $$(make-link) endef |