aboutsummaryrefslogtreecommitdiff
path: root/nptl
diff options
context:
space:
mode:
Diffstat (limited to 'nptl')
-rw-r--r--nptl/Makefile3
-rw-r--r--nptl/Versions2
2 files changed, 2 insertions, 3 deletions
diff --git a/nptl/Makefile b/nptl/Makefile
index fffd9462ff..721030cd30 100644
--- a/nptl/Makefile
+++ b/nptl/Makefile
@@ -47,7 +47,7 @@ pthread-compat-wrappers = \
sendto fsync lseek lseek64 \
msync open open64 pause \
pread pread64 pwrite pwrite64 \
- tcdrain wait waitpid msgrcv msgsnd \
+ tcdrain waitpid msgrcv msgsnd \
sigwait sigsuspend \
recvmsg sendmsg
@@ -206,7 +206,6 @@ CFLAGS-pread.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-pread64.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-pwrite.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-pwrite64.c += -fexceptions -fasynchronous-unwind-tables
-CFLAGS-wait.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-waitpid.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-sigwait.c += -fexceptions -fasynchronous-unwind-tables
CFLAGS-msgrcv.c += -fexceptions -fasynchronous-unwind-tables
diff --git a/nptl/Versions b/nptl/Versions
index 5d6aedb7de..1dda4b9064 100644
--- a/nptl/Versions
+++ b/nptl/Versions
@@ -99,7 +99,7 @@ libpthread {
close; __close; fcntl; __fcntl; read; __read; write; __write; accept;
connect; __connect; recv; recvfrom; recvmsg; send; __send; sendmsg; sendto;
fsync; lseek; __lseek; msync; open; __open; pause; tcdrain;
- system; wait; __wait; waitpid;
+ system; waitpid;
# Hidden entry point (through macros).
_pthread_cleanup_push; _pthread_cleanup_pop;