aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-06-25 22:40:40 +0900
committerMike Gilbert <floppym@gentoo.org>2018-06-27 14:15:29 -0400
commit14bc392a4f1ce9b1c4cf7a3ddfa8a0ff7d1d277e (patch)
tree7c094592cb9dc476c791ced0517d5515b4475b47
parentcore/manager: Make sure jobs statistics are not double after daemon-reload (diff)
downloadsystemd-14bc392a4f1ce9b1c4cf7a3ddfa8a0ff7d1d277e.tar.gz
systemd-14bc392a4f1ce9b1c4cf7a3ddfa8a0ff7d1d277e.tar.bz2
systemd-14bc392a4f1ce9b1c4cf7a3ddfa8a0ff7d1d277e.zip
meson: check whether gnutls supports TCP fast open
Fixes #9403 (cherry picked from commit f02582f69fe1e7663a87ba80bd4f90d5d23ee75f)
-rw-r--r--README1
-rw-r--r--meson.build2
2 files changed, 2 insertions, 1 deletions
diff --git a/README b/README
index 2cde08c37..7d06e0480 100644
--- a/README
+++ b/README
@@ -154,6 +154,7 @@ REQUIREMENTS:
libmicrohttpd (optional)
libpython (optional)
libidn2 or libidn (optional)
+ gnutls >= 3.1.4 (optional, >= 3.5.3 is necessary to support DNS-over-TLS)
elfutils >= 158 (optional)
polkit (optional)
pkg-config
diff --git a/meson.build b/meson.build
index 04331dd41..80f59d77d 100644
--- a/meson.build
+++ b/meson.build
@@ -1137,7 +1137,7 @@ substs.set('DEFAULT_DNSSEC_MODE', default_dnssec)
dns_over_tls = get_option('dns-over-tls')
if dns_over_tls != 'false'
- have = conf.get('HAVE_GNUTLS') == 1
+ have = libgnutls != [] and libgnutls.version().version_compare('>=3.5.3')
if dns_over_tls == 'true' and not have
error('DNS-over-TLS support was requested, but dependencies are not available')
endif