aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-23 18:28:25 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-23 18:28:25 +0000
commita1fc52e19eac74031c8ad5788be050b77d298ed6 (patch)
tree52f3651367e6de1323f458ce875de5a332d281f1
parentfix comment (diff)
downloadautotools-wrappers-a1fc52e19eac74031c8ad5788be050b77d298ed6.tar.gz
autotools-wrappers-a1fc52e19eac74031c8ad5788be050b77d298ed6.tar.bz2
autotools-wrappers-a1fc52e19eac74031c8ad5788be050b77d298ed6.zip
wrapper updates
Firstly I should mention that the perl wrapper 'ac-wrapper.pl', is based on great work by Guillaume Cottenceau (gc@mandrakesoft.com). This updates it to correctly detect if automake-1.6 was used.
-rwxr-xr-xac-wrapper.pl8
1 files changed, 8 insertions, 0 deletions
diff --git a/ac-wrapper.pl b/ac-wrapper.pl
index 9ab8106..29005d2 100755
--- a/ac-wrapper.pl
+++ b/ac-wrapper.pl
@@ -23,6 +23,12 @@
# -or-
# - `configure.in' contains AC_PREREQ and the value's 3 first letters
# are stringwise greater than '2.1'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.1'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs autoconf-2.5x
#
#use MDK::Common;
@@ -37,6 +43,8 @@ if (!$ENV{WANT_AUTOCONF_2_1}) {
&& ($ENV{WANT_AUTOCONF_2_5}
|| -r 'configure.ac'
|| (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
|| (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;