aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-01-21 17:26:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-01-21 17:26:07 +0000
commit50770415a10bdbcaf58f1c534d2bc5693992fd35 (patch)
treee19af8d7f449ff6c5eb683a414dc737e74756195
parentwrapper updates (diff)
downloadautotools-wrappers-50770415a10bdbcaf58f1c534d2bc5693992fd35.tar.gz
autotools-wrappers-50770415a10bdbcaf58f1c534d2bc5693992fd35.tar.bz2
autotools-wrappers-50770415a10bdbcaf58f1c534d2bc5693992fd35.zip
new version
-rwxr-xr-xac-wrapper.pl4
1 files changed, 2 insertions, 2 deletions
diff --git a/ac-wrapper.pl b/ac-wrapper.pl
index 29005d2..7b9bcb7 100755
--- a/ac-wrapper.pl
+++ b/ac-wrapper.pl
@@ -42,10 +42,10 @@ if (!$ENV{WANT_AUTOCONF_2_1}) {
if (-x $binary_new # user may have only 2.13
&& ($ENV{WANT_AUTOCONF_2_5}
|| -r 'configure.ac'
- || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
|| (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
|| (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
- || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;
} else {