aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordlezcano <dlezcano>2008-10-28 22:08:05 +0000
committerdlezcano <dlezcano>2008-10-28 22:08:05 +0000
commitf04d36bf47112a59282fd0ef1e8a0703a7d9e802 (patch)
tree37944bd43ac89ac202bfd7efe7a93f1dbeff6f32
parentAdded a helper to generate the Changelog between two releases (diff)
downloadlxc-f04d36bf47112a59282fd0ef1e8a0703a7d9e802.tar.gz
lxc-f04d36bf47112a59282fd0ef1e8a0703a7d9e802.tar.bz2
lxc-f04d36bf47112a59282fd0ef1e8a0703a7d9e802.zip
Generate a ChangeLog, if possible, and copy it to the dist directory in order
to be shipped with the release
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ab16cb..921a132 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,14 +5,16 @@ DIST_SUBDIRS = config src test etc
EXTRA_DIST = lxc.spec
ChangeLog::
- touch ChangeLog
+ @touch ChangeLog
+
+dist-hook:
+ -@cvs2cl
+ @cp ChangeLog $(distdir)
rpm: dist
rpmbuild --clean -ta ${distdir}.tar.gz
release: rpm
- @echo "Generating ChangeLog"
- @cvs2cl
@sh ./release.sh $(PACKAGE_NAME) \
$(LXC_MAJOR_VERSION) \
$(LXC_MINOR_VERSION) \