aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-02-19 03:00:08 +0100
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2008-02-19 03:00:08 +0100
commit929b11d726ae34c016affc8bff726d84b7f3faa7 (patch)
tree818a583760db35fd1e68039f5b1e71502b3a7c4b
parentIgnore tarballs. (diff)
downloadpambase-929b11d726ae34c016affc8bff726d84b7f3faa7.tar.gz
pambase-929b11d726ae34c016affc8bff726d84b7f3faa7.tar.bz2
pambase-929b11d726ae34c016affc8bff726d84b7f3faa7.zip
Add support for SELinux session.
-rw-r--r--Makefile4
-rw-r--r--system-login.in6
2 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8c9c61f..9472d2c 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,10 @@ ifeq "$(CRACKLIB)" "yes"
PAMFLAGS += -DHAVE_CRACKLIB=1
endif
+ifeq "$(SELINUX)" "yes"
+PAMFLAGS += -DHAVE_SELINUX=1
+endif
+
ifeq "$(DEBUG)" "yes"
PAMFLAGS += -DDEBUG=debug
endif
diff --git a/system-login.in b/system-login.in
index 257c3eb..0ae6ceb 100644
--- a/system-login.in
+++ b/system-login.in
@@ -15,9 +15,15 @@ account required pam_tally.so file=/var/log/faillog onerr=succeed DEBUG
password include system-auth
+#if HAVE_SELINUX
+session required pam_selinux.so close
+#endif
#if HAVE_ENV
session required pam_env.so DEBUG
#endif
session optional pam_lastlog.so DEBUG
session include system-auth
+#if HAVE_SELINUX
+session required pam_selinux.so multiple open
+#endif