aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--system-login.in6
2 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 8c9c61f..9472d2c 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,10 @@ ifeq "$(CRACKLIB)" "yes"
PAMFLAGS += -DHAVE_CRACKLIB=1
endif
+ifeq "$(SELINUX)" "yes"
+PAMFLAGS += -DHAVE_SELINUX=1
+endif
+
ifeq "$(DEBUG)" "yes"
PAMFLAGS += -DDEBUG=debug
endif
diff --git a/system-login.in b/system-login.in
index 257c3eb..0ae6ceb 100644
--- a/system-login.in
+++ b/system-login.in
@@ -15,9 +15,15 @@ account required pam_tally.so file=/var/log/faillog onerr=succeed DEBUG
password include system-auth
+#if HAVE_SELINUX
+session required pam_selinux.so close
+#endif
#if HAVE_ENV
session required pam_env.so DEBUG
#endif
session optional pam_lastlog.so DEBUG
session include system-auth
+#if HAVE_SELINUX
+session required pam_selinux.so multiple open
+#endif