aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2015-02-18 00:25:26 -0500
committerTim Harder <radhermit@gmail.com>2015-02-18 17:03:43 -0500
commit5067fa4c8c1067f99fdbddb02f66586febda6b07 (patch)
tree6fc0fea1046091a01c34a11d9ede64cbd586dfad
parentsetup: return a generator instead of a list for _get_files() (diff)
downloadpkgcore-5067fa4c8c1067f99fdbddb02f66586febda6b07.tar.gz
pkgcore-5067fa4c8c1067f99fdbddb02f66586febda6b07.tar.bz2
pkgcore-5067fa4c8c1067f99fdbddb02f66586febda6b07.zip
install bash files in /usr/lib/pkgcore instead of the python module
We don't need to duplicate these for every version of python we install for especially once py3 support is re-added. Note that there is one python script in the bash directory for dohtml, but it's always had a generic shebang anyway.
-rw-r--r--bash/dont_export_funcs.list (renamed from pkgcore/ebuild/eapi-bash/dont_export_funcs.list)0
-rw-r--r--bash/eapi/0.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/0.lib)0
-rw-r--r--bash/eapi/1.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/1.lib)0
-rw-r--r--bash/eapi/2.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/2.lib)0
-rw-r--r--bash/eapi/3.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/3.lib)0
-rw-r--r--bash/eapi/4.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/4.lib)0
-rw-r--r--bash/eapi/5.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/5.lib)0
-rw-r--r--bash/eapi/common.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/common.lib)0
-rw-r--r--bash/eapi/depend.lib (renamed from pkgcore/ebuild/eapi-bash/eapi/depend.lib)0
-rwxr-xr-xbash/ebuild-daemon.bash (renamed from pkgcore/ebuild/eapi-bash/ebuild-daemon.bash)0
-rw-r--r--bash/ebuild-daemon.lib (renamed from pkgcore/ebuild/eapi-bash/ebuild-daemon.lib)0
-rw-r--r--bash/ebuild-default-functions.lib (renamed from pkgcore/ebuild/eapi-bash/ebuild-default-functions.lib)0
-rw-r--r--bash/ebuild-env-utils.lib (renamed from pkgcore/ebuild/eapi-bash/ebuild-env-utils.lib)0
-rw-r--r--bash/ebuild.lib (renamed from pkgcore/ebuild/eapi-bash/ebuild.lib)0
-rw-r--r--bash/exit-handling.lib (renamed from pkgcore/ebuild/eapi-bash/exit-handling.lib)0
-rwxr-xr-xbash/generate_eapi_func_list.bash (renamed from pkgcore/ebuild/eapi-bash/generate_eapi_func_list.bash)0
-rwxr-xr-xbash/helpers/4/docompress (renamed from pkgcore/ebuild/eapi-bash/helpers/4/docompress)0
l---------bash/helpers/4/dohard (renamed from pkgcore/ebuild/eapi-bash/helpers/4/dohard)0
l---------bash/helpers/4/dosed (renamed from pkgcore/ebuild/eapi-bash/helpers/4/dosed)0
-rwxr-xr-xbash/helpers/5/doheader (renamed from pkgcore/ebuild/eapi-bash/helpers/5/doheader)0
l---------bash/helpers/5/newheader (renamed from pkgcore/ebuild/eapi-bash/helpers/5/newheader)0
-rwxr-xr-xbash/helpers/common/dobin (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dobin)0
-rwxr-xr-xbash/helpers/common/doconfd (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doconfd)0
-rwxr-xr-xbash/helpers/common/dodir (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dodir)0
-rwxr-xr-xbash/helpers/common/dodoc (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dodoc)0
-rwxr-xr-xbash/helpers/common/doenvd (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doenvd)0
-rwxr-xr-xbash/helpers/common/doexe (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doexe)0
-rwxr-xr-xbash/helpers/common/dohard (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dohard)0
-rwxr-xr-xbash/helpers/common/dohtml (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dohtml)0
-rwxr-xr-xbash/helpers/common/doinfo (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doinfo)0
-rwxr-xr-xbash/helpers/common/doinitd (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doinitd)0
-rwxr-xr-xbash/helpers/common/doins (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doins)0
-rwxr-xr-xbash/helpers/common/dolib (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dolib)0
l---------bash/helpers/common/dolib.a (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dolib.a)0
l---------bash/helpers/common/dolib.so (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dolib.so)0
-rwxr-xr-xbash/helpers/common/doman (renamed from pkgcore/ebuild/eapi-bash/helpers/common/doman)0
-rwxr-xr-xbash/helpers/common/domo (renamed from pkgcore/ebuild/eapi-bash/helpers/common/domo)0
l---------bash/helpers/common/dosbin (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dosbin)0
-rwxr-xr-xbash/helpers/common/dosed (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dosed)0
l---------bash/helpers/common/dosym (renamed from pkgcore/ebuild/eapi-bash/helpers/common/dosym)0
-rwxr-xr-xbash/helpers/common/emake (renamed from pkgcore/ebuild/eapi-bash/helpers/common/emake)0
-rwxr-xr-xbash/helpers/common/fowners (renamed from pkgcore/ebuild/eapi-bash/helpers/common/fowners)0
-rwxr-xr-xbash/helpers/common/fperms (renamed from pkgcore/ebuild/eapi-bash/helpers/common/fperms)0
-rwxr-xr-xbash/helpers/common/keepdir (renamed from pkgcore/ebuild/eapi-bash/helpers/common/keepdir)0
l---------bash/helpers/common/newbin (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newbin)0
l---------bash/helpers/common/newconfd (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newconfd)0
l---------bash/helpers/common/newdoc (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newdoc)0
l---------bash/helpers/common/newenvd (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newenvd)0
l---------bash/helpers/common/newexe (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newexe)0
l---------bash/helpers/common/newinitd (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newinitd)0
l---------bash/helpers/common/newins (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newins)0
l---------bash/helpers/common/newlib.a (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newlib.a)0
l---------bash/helpers/common/newlib.so (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newlib.so)0
l---------bash/helpers/common/newman (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newman)0
l---------bash/helpers/common/newsbin (renamed from pkgcore/ebuild/eapi-bash/helpers/common/newsbin)0
-rwxr-xr-xbash/helpers/common/pkgcore-ebuild-helper (renamed from pkgcore/ebuild/eapi-bash/helpers/common/pkgcore-ebuild-helper)0
-rwxr-xr-xbash/helpers/common/prepalldocs (renamed from pkgcore/ebuild/eapi-bash/helpers/common/prepalldocs)0
-rwxr-xr-xbash/helpers/common/prepallstrip (renamed from pkgcore/ebuild/eapi-bash/helpers/common/prepallstrip)0
-rwxr-xr-xbash/helpers/common/prepinfo (renamed from pkgcore/ebuild/eapi-bash/helpers/common/prepinfo)0
-rwxr-xr-xbash/helpers/common/prepman (renamed from pkgcore/ebuild/eapi-bash/helpers/common/prepman)0
-rwxr-xr-xbash/helpers/common/prepstrip (renamed from pkgcore/ebuild/eapi-bash/helpers/common/prepstrip)0
-rwxr-xr-xbash/helpers/internals/_generic_new (renamed from pkgcore/ebuild/eapi-bash/helpers/internals/_generic_new)0
-rwxr-xr-xbash/helpers/internals/_raw_dohtml (renamed from pkgcore/ebuild/eapi-bash/helpers/internals/_raw_dohtml)0
-rwxr-xr-xbash/helpers/internals/banned (renamed from pkgcore/ebuild/eapi-bash/helpers/internals/banned)0
-rwxr-xr-xbash/helpers/internals/deprecated (renamed from pkgcore/ebuild/eapi-bash/helpers/internals/deprecated)0
-rwxr-xr-xbash/helpers/internals/prepall (renamed from pkgcore/ebuild/eapi-bash/helpers/internals/prepall)0
-rwxr-xr-xbash/helpers/internals/prepallman (renamed from pkgcore/ebuild/eapi-bash/helpers/internals/prepallman)0
-rw-r--r--bash/isolated-functions.lib (renamed from pkgcore/ebuild/eapi-bash/isolated-functions.lib)0
-rwxr-xr-xbash/regenerate_dont_export_func_list.bash (renamed from pkgcore/ebuild/eapi-bash/regenerate_dont_export_func_list.bash)0
-rwxr-xr-xbin/pwrapper2
-rw-r--r--pkgcore/ebuild/const.py15
-rw-r--r--setup.py35
72 files changed, 16 insertions, 36 deletions
diff --git a/pkgcore/ebuild/eapi-bash/dont_export_funcs.list b/bash/dont_export_funcs.list
index da5cb11da..da5cb11da 100644
--- a/pkgcore/ebuild/eapi-bash/dont_export_funcs.list
+++ b/bash/dont_export_funcs.list
diff --git a/pkgcore/ebuild/eapi-bash/eapi/0.lib b/bash/eapi/0.lib
index 35ef2ee73..35ef2ee73 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/0.lib
+++ b/bash/eapi/0.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/1.lib b/bash/eapi/1.lib
index 35ef2ee73..35ef2ee73 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/1.lib
+++ b/bash/eapi/1.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/2.lib b/bash/eapi/2.lib
index 1b63af89a..1b63af89a 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/2.lib
+++ b/bash/eapi/2.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/3.lib b/bash/eapi/3.lib
index 7dbc85cc8..7dbc85cc8 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/3.lib
+++ b/bash/eapi/3.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/4.lib b/bash/eapi/4.lib
index 82e344fef..82e344fef 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/4.lib
+++ b/bash/eapi/4.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/5.lib b/bash/eapi/5.lib
index ca3cc35be..ca3cc35be 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/5.lib
+++ b/bash/eapi/5.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/common.lib b/bash/eapi/common.lib
index dd6369ad5..dd6369ad5 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/common.lib
+++ b/bash/eapi/common.lib
diff --git a/pkgcore/ebuild/eapi-bash/eapi/depend.lib b/bash/eapi/depend.lib
index f7870cb11..f7870cb11 100644
--- a/pkgcore/ebuild/eapi-bash/eapi/depend.lib
+++ b/bash/eapi/depend.lib
diff --git a/pkgcore/ebuild/eapi-bash/ebuild-daemon.bash b/bash/ebuild-daemon.bash
index 75e65f78b..75e65f78b 100755
--- a/pkgcore/ebuild/eapi-bash/ebuild-daemon.bash
+++ b/bash/ebuild-daemon.bash
diff --git a/pkgcore/ebuild/eapi-bash/ebuild-daemon.lib b/bash/ebuild-daemon.lib
index f0fa81233..f0fa81233 100644
--- a/pkgcore/ebuild/eapi-bash/ebuild-daemon.lib
+++ b/bash/ebuild-daemon.lib
diff --git a/pkgcore/ebuild/eapi-bash/ebuild-default-functions.lib b/bash/ebuild-default-functions.lib
index 70a0f4735..70a0f4735 100644
--- a/pkgcore/ebuild/eapi-bash/ebuild-default-functions.lib
+++ b/bash/ebuild-default-functions.lib
diff --git a/pkgcore/ebuild/eapi-bash/ebuild-env-utils.lib b/bash/ebuild-env-utils.lib
index d064e1654..d064e1654 100644
--- a/pkgcore/ebuild/eapi-bash/ebuild-env-utils.lib
+++ b/bash/ebuild-env-utils.lib
diff --git a/pkgcore/ebuild/eapi-bash/ebuild.lib b/bash/ebuild.lib
index 724729656..724729656 100644
--- a/pkgcore/ebuild/eapi-bash/ebuild.lib
+++ b/bash/ebuild.lib
diff --git a/pkgcore/ebuild/eapi-bash/exit-handling.lib b/bash/exit-handling.lib
index e2a40fd3b..e2a40fd3b 100644
--- a/pkgcore/ebuild/eapi-bash/exit-handling.lib
+++ b/bash/exit-handling.lib
diff --git a/pkgcore/ebuild/eapi-bash/generate_eapi_func_list.bash b/bash/generate_eapi_func_list.bash
index a5342b5fe..a5342b5fe 100755
--- a/pkgcore/ebuild/eapi-bash/generate_eapi_func_list.bash
+++ b/bash/generate_eapi_func_list.bash
diff --git a/pkgcore/ebuild/eapi-bash/helpers/4/docompress b/bash/helpers/4/docompress
index 3cc710882..3cc710882 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/4/docompress
+++ b/bash/helpers/4/docompress
diff --git a/pkgcore/ebuild/eapi-bash/helpers/4/dohard b/bash/helpers/4/dohard
index 22465e004..22465e004 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/4/dohard
+++ b/bash/helpers/4/dohard
diff --git a/pkgcore/ebuild/eapi-bash/helpers/4/dosed b/bash/helpers/4/dosed
index 22465e004..22465e004 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/4/dosed
+++ b/bash/helpers/4/dosed
diff --git a/pkgcore/ebuild/eapi-bash/helpers/5/doheader b/bash/helpers/5/doheader
index a344f34ff..a344f34ff 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/5/doheader
+++ b/bash/helpers/5/doheader
diff --git a/pkgcore/ebuild/eapi-bash/helpers/5/newheader b/bash/helpers/5/newheader
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/5/newheader
+++ b/bash/helpers/5/newheader
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dobin b/bash/helpers/common/dobin
index 4c974cbb2..4c974cbb2 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dobin
+++ b/bash/helpers/common/dobin
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doconfd b/bash/helpers/common/doconfd
index beca058f4..beca058f4 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doconfd
+++ b/bash/helpers/common/doconfd
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dodir b/bash/helpers/common/dodir
index 6646bcdcc..6646bcdcc 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dodir
+++ b/bash/helpers/common/dodir
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dodoc b/bash/helpers/common/dodoc
index e64adda36..e64adda36 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dodoc
+++ b/bash/helpers/common/dodoc
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doenvd b/bash/helpers/common/doenvd
index ef7590551..ef7590551 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doenvd
+++ b/bash/helpers/common/doenvd
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doexe b/bash/helpers/common/doexe
index 7ea5ebff7..7ea5ebff7 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doexe
+++ b/bash/helpers/common/doexe
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dohard b/bash/helpers/common/dohard
index be567e3b6..be567e3b6 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dohard
+++ b/bash/helpers/common/dohard
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dohtml b/bash/helpers/common/dohtml
index df8a7fc45..df8a7fc45 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dohtml
+++ b/bash/helpers/common/dohtml
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doinfo b/bash/helpers/common/doinfo
index ca4ac8d86..ca4ac8d86 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doinfo
+++ b/bash/helpers/common/doinfo
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doinitd b/bash/helpers/common/doinitd
index 2e969ff03..2e969ff03 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doinitd
+++ b/bash/helpers/common/doinitd
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doins b/bash/helpers/common/doins
index ef4894f11..ef4894f11 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doins
+++ b/bash/helpers/common/doins
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dolib b/bash/helpers/common/dolib
index c88e7429f..c88e7429f 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dolib
+++ b/bash/helpers/common/dolib
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dolib.a b/bash/helpers/common/dolib.a
index c013e45e8..c013e45e8 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dolib.a
+++ b/bash/helpers/common/dolib.a
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dolib.so b/bash/helpers/common/dolib.so
index c013e45e8..c013e45e8 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dolib.so
+++ b/bash/helpers/common/dolib.so
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/doman b/bash/helpers/common/doman
index bc5e1ea26..bc5e1ea26 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/doman
+++ b/bash/helpers/common/doman
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/domo b/bash/helpers/common/domo
index 8f7fc66eb..8f7fc66eb 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/domo
+++ b/bash/helpers/common/domo
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dosbin b/bash/helpers/common/dosbin
index 46bbe6165..46bbe6165 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dosbin
+++ b/bash/helpers/common/dosbin
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dosed b/bash/helpers/common/dosed
index 6e4aaeb98..6e4aaeb98 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dosed
+++ b/bash/helpers/common/dosed
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/dosym b/bash/helpers/common/dosym
index dacdb2f13..dacdb2f13 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/dosym
+++ b/bash/helpers/common/dosym
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/emake b/bash/helpers/common/emake
index ccc568fdd..ccc568fdd 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/emake
+++ b/bash/helpers/common/emake
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/fowners b/bash/helpers/common/fowners
index 011620369..011620369 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/fowners
+++ b/bash/helpers/common/fowners
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/fperms b/bash/helpers/common/fperms
index 8883c9827..8883c9827 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/fperms
+++ b/bash/helpers/common/fperms
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/keepdir b/bash/helpers/common/keepdir
index b1efedfc0..b1efedfc0 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/keepdir
+++ b/bash/helpers/common/keepdir
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newbin b/bash/helpers/common/newbin
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newbin
+++ b/bash/helpers/common/newbin
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newconfd b/bash/helpers/common/newconfd
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newconfd
+++ b/bash/helpers/common/newconfd
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newdoc b/bash/helpers/common/newdoc
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newdoc
+++ b/bash/helpers/common/newdoc
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newenvd b/bash/helpers/common/newenvd
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newenvd
+++ b/bash/helpers/common/newenvd
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newexe b/bash/helpers/common/newexe
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newexe
+++ b/bash/helpers/common/newexe
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newinitd b/bash/helpers/common/newinitd
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newinitd
+++ b/bash/helpers/common/newinitd
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newins b/bash/helpers/common/newins
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newins
+++ b/bash/helpers/common/newins
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newlib.a b/bash/helpers/common/newlib.a
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newlib.a
+++ b/bash/helpers/common/newlib.a
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newlib.so b/bash/helpers/common/newlib.so
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newlib.so
+++ b/bash/helpers/common/newlib.so
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newman b/bash/helpers/common/newman
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newman
+++ b/bash/helpers/common/newman
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/newsbin b/bash/helpers/common/newsbin
index 221e3362d..221e3362d 120000
--- a/pkgcore/ebuild/eapi-bash/helpers/common/newsbin
+++ b/bash/helpers/common/newsbin
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/pkgcore-ebuild-helper b/bash/helpers/common/pkgcore-ebuild-helper
index c0b1b0430..c0b1b0430 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/pkgcore-ebuild-helper
+++ b/bash/helpers/common/pkgcore-ebuild-helper
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/prepalldocs b/bash/helpers/common/prepalldocs
index 5547fd734..5547fd734 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/prepalldocs
+++ b/bash/helpers/common/prepalldocs
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/prepallstrip b/bash/helpers/common/prepallstrip
index 5a0f33535..5a0f33535 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/prepallstrip
+++ b/bash/helpers/common/prepallstrip
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/prepinfo b/bash/helpers/common/prepinfo
index e9ee5802d..e9ee5802d 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/prepinfo
+++ b/bash/helpers/common/prepinfo
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/prepman b/bash/helpers/common/prepman
index 530ca6c22..530ca6c22 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/prepman
+++ b/bash/helpers/common/prepman
diff --git a/pkgcore/ebuild/eapi-bash/helpers/common/prepstrip b/bash/helpers/common/prepstrip
index 0f31e80ed..0f31e80ed 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/common/prepstrip
+++ b/bash/helpers/common/prepstrip
diff --git a/pkgcore/ebuild/eapi-bash/helpers/internals/_generic_new b/bash/helpers/internals/_generic_new
index 8bc3aa6d0..8bc3aa6d0 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/internals/_generic_new
+++ b/bash/helpers/internals/_generic_new
diff --git a/pkgcore/ebuild/eapi-bash/helpers/internals/_raw_dohtml b/bash/helpers/internals/_raw_dohtml
index 1a1ec8ae0..1a1ec8ae0 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/internals/_raw_dohtml
+++ b/bash/helpers/internals/_raw_dohtml
diff --git a/pkgcore/ebuild/eapi-bash/helpers/internals/banned b/bash/helpers/internals/banned
index ddda11767..ddda11767 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/internals/banned
+++ b/bash/helpers/internals/banned
diff --git a/pkgcore/ebuild/eapi-bash/helpers/internals/deprecated b/bash/helpers/internals/deprecated
index dc89b0102..dc89b0102 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/internals/deprecated
+++ b/bash/helpers/internals/deprecated
diff --git a/pkgcore/ebuild/eapi-bash/helpers/internals/prepall b/bash/helpers/internals/prepall
index 5e4e9f285..5e4e9f285 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/internals/prepall
+++ b/bash/helpers/internals/prepall
diff --git a/pkgcore/ebuild/eapi-bash/helpers/internals/prepallman b/bash/helpers/internals/prepallman
index 257498f40..257498f40 100755
--- a/pkgcore/ebuild/eapi-bash/helpers/internals/prepallman
+++ b/bash/helpers/internals/prepallman
diff --git a/pkgcore/ebuild/eapi-bash/isolated-functions.lib b/bash/isolated-functions.lib
index 7e887851f..7e887851f 100644
--- a/pkgcore/ebuild/eapi-bash/isolated-functions.lib
+++ b/bash/isolated-functions.lib
diff --git a/pkgcore/ebuild/eapi-bash/regenerate_dont_export_func_list.bash b/bash/regenerate_dont_export_func_list.bash
index 23a0db913..23a0db913 100755
--- a/pkgcore/ebuild/eapi-bash/regenerate_dont_export_func_list.bash
+++ b/bash/regenerate_dont_export_func_list.bash
diff --git a/bin/pwrapper b/bin/pwrapper
index ecbc3ce76..505611371 100755
--- a/bin/pwrapper
+++ b/bin/pwrapper
@@ -31,6 +31,8 @@ if __name__ == '__main__':
os.environ.update({
'PKGCORE_SCRIPT_PATH': os.path.dirname(os.path.abspath(__file__)),
+ 'PKGCORE_BASH_PATH': os.path.join(
+ os.path.dirname(os.path.dirname(os.path.abspath(__file__))), 'bash'),
'PKGCORE_CONFIG_PATH': os.path.join(
os.path.dirname(os.path.dirname(os.path.abspath(__file__))), 'config'),
})
diff --git a/pkgcore/ebuild/const.py b/pkgcore/ebuild/const.py
index 8791ccb91..41d0ed18c 100644
--- a/pkgcore/ebuild/const.py
+++ b/pkgcore/ebuild/const.py
@@ -4,7 +4,10 @@
"""
ebuild internal constants
"""
-from os import path
+
+import os
+from os.path import join as pjoin
+import sys
incrementals = (
"ACCEPT_KEYWORDS", "ACCEPT_LICENSE", "CONFIG_PROTECT",
@@ -21,10 +24,10 @@ metadata_keys = (
"RDEPEND", "REQUIRED_USE", "RESTRICT", "SLOT", "SRC_URI", "_eclasses_",
)
-WORLD_FILE = '/var/lib/portage/world'
+WORLD_FILE = '/var/lib/portage/world'
-EAPI_BIN_PATH = path.join(path.dirname(path.abspath(__file__)), "eapi-bash")
-EBUILD_DAEMON_PATH = path.join(EAPI_BIN_PATH, "ebuild-daemon.bash")
-EBUILD_HELPERS_PATH = path.join(EAPI_BIN_PATH, "helpers")
+EAPI_BIN_PATH = os.environ.get("PKGCORE_BASH_PATH", pjoin(sys.prefix, 'lib/pkgcore'))
+EBUILD_DAEMON_PATH = pjoin(EAPI_BIN_PATH, "ebuild-daemon.bash")
+EBUILD_HELPERS_PATH = pjoin(EAPI_BIN_PATH, "helpers")
-PKGCORE_DEBUG_VARS = ("PKGCORE_DEBUG", "PKGCORE_PERF_DEBUG")
+PKGCORE_DEBUG_VARS = ("PKGCORE_DEBUG", "PKGCORE_PERF_DEBUG")
diff --git a/setup.py b/setup.py
index 4b9b53879..9d7b35f4e 100644
--- a/setup.py
+++ b/setup.py
@@ -204,6 +204,10 @@ def _get_files(path):
for f in files:
yield os.path.join(root, f)[len(path):].lstrip('/')
+def _get_data_mapping(host_path, path):
+ for x in os.walk(path):
+ yield (os.path.join(host_path, x[0].partition(path)[2].lstrip('/')),
+ map(lambda y: os.path.join(x[0], y), x[2]))
class pkgcore_install_docs(core.Command):
@@ -360,31 +364,6 @@ class pkgcore_build_py(snk_distutils.build_py):
package_namespace = 'pkgcore'
generate_verinfo = True
- def _recursive_chmod_files(self, base):
- for f in os.listdir(base):
- fp = os.path.join(base, f)
- if os.path.isdir(fp):
- self._recursive_chmod_files(fp)
- elif os.path.isfile(fp):
- self.set_chmod(fp)
-
- def _inner_run(self, py3k_rebuilds):
- base = os.path.join(self.build_lib, "pkgcore", "ebuild", "eapi-bash")
- self._recursive_chmod_files(os.path.join(base, "helpers"))
- self.set_chmod(os.path.join(base, "ebuild-daemon.bash"))
- self.set_chmod(os.path.join(base, "generate_eapi_func_list.bash"))
- self.set_chmod(os.path.join(base, "regenerate_dont_export_func_list.bash"))
-
- def set_chmod(self, path):
- if self.dry_run:
- log.info("changing mode of %s", path)
- else:
- # note, we use the int here for python3k compatibility.
- # 365 == 0555, 4095 = 0777
- mode = ((os.stat(path)[ST_MODE]) | 365) & 4095
- log.debug("changing mode of %s to %o", path, mode)
- os.chmod(path, mode)
-
class test(snk_distutils.test):
@@ -460,12 +439,8 @@ core.setup(
author='Brian Harring',
author_email='ferringb@gmail.com',
packages=packages,
- package_data={
- 'pkgcore': ['ebuild/eapi-bash/%s' % (x,) for x in
- _get_files('pkgcore/ebuild/eapi-bash')],
- },
data_files=[
('share/pkgcore/config', glob.glob('config/*')),
- ],
+ ] + list(_get_data_mapping('lib/pkgcore', 'bash')),
ext_modules=extensions, cmdclass=cmdclass, command_options=command_options,
)