aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2021-03-18 19:21:30 -0600
committerTim Harder <radhermit@gmail.com>2021-03-18 19:21:30 -0600
commit31689308d48a8352ca65b59d745fe1898da97726 (patch)
tree71a3d404ff39bc694584df837d5e18331e19c404 /tests
parenttests: verify git rename summary (diff)
downloadpkgdev-31689308d48a8352ca65b59d745fe1898da97726.tar.gz
pkgdev-31689308d48a8352ca65b59d745fe1898da97726.tar.bz2
pkgdev-31689308d48a8352ca65b59d745fe1898da97726.zip
tests: verify revision removal summary
Diffstat (limited to 'tests')
-rw-r--r--tests/scripts/test_pkgdev_commit.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/scripts/test_pkgdev_commit.py b/tests/scripts/test_pkgdev_commit.py
index 98991e8..2e8e1b8 100644
--- a/tests/scripts/test_pkgdev_commit.py
+++ b/tests/scripts/test_pkgdev_commit.py
@@ -441,7 +441,9 @@ class TestPkgdevCommit:
os.remove(pjoin(git_repo.path, 'cat/pkg/Manifest'))
assert commit() == 'cat/pkg: update Manifest'
- # single removal
+ # single removals
+ os.remove(pjoin(git_repo.path, 'cat/pkg/pkg-4-r1.ebuild'))
+ assert commit() == 'cat/pkg: drop 4-r1'
os.remove(pjoin(git_repo.path, 'cat/pkg/pkg-3.ebuild'))
assert commit() == 'cat/pkg: drop 3'