aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorTim Harder <radhermit@gmail.com>2021-03-05 15:19:55 -0700
committerTim Harder <radhermit@gmail.com>2021-03-05 15:29:27 -0700
commitcfec51efcba77b1ee6936239a6d0b1b1ecc9a89f (patch)
treeb295e4e2e8f24903a474420c83316444beaf816f /tests
parenttests: add initial git.run() tests (diff)
downloadpkgdev-cfec51efcba77b1ee6936239a6d0b1b1ecc9a89f.tar.gz
pkgdev-cfec51efcba77b1ee6936239a6d0b1b1ecc9a89f.tar.bz2
pkgdev-cfec51efcba77b1ee6936239a6d0b1b1ecc9a89f.zip
pkgdev commit: use the full atom version for message summaries
Fixes #18.
Diffstat (limited to 'tests')
-rw-r--r--tests/scripts/test_pkgdev_commit.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/scripts/test_pkgdev_commit.py b/tests/scripts/test_pkgdev_commit.py
index de8d6f0..cfe89c5 100644
--- a/tests/scripts/test_pkgdev_commit.py
+++ b/tests/scripts/test_pkgdev_commit.py
@@ -239,8 +239,9 @@ class TestPkgdevCommit:
# multiple bumps
repo.create_ebuild('cat/pkg-2')
+ repo.create_ebuild('cat/pkg-2-r1')
repo.create_ebuild('cat/pkg-3')
- assert commit() == 'cat/pkg: bump 2, 3'
+ assert commit() == 'cat/pkg: bump 2, 2-r1, 3'
# large number of bumps in a single commit
for v in range(10000, 10010):
@@ -252,9 +253,10 @@ class TestPkgdevCommit:
assert commit() == 'cat/pkg: drop 3'
# multiple removal
+ os.remove(pjoin(git_repo.path, 'cat/pkg/pkg-2-r1.ebuild'))
os.remove(pjoin(git_repo.path, 'cat/pkg/pkg-2.ebuild'))
os.remove(pjoin(git_repo.path, 'cat/pkg/pkg-1.ebuild'))
- assert commit() == 'cat/pkg: drop 1, 2'
+ assert commit() == 'cat/pkg: drop 1, 2, 2-r1'
# large number of removals in a single commit
for v in range(10000, 10010):